Diodon fails to start under Natty/Unity 3D

Asked by David Raviv


After upgrading my Ubuntu 10.10 to 11.04 with Unity 3D, Diodon stopped working (no indicator, CTRL+ALT+v doesn't list the clipboard history).
When starting Diodon from the terminal, I get the following:
diodon: error while loading shared libraries: libdbusmenu-glib.so.1: cannot open shared object file: No such file or directory

While searching in Synaptic I've found the following packages installed on my system: libdbusmenu-glib3, gir1.2-dbusmenu-glib-0.4.

I've installed Diodon from the PPA, http://ppa.launchpad.net/diodon-team/stable/ubuntu

Am I missing anything?
I guess it is not a bug as it is very fundamental and there isn't a reported bug for the issue.

Thanks, David.

Question information

English Edit question
Diodon Edit question
No assignee Edit question
Solved by:
Oliver Sauder
Last query:
Last reply:
Revision history for this message
Best Oliver Sauder (sao) said :

libdbusmenu-glib.so.1 is a library only available in maverick but not in natty.

So it seems that you still have the diodon Version of maverick installed (the update process usually does not update the ppas but disables them).

To update diodon to natty as well, you have to run following commands:
sudo add-apt-repository ppa:diodon-team/stable
sudo apt-get update
sudo apt-get dist-upgrade

Hope this helps.

Revision history for this message
David Raviv (davrav) said :

Thanks Oliver Sauder, that solved my question.