fails to connect to camera USB PTP Class Camera tests ok with gphoto2 -P

Asked by wirechief on 2007-05-06

I have a Kodak V570 camera, I have setup digikam to use USB PTP Class Camera the digikam screens says failed to connect to the camera, please make sure it is properly connected and turned on, Would you like to try again. I would like to download the pictures, I have found that using the command gphoto2 -P will download the files, but I would like digikam to do that.

Question information

Language:
English Edit question
Status:
Solved
For:
digiKam Edit question
Assignee:
No assignee Edit question
Solved by:
wirechief
Solved:
2007-05-06
Last query:
2007-05-06
Last reply:
Best wirechief (wirechief) said : #1

I found out this had to do with permissions, changing them to (root plugdev) solved the problem now digiKam is able to download the pictures

wirechief (wirechief) said : #2

ls -l /dev/bus/usb/002/001
crw-rw-r-- 1 root root 189, 128 2007-05-05 11:33 /dev/bus/usb/002/001

chown root:plugdev 001
root@Newsroom:/proc/bus/usb/002# ls -l 001
-rw-r--r-- 1 root plugdev 43 2007-05-05 11:33 001

Now digicam downloads the pictures.
I also made sure that my Bus 002 Device 022: ID 040a:0591 Kodak Co. information was put into my /etc/udev/rules.d/025_libgphoto2.rules
by adding another line with the ID 040a and 0591
ATTRS{idVendor}=="040a", ATTRS{idProduct}=="0591", MODE="0660", GROUP="plugdev"
This helped but changing the permissions on the usb device to root plugdev is what got digikam working.