Natty removed Dexter! (?) Now ppa fails.

Asked by Jon Gilgenbach on 2011-05-19

About a day after upgrading to Ubuntu 11.04, I realized Dexter was gone!!! I just yesterday found the hidden local share directory with the file "dexterdb" (and also my own little picture of me in the "images" folder). I'm hoping this means that all the contacts I had entered will return when I finally re-install it. However, since it was removed, the repo consistently fails to fetch. It was "removed during the upgrade", but I re-checked it (or both of them, I should say) in Synaptic, and I even removed it and re-added it manually, but still no love. The specific message is:

"Failed to fetch http://ppa.launchpad.net/lallenlowe/dexter-ppa/ubuntu/dists/natty/main/source/Sources 404 Not Found
Failed to fetch http://ppa.launchpad.net/lallenlowe/dexter-ppa/ubuntu/dists/natty/main/binary-i386/Packages 404 Not Found"

So 1. What do I do?! I was really loving this app! 2. When it finally is reinstalled, will that "dexterdb" file persist/merge and return my saved contacts? Should I back it up first while there's still time?? 3. Was this a Natty bug, or just a coincidence?

Thanks, and keep up the work on this great app.

Question information

Language:
English Edit question
Status:
Solved
For:
Dexter - Old Edit question
Assignee:
No assignee Edit question
Solved by:
Allen Lowe
Solved:
2011-05-20
Last query:
2011-05-20
Last reply:
2011-05-20
Allen Lowe (lallenlowe) said : #1

There is no natty ppa, change the word natty to maverick. Your contacts will
still be there

Thanks for the fast response. That fixed the repository problem, but now I'm getting a broken package error. By trying the install from terminal, I've tracked it down to this error:

The following packages have unmet dependencies:
 dexter : Depends: python (< 2.7) but 2.7.1-0ubuntu5 is to be installed
E: Broken packages

Is there a solution for this? Thanks!

Best Allen Lowe (lallenlowe) said : #3

I think it works if you install from the postler dev ppa for natty

Thanks Allen Lowe, that solved my question.

w00t! This did the trick. It installed in a snap, and all of my contacts were just like I had left them! I had to track down the "postler dev ppa for natty", btw... If anyone else has these issues, it is:

ppa:postler-dev/ppa