Latest devstack with Fedora 18 does not work with Horizon

Asked by Kyle Mestery on 2013-04-11

For about the last week, I had seen issues with devstack on Fedora 18. This is with the Havana branches of OpenStack Horizon now. What I see is that with the stock devstack, horizon starts fine. But accessing Horizon from a remote machine yields the stock Fedora Apache page, and not Horizon.

After some digging, I found that by make the change below to devstack, it succesfully works. My question is, why does Ubuntu not need this? Is there some configuration default option in Fedora Apache which requires this? I can propose this patch upstream if people think this is appropriate as well.

[kmestery@fedora-mac devstack]$ git diff
diff --git a/files/apache-horizon.template b/files/apache-horizon.template
index fb98471..7a443ac 100644
--- a/files/apache-horizon.template
+++ b/files/apache-horizon.template
@@ -20,6 +20,8 @@
         AllowOverride None
         Order allow,deny
         allow from all
+ Options +ExecCGI
+ Require all granted
     </Directory>

     ErrorLog /var/log/%APACHE_NAME%/horizon_error.log
[kmestery@fedora-mac devstack]$

Question information

Language:
English Edit question
Status:
Answered
For:
devstack Edit question
Assignee:
No assignee Edit question
Last query:
2013-04-11
Last reply:
2013-04-12
Julie Pichon (jpichon) said : #1

Fedora 18 ships with Apache 2.4, and the syntax changed from 2.2. Ubuntu still ships Apache 2.2 I imagine and therefore doesn't encounter the problem yet.

See also:
bug 1158416
http://httpd.apache.org/docs/trunk/upgrading.html

Sunil Thaha (sthaha) said : #2

I am not sure if Options +ExecCGI is needed. I believe only the fix for bug 1167066 which is already in mainline, is needed. Could you please verify?

Can you help with this problem?

Provide an answer of your own, or ask Kyle Mestery for more information if necessary.

To post a message you must log in.