Kicked my user from root group

Asked by Samuel Chandler on 2016-12-17

Using Dell xps 13 developer's edition Ubuntu LTS 14.04 and somehow kicked my user from root group. How can I log in as root upon boot to add myself to the group again? Or is there another solution? Thanks!

Question information

English Edit question
Dell Sputnik Edit question
No assignee Edit question
Last query:
Last reply:
Manfred Hampl (m-hampl) said : #1

There is a method to start the computer in root command prompt mode, see

Instead of changing the password, you probably have to use "useradd -G admin your-username" after the remount command.

Samuel Chandler (samxchandler) said : #2

I have the method suggested in the link to boot into recovery mode, holding down the "shift key" during boot. However, this does not work for me. I just log in normally.

Manfred Hampl (m-hampl) said : #3

You have to experiment with timing. try pressing the shift key earlier during the initial boot, or later, or hitting it repeatedly ...

Samuel Chandler (samxchandler) said : #4

I've tried every permutation of "shift" key pressing that I can think of and so far nothing has worked. Any other suggestions? Is there something unique about the dell xps 13 developer edition laptop?

Manfred Hampl (m-hampl) said : #5

Another possibility could be to boot into a live system from an Ubuntu installer in the "try Ubuntu without installing" mode, and then modifying the account settings on your hard disk installation (either by editing the files or by chroot-ing into the hard disk installation).

Can you help with this problem?

Provide an answer of your own, or ask Samuel Chandler for more information if necessary.

To post a message you must log in.