cannot disable wl driver

Asked by Nathan Adams on 2009-05-02

Ever since I got my Dell Mini 9 I found the included wireless driver to be "incomplete". At first Network Manager would not even pick up Ad-Hoc connections, and now it seems that I can't connect to anything that uses WEP. A long time ago before a kernel upgrade, I was happily using ndiswrapper as the bridge to my wireless card (using the Windows drivers of course) and it worked perfectly!

Recently, I did a upgrade and now I can't get rid of this wl driver. When I try and use ndiswrapper it says "(alternate driver: wl)" but wl.ko does not exist ANYWHERE on the SSD (I did make a copy to my home directory, but it shouldn't be loading that should it?). And now although the driver seems to be improved whereas Network Manager is detecting ad-hoc networks, however, it wont connect to them still.

My question is how to prevent this driver from loading so the ndiswrapper driver can manage the wireless?

I added the line
blacklist wl
to /etc/modprobe.d/blacklist but that doesn't seem to work.

Question information

Language:
English Edit question
Status:
Solved
For:
The Dell Mini Project Edit question
Assignee:
No assignee Edit question
Solved by:
Nathan Adams
Solved:
2009-05-03
Last query:
2009-05-03
Last reply:
Nathan Adams (adamsna) said : #1

Well, this certinatly has been a strange bug?

I removed the driver from ndiswrapper, and tried to readd it - no dice still said that the wl driver was in use.
Again, removed driver, reinstalled ndiswrapper from source, restarted, readded the driver and now Network Manager is happy but now I can't join from the CLI with a script I wrote that worked for a previous version.

So the solution for anyone else who experiences the "ghost driver" in ndiswrapper - just reinstall ndiswrapper from source (latest version) and see what happens.