some web pages don't work in wireless mode

Asked by MiniHelp on 2009-04-19

New Mini-9 Series N laptop. Works fine when ethernet cable is plugged in directly from my router. However, when I am in wireless mode, it works sometimes and not others. This is not an issue establishing a connection to my router. It detects the network and connects just fine, and works for some web pages. Here is what it does:

Most web pages work fine (e.g. Google & Dell), albeit they are a bit slow (compared to the direct connect). But others - most notably E-Bay - just hang in a waiting mode. For example, I am now looking at a screen that has been "Waiting for signin.ebay.com" for over 15 minutes. It will never come back.

Sometimes, just pressing refresh will work to unhang the page. Other times, not. Again, everything works fine in direct connect mode, and the wireless works fine on my other home computer (Windows XP).

Here is what I have tried:

1) I've turned off security on my home wireless network (had been WEP).
2) I've tried disabling the ipv6 setting. No luck.
3) I've installed all updates. The system is entirely up to date.
4) I've tried disabling Javascript to some success. This seems to solve some of the issues, but when a page needs to run Javascript it can't.
5) I've tried enabling/disabling the Javascript options. Some success, but I can't reproduce it.
6) I've tried changing my wireless channel from 11 to 8. No luck.

Signing into E-Bay seems to be the Holy Grail. If I can get the Mini to do that, I think the problem will be solved.

Question information

Language:
English Edit question
Status:
Solved
For:
The Dell Mini Project Edit question
Assignee:
No assignee Edit question
Solved by:
MiniHelp
Solved:
2009-04-20
Last query:
2009-04-20
Last reply:
2009-04-19
Nicola Ferralis (feranick) said : #1

I cannot seem to replicate your problem. What is the brand/model of your wireless router? have you tried to connect on a different router? Still slow on some sites?

MiniHelp (larrylaing) said : #2

It is a Linksys model DI-514 Router. My neighbor's router is strong enough to where I can use their signal, and it does the same thing. It's not that it's just slow. It hangs and never comes back. Pressing the refresh sometimes helps, but not always.

I'm almost certain it is one of the following:

1) My driver isn't up to date (I've noticed Broadcom has updated the driver recently, but the procedure to install it is just over my head)

2) There is some setting that is not compatible with my router, and I just have to keep trying different options until I find one that works, or

3) My wireless card is just flaky.

MiniHelp (larrylaing) said : #3

Question: Is there any way I can turn on some sort of trace to find out exactly what the driver/OS is trying to do, and where it hangs?

MiniHelp (larrylaing) said : #4

I have a short version an a long version:

Short version: Problem SOLVED! I had to replace my router.

Long version: I had a Linksys D-LINK DI-514 router that was about 5 years old. Deperate to try anything, I noticed that the firware was out of date. So, I uploaded the latest router firmware and installed it. Unfortunately, this caused my entire network to fail. My router was toast.

So, I went down and bought the latest/greatest Cisco Linksys Router. I set it up just like the old one, and my network still DIDN'T WORK (even my home network). I got on the phone to Linksys (GREAT technical support - 24 hours) and found out that they should rename WEP to RIP. WEP just flat out doesn't work anymore in a lot of environments. We switched the security protocol to WPA and then my home network worked great (better than before).

I held my breath as I configured my Mini-9 to the new network key and WPA protocol. It connected. It went to Google. And then, the Holy Grail: I could SIGN INTO E-BAY!

My advice to anyone having problems with their home system:

1) Make sure all of your Mini-9 software is completely up to date (use the update manager).
2) If you have an older Router (maybe one that only supports WEP?), bite the bullet and replace it with the latest/greatest.
3) Use WPA protocol.

It worked for me.

One other thing: When I first fired up my Mini-9 I was very frustrated that I couldn't connect at all to my wireless network. I was used to Windows where the network list automatically comes up. Not so on the Mini-9. You have to know to find the icon on the top banner that is your network connection (two monitors superimposed with a red "x" on my original system, a mouse with wires sticking out of it with a red "x" after I upgraded all of the software). Click on this icon and you should see a list of wireless networks. This is where you click on your network to activate it. I just hadn't clicked on the network! You can also set everything you need to using the "Edit Connection" selection at the bottom of the menu.

Hope this helps someone.