need updated binary

Asked by Kyle Cronan on 2009-02-12

I have a Mini 12. I managed to get xserver-xorg-video-psb (the latest version, 0.20.0+repack-0ubuntu1~804um1~dooz1) to compile and run in Intrepid. I copied over the varies binary blobs from Belmont:, msvdx_fw.bin and The first two load fine with Intrepid's xorg 1.5.2, but the second gives the following xorg error:

(EE) AIGLX error: psb exports no extensions (/usr/lib/dri/ undefined symbol: __driDriverExtensions)

This is because the newer mesa version that comes with 1.5.2 is expecting a new interface that this binary does not support. My questions are: Does Canonical have access to this source code? If so, will you provide a binary that is compiled for compatibility with xorg 1.5.2? If not, will you ask Intel to do so?

This is going to need to be done sometime, if Poulsbo hardware is ever going to work in releases more recent than Hardy. This time, why not release the binary to the community before shipping it out on new machines?

Question information

English Edit question
The Dell Mini Project Edit question
No assignee Edit question
Solved by:
Kyle Cronan
Last query:
Last reply:
Kyle Cronan (kyle-pbx) said : #1

Btw, this is the libgl1-mesa-dri-psb package. Not that I've ever seen a deb, but that's apparently what the package is called.

Nicola Ferralis (feranick) said : #2

You need to be careful that not necessarily what has been compiled for intrepid will work on hardy. Why did you compile it in intrepid in first place? Also, did you get your mini 12 with windows and are you trying to get ubuntu on it, ot you got it with ubuntu in first place?

Kyle Cronan (kyle-pbx) said : #3

First, why did I compile it for Intrepid in the first place? I'm not sure how to answer that. I can only refer you to the definition of a hacker:

1. A person who enjoys exploring the details of programmable systems and how to stretch their capabilities, as opposed to most users, who prefer to learn only the minimum necessary.

Although I don't claim to be an expert on X, it seems that patching the driver for xorg 1.5.2 was entirely successful. The patch is available here (it consists of trivial fixes and some basic API updates):

The part that didn't work was the DRI module,

Second, my Mini 12 came with Windows. I don't see how that's relevant.

I'd really appreciate it if you tried to find out for me whether Canonical or Intel has a newer version of this binary. I suspect that someone at Intel is already working on or has already completed work on these forward-compatibility issues.

Nicola Ferralis (feranick) said : #4

1. My question about why you tried to compiled in Intrepid is not by any means philosophical, but strictly practical. As an hacker you should know that if you want to have a binary for hardy, you should compile it in hardy. You cannot expect that something compiled for intrepid to work on hardy. So I'd recommend to compile it on the mini or otherwise run a LiveCD with hardy on another computer and than get that binary into the mini. I think that is quite doable for a hacker.

2. Why Windows? It's relevant because now I wonder what version of hardy you are trying to install. If your Mini12 would have come with ubuntu, than it would have come with Dell customized version of ubuntu hardy, with full compatibility with your graphic card (i.e. drivers). Unless you have that custom installation CD of hardy (which is not available for download, you get it only if you buy your mini with Ubuntu), the generic installation of hardy won't have the required drivers as you well know. Because of the fact that these drivers may not be openly available to everybody, but only to those who actually get their mini with Ubuntu, you might actually not be able to get updated drivers.

I would like to point out that I am a user just like you. With my questions I was just trying to understand your situation in order, maybe, to help you with a solution. If you think that my way to help you is not adequate and my question stupid, please let me know. If that is the case, since I am no customer service, I'll happily refrain to further comment on the issue. I am sure you will find other people willing to provide with the answers you are looking for.

BTW, I'll look if there are drivers available, but my way to find them is exactly the same as yours (i.e. searching online).

Kyle Cronan (kyle-pbx) said : #5

Oh, I see the confusion now: I compiled it in intrepid because I'm trying to get the driver to work in intrepid! Obviously, getting all this stuff to work in hardy is trivial by comparison- i've already done that. Sorry, I thought you were saying, "that code is for hardy so you can't use it in intrepid".

I guess I'll try asking Intel directly.