How to update to the lastest Bios (A04) in Ubuntu (and without any Windows Trick) ?

Asked by Donovan

Facts => It's *not* possibile to easily upgrade the Delle Mini 9 with the latest Bios from Dell (A04)

On the Dell official site it's present only an *.exe for Windows, nothing for Ubuntu. This bios fixes a lot of hardware problem: the F11 and F12 fn shortcut for the Mini, a better energy saving, and a better boot time, plus a lot of other minor bugs.

I asked assistance to Dell for this problem and his reply was "You have to request assistance to Canonical for Ubuntu". Of Course Canonical requested a billed assitance!

IMHO this situation is absurd: Dell sell a computer with an OS, and they don't make their Bios update (that fix technical problem) available and/or suitable for this OS!

So, i request assistence here in Launchpad: it's possible to make a simple bios updater for Ubuntu, without making any Windows blob tricks (USb disk from Windows, or other absurd workaround like virtualfloppy, dos emulation, etc etc) as i see in the forum on the Web?

I think a reply to this topic is very important also to really understand *how* it's possibile to sell a FOSS computer, if the vendor release bios updates and other technical updates available only for the Windows World.

Is this the statement made by Canonical with Dell?

Thank for your attention :-)

Question information

English Edit question
The Dell Mini Project Edit question
No assignee Edit question
Last query:
Last reply:

This question was reopened

Revision history for this message
Nicola Ferralis (feranick) said :

A BIOS compressed in a ZIP archive (instead of an exe file) is now available on dell support. Just select BIOS in the OS type.

Here's a quick HOWTO, which requires Windows only to create a bootable USB drive:

A. Create a USB bootable drive. For this you need:

1. Since the Mini is not equipped with a floppy, create a virtual one, using the the [free] "virtual floppy driver" from here:

2. Install the HP USB Disk Storage Format Tool Version 2.0.6

3. Run the HP USB Disk Storage Format Tool to format the USB drive. The program would need to use a DOS file image, so redirect it to the real or virtual floppy A:

4. The USB drive is now bootable.

B. Prepare the new BIOS:

1. Download and extract into a temporary folder "910_A00_BIOS" the older I910 BIOS with 16-bit DOS compatible flash utility:

2. Download BIOS from dell support

3. Uncompress the file

4. grab the file BIOS.ROM A02 BIOS

5. copy and paste it into the 910_A00_BIOS folder

6. You can either edit the FLASHB.BAT
Flash /x /MODE=3 KIZ00A00.wph
Flash /x /MODE=3 BIOS.wph

and rename the A02 BIOS from BIOS.ROM to BIOS.wph or
don't edit FLASHB.BAT and just rename BIOS.ROM to kiz00A00.wph

7. Copy the 910_A00_BIOS folder to a DOS bootable USB drive and then execute FLASHB.BAT in DOS.

8. The update should now take place.

I realize this is not the easiest way and it might require a Windows machine, but it's the best I can think of. Besides, I think Dell discourages Ubuntu users to perform the update on the mini (correct me if I am wrong).

Revision history for this message
Donovan (donovan2014) said :

Thanks for your reply Feranick :-)

Anyway your answer do not solved the problem in the question that i repeat clearer here: it's there any method to update the Bios for the Mini Dell 9 => without <= the forced use of Microsoft Windows to create the USB media updater?

[maybe this is related with some n° 1 bug here in launchpad for ubuntu]

If i buy a computer with Ubuntu preinstalled from a Vendor, i hope that his bios is upgradable without the use of any other (proprietary) OS.

All the procedure proposed here needs a Microsoft Windows box to create the USB media with the updater. Potentially i need to buy an OS symply to update the bios of my computer that is selled with freesoftware. I think it's a *little bit* illogical.

And my question was to understand exacly this: who have to solve this problem, Canonical or Dell?

If I buy the Mini from Dell, Dell say me that this problem must be solved by Canonical. But Canonical say me that this problem must be solved by Dell.

It's an insane loop.

> Besides, I think Dell discourages Ubuntu users to perform the update on the mini (correct me if I am wrong).

Also here i can't understand why Dell eventually discourages updates of a bios when there are a lot of very important fixes (energy efficient, F11 F12 fix on the keyboard, etc etc).

Anyway, thank you for your effort.

Revision history for this message
Brandon Williams (opensource-subakutty) said :

Earlier today, I updated my bios to A04 using the method described here:

It is very much a work-around (a.k.a. hack) to deal with the fact that Dell doesn't provide a supported method, and it will only work if you still have the diagnostic partition on your SSD (probably not true if you dumped MiniOS and installed i386 Ubuntu, as many have). That said, the method does not require the use of an OS that was not on the mini when you bought it, nor does it require any external hardware.

Please note, though, that this method is clearly not supported by Dell, and if it doesn't work for you, Dell probably won't help. In other words, the primary complaint of there not being a supported method to upgrade the bios still stands. This is just a way to make it work without the use of either windows or a usb drive.

Revision history for this message
robin (draper) said :

I can't help with the problem but i fully support the frustration shown by the customer that has the mini with ubunto and no support from Dell. This strikes me that if we were organised in the USA there could be some form of class action law suit against dell. they sell a product they say they support but it is a different story when you phone for helpl.
Such a shame with a good product and a good operating system...

Revision history for this message
anjilslaire (anjilslaire) said :

No fix, but to update feranick's post, I downloaded the A04 zip from Dell and it includes the phlash16.exe and bat file to install from DOS, so not hacking the actual bios files. But, it does still require bootable DOS...

Revision history for this message
Brandon Williams (opensource-subakutty) said :

For those who are uncomfortable at the command line, here's is a step-by-step variation on feranick's above post that uses the new .zip version of the bios update and also makes use of the existing DOS bootable diagnostic partition on the mini. It should work for you if you are still running the pre-installed MiniOS version of Ubuntu, or if you did not delete the diagnostic partition when you installed your new OS. The method doesn't require Windows and it doesn't require an OS installation that did not come with the mini when you bought it.

    1. download from Dell (see the previous post for a link)

    2. unzip the bios update into a new directory (assuming you saved the zip file in ~/Downloads)

        $ cd ~/Downloads
        $ mkdir bios
        $ cd bios
        $ unzip ../

    3. mount the diagnostic partition and prepare for flashing

        $ sudo mount -tvfat /dev/sda1 /mnt/
        $ sudo mkdir /mnt/bios
        $ sudo cp * /mnt/bios/
        $ sudo mv /mnt/autoexec.bat /mnt/bios/
        $ sudo mv /mnt/config.sys /mnt/bios/
        $ sudo umount /mnt/

    4. reboot, press 0 when you see the Dell flash screen on bootup, and select Diagnostics

    5. at the C: prompt, flash the bios, cleanup, and reboot

        C:\> cd bios
        C:\BIOS> 910A04.BAT
        C:\BIOS> rename autoexec.bat ..\autoexec.bat
        C:\BIOS> rename config.sys ..\config.sys
        C:\BIOS> ..\autoexec.bat
        select [Exit]

    6. if you want to verify that you're running the correct bios, press 2 at the Dell flash screen
        on reboot. it should say A04. press esc, and then exit discarding changes.

This method is easy enough that I'm surprised that Dell doesn't simply provide the required utility scripts for Ubuntu and DOS. As noted in earlier posts, this is not an officially supported method, but it worked for me and others.

Revision history for this message
UbuntuFledgling (business6945) said :

As my screen name indicates, I'm new to Ubuntu. This question is in response to Brandon Williams post of 2009-02-21:

How do I find the existing DOS bootable diagnostic partition? I've downloaded the to both my Home Folder and the My_Downloads folder on my Desktop.

Ubuntu doesn't have an equivalent to the "run" command/window?

Thank you in advance for any help you can give.

Revision history for this message
MiniHelp (larrylaing) said :

I can't help with the answer, but I too have shared the same frustration.

When I try to get support for Dell ubuntu, they give me a phone number (866) 622-1947. When I dial that number, there is a recorded message saying that Dell no longer supports ubuntu and directs you to the ubuntu website. Dell support also gives you this number: (866) 982-8688. It is the direct line to Canonical. When you call that number, they refer you back to the (866) 622-1947 number if you are calling about a Dell Mini-9. If you choose to stay on the line, and get a live person, they inform you that they will not provide support unless you are a paying customer. They also seemed (in my opinion) a bit exasperated by the whole situation, as they probably are fielding a lot of calls from bewildered Dell customers.

When I posted this on the Dell forums, my post was removed as containing offensive language and against the terms of service. I said nothing more than I did above. Only the facts.

I bought a Mini-9 with ubuntu for my wife for her birthday, and we can't get the wireless internet to work reliably. Dell won't support us, and all of the "fixes" and "workarounds" are way above my head technically.

I'm probably just going to junk the Mini-9. I doubt that Dell will take it back, and I'm not hopeful this problem can be solved (I described it in another post).

Can anyone advise me on a good solution for a bullet-proof/rock-solid choice of a mini-laptop for my wife who just wants to use it for Internet access and word processing / spreadsheet? I just want to open the box, turn it on, and have it work.

Revision history for this message
Mackenzie Morgan (maco.m) said :

I just dialed that number, and the recording only said to wait for a representative. There was nothing about Dell no longer supporting Ubuntu.

Alt+F2 will bring up a runbox

Revision history for this message
MiniHelp (larrylaing) said :
#10 have to wait for a while. After you call the number:

1) It tells you to hold for the next available representative. Then, you hear some hold music.

2) It then tells you that the call is being transferred and you will hear 2 tones before the transfer.

3) There is quite a delay here. You are then told how to get website support.

4) Hold music again. Then, you are told what to do if your monitor is not working. Try plugging it in.

5) Hold music again. It is at this point you are told that Dell no longer supports ubuntu, and gives you web site information.

I just called the number, and this is what it does. Let me know if you have found a way to talk with a live Dell representative using this number.

Revision history for this message
Brandon Williams (opensource-subakutty) said :


If you're still trying to handle this, please tell me which specific part of my previous response is giving you trouble. My post provides the exact set of commands that are required, so I'm not sure what additional details are necessary.

Revision history for this message
Donovan (donovan2014) said :


The problem of this question was only with the support for upgrading BIOS that Dell offer just for Windows users.
Rather then this, i'm very satisfied with Mini9 as product.

Revision history for this message
Mackenzie Morgan (maco.m) said :

Why did you say that Feranick doesn't answer the question? You asked how to do the BIOS update if Dell only offers a Windows installer. Feranick pointed out that Dell offers a non-Windows installer and that you should thusly just use that.

Revision history for this message
Nicola Ferralis (feranick) said :

Just to clarify a couple of points, I would like to add a couple of things:

1. If the issue is technical, either Brandon William or my howto should be sufficient to update the BIOS. It's not straightforward, I know, but it does the job.

2. If the problem is political, meaning that basically there are no tools (GUI?) that can update the BIOS natively under ubuntu, well, there is nothing that I can say about that. I am sympathetic with the general feelings about the lack of support from Canonical/Dell on this. Although looking for an answer that doesn't exist (such as a native tool for the purpose), won't go very far, I think it's good to make the user's voice heard.

Revision history for this message
mkwa (mkol2006) said :

I updated my Dell Mini 9 BIOS from version A00 to A05 by downloading two files and using a flash drive:
(1) Download QHA05DOS.exe from
(2) Download FDSTD.288.imz from
(3) $ unzip FDSTD.288.imz
(4) After unzip, have image of DOS bootable 2.88MB floppy in file FDSTD.288
(5) Insert flash drive. If it gets mounted, unmount it (right click the desktop icon and select unmount). Now transfer the bootable floppy image to the flash drive by command (executed as root):
(6) # dd if=FDSTD.288 of=/dev/sdx
(7) where sdx is the device name of the flash drive. You can find it by df command while the flash drive is mounted, or in kernel messages shown by dmesg command. Make sure you use correct sdx name. Name sda is the probably your hard drive and you don't want to overwrite that.
(8) Pull out the flash drive, and plug it in again. Now the flash drive should mount as a 2.88MB DOS disk with over 2MB free space. Copy QHA05DOS.exe to the DOS disk, unmount the DOS disk, and pull the flash drive out. The steps up till now can be done on any Linux computer (including your Mini 9).
(9) Now plug the flash drive into your Mini 9 and power up. Click key 0 to select booting from the flash drive. Mini 9 will boot up in DOS, asking few questions, I answered NO to all of them.
(10) Now from the A:\ DOS prompt, execute the QHA05DOS.exe and it will do the reflashing.

Revision history for this message
Donovan (donovan2014) said :

Finally there is the REAL solution:

BIOS Update Process using libsmbios dellBiosUpdate

This article describes how to update your Dell computer's system BIOS using exclusively Linux tools. To do this, we will install Libsmbios, a generic Linux software package. It is assumed throughout this page that all commands will be run as the 'root' user. Use either 'sudo' or 'su' to become root before attempting any of these commands or they will fail.

    * Install libsmbios

# apt-get update (not always necessary)
# apt-get install libsmbios-bin

    * Get the System ID

# getSystemId
Libsmbios: 0.12.1
System ID: 0x01DD
Service Tag: DT6WLB1
Express Service Code: 30063287773
Product Name: Dell DM061
BIOS Version: 2.3.2
Vendor: Dell Inc.
Is Dell: 1

    * Download the latest BIOS ".HDR" file for this system. Go here: Scroll down the list to find a directory matching the System ID from the previous step. The directory will be named: system_bios_ven_0x1028_dev_SYSTEM_ID_version_BIOS_VERSION. Go into this directory and download the file, "bios.hdr".

    * load the dell_rbu driver

# modprobe dell_rbu

    * update the bios

# dellBiosUpdate -u -f ./bios.hdr-2.3.2
Supported RBU type for this system: (MONOLITHIC)
Using RBU v2 driver. Initializing Driver.
Setting RBU type in v2 driver to: MONOLITHIC
Prep driver for data load.
Writing RBU data (4096bytes/dot): ............................
Notify driver data is finished.
Activate CMOS bit to notify BIOS that update is ready on next boot.
Update staged sucessfully. BIOS update will occur on next reboot.

    * reboot the system

# reboot

[edit] Troubleshooting

There are two common problems that you may run into when following this process:

Problem: You follow all the instructions above, everything says it worked, but BIOS doesnt update. Solution: Normally, this is because the kernel is doing a "cold boot", which messes up the update process. Tell the kernel to do a warm reboot by adding "reboot=bios" to the end of your kernel command line. Reboot to let that setting take effect, and then try the bios update again.

Problem: You get a message from dellBiosUpdate saying it could not allocate enough memory. Solution: Some systems require up to 2MB of contiguous *physical* memory, which can sometimes be in short supply, especially if the system has been running for a while. You may have to reboot your system a couple times and retry the update for it to take.

I'm really really happy. Thanks to Dell for finding this opensource solution e writing it on his wiki.

Revision history for this message
Donovan (donovan2014) said :

Sorry but the method above don't works, there is no HDR bios for the Dell Mini 9 :-(((((


I ReOpen the question that still has no clear reply from Canonical and Dell: like a lot of users, I'd like to update the Bios on my Mini9 WITHOUT any Windows or Dos Blob, just under Linux.

IMHO it's really a shame that Dell Staff don't provide this bios to work with the super simple method above. Maybe Canonical Staff can make some pressure and also make an official request about.

Revision history for this message
Launchpad Janitor (janitor) said :

This question was expired because it remained in the 'Open' state without activity for the last 15 days.