wired networking does not work in Intrepid

Asked by MattParkins on 2009-01-27

Yesterday I upgraded from the standard dell ubuntu 8.04.1 for lpia to ubuntu 8.10 for i386 using a bootable usb stick. I'm quite pleased that most stuff just works right off the bat.

One thing that doesn't work though is my wired networking! After the install of Intrepid I think it all worked fine. Then it asked to get all the updates, about 200MB of updates or so, and then neither my wireless or wired networking would work at all. They would both sit there trying to acquire an IP address. I have another ubuntu machine (8.10) that happily connects to the router so I know the router is just fine.

After a bit of playing around I installed wicd as my network manager and now wireless networking often(!) works (it might just be that it works the first time after boot). But wired networking refuses to work at all. It does all the steps as you'd expect and then sits there trying to obtain an IP address. Interestingly even with the ethernet cable unplugged wicd tries to connect to the wired network as the desktop starts up and stops at obtaining IP address.

I'm using the broadcom restricted wireless driver. From ifconfig - the dropped frame count is continually increasing:

eth0 Link encap:Ethernet HWaddr 00:21:70:c7:fe:77
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:520087009 overruns:0 frame:0
          TX packets:0 errors:0 dropped:5 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
          Interrupt:220 Base address:0xa000

Any ideas?

Question information

Language:
English Edit question
Status:
Solved
For:
The Dell Mini Project Edit question
Assignee:
No assignee Edit question
Solved by:
MattParkins
Solved:
2009-01-27
Last query:
2009-01-27
Last reply:

Since I had just reformatted & installed a new version I decided to just do it again and this time not include the proposed updates in the sources list. I had also gotten rid of evolution (long live gmail!) and lots of its components so perhaps that had something to do with it. I've now reinstalled the basic intrepid install & updates and both wired & wireless works fine.