dejadup won't find duplicity anymore

Asked by Stephan

Since two weeks I can't create a backup anymore. When I do (or when the automated backup starts) a message is displayed:

Install Packages
For proceeding these packages have to be installed:
- duplicity
(translated from German)

When I click "Install" I am asked for the root password which I enter. An installation progress bar is displayed, but in the end I get:
Backup failed
The packages are already all installed
which is true because duplicity was there all the time.

I tried to remove and reinstall duplicity and Déjà Dup. It seems duplicity is not availabe for Opensuse Leap 15.4 anymore, at least not in the official repositories. I reinstalled it from But still Déjà does not recognise duplicity.

Any idea what I can do?

Question information

English Edit question
Déjà Dup Edit question
No assignee Edit question
Last query:
Last reply:

This question was reopened

Revision history for this message
Stephan (joesse) said :

I found a solution. I removed the package duplicity without checking for dependencies. I started Déjà Dup and had it install duplicity. Not elegant, but seems to work.

Revision history for this message
Stephan (joesse) said :

No it's not solved. removing and reinstalling duplicity works only once. The next time Déjà Dup tries to create a backup, it will ask for duplicity again.

Revision history for this message
Michael Terry (mterry) said :

That's odd... I'm not super familiar with OpenSuse's package system... but we use packagekit to detect & install missing dependencies. If that's not working right, it might be better to file a ticket against OpenSUSE.

As a workaround, you could install the flatpak version:

Can you help with this problem?

Provide an answer of your own, or ask Stephan for more information if necessary.

To post a message you must log in.