I can map to a Samba Share but Deja-Dups cannot

Asked by Niall Chapman

I've setup a Samba share server that 50+ people use for Backups, some on macOS but mostly on Ubuntu using the native Backups application and it worked perfectly for +6 months.

But now the Ubuntu Backups application can't connect to it, even though I can map to Samba Shares on the same server and Read/Write files using the normal Ubuntu GUI (Nautilus/Files).

I can also mount it using the command below:

    mount -t cifs -o username=username,password=<your_password> //server/share /mountpoint

The error I see when I click "Backup Now" in Deja-dup is:

    "Storage Location Not Available - Waiting for a Network Connection"

Also Time-Machine on macOS still works, so it seems like there's an issue with Deja-Dup but I can't find any logs for it, even if I set the environment variable DEJA_DUP_DEBUG=1 I see nothing new in ~/.cache/deja-dup.

Question information

English Edit question
Déjà Dup Edit question
No assignee Edit question
Solved by:
Niall Chapman
Last query:
Last reply:
Revision history for this message
Michael Terry (mterry) said :

What version of deja-dup are you using? (And/or what distro?)

If Files can read/write to the storage location, Deja Dup should be able to, for sure. We use the same plumbing. But this looks like we are getting confused about whether the network connection is available. Is there anything interesting / unusual about your network?

> even if I set the environment variable DEJA_DUP_DEBUG=1 I see nothing new in ~/.cache/deja-dup.

You would see output if you run Deja Dup on the command line. Something like:

DEJA_DUP_DEBUG=1 deja-dup --backup

But... probably not in this case, since I think we are stopping before we even get to the juicy logging bits.

Revision history for this message
Niall Chapman (blablubla) said :

Thanks for the response Michael, and sorry for the delay in replying, a few fires came up and I'm only getting back to this now.

The version of deja-dup is 40.7, the OS that I and the users have is "Ubuntu: 20.04.3 LTS"

The network connection is available since I can connect to the samba share via Files > Other Locations smb://server/folder (+ entering credentials on the gui)

The only thing I can think of that isn't completely normal is that I'm running the Samba server on a docker, but like I said before the Backups application worked up until January ( although it could have been end of December when the Ubuntu 20.04.3 release came out).

At this point I'm looking at other alternatives to Deja but can't find anything that worked so seamlessly.

Revision history for this message
Niall Chapman (blablubla) said :

Problem solved, was using "Network Location" instead of "Local Folder" and selecting the mapped samba drive on my machine. My mistake