justification for the general operation

Asked by Alessandro Cuomo

I am wondering why, after I backup on a personal server a new folder is created in my home directory named after: User@ip-server and in this folder there is something similar to the home itself plus another sub folder named after User@ip-server.
Inside this subfolder another home-like set of folder.

The home-like directory in the new two folder User@ip-server are sometimes marked with a padlock and a cross sign and are inaccessible, sometimes they have the exact content of their copies in the original home.

Is all this normal? What the purpose of this thing?

Thanks a lot

Question information

English Edit question
Déjà Dup Edit question
No assignee Edit question
Solved by:
Alessandro Cuomo
Last query:
Last reply:
Revision history for this message
Alessandro Cuomo (alessandro-ubuntu-one) said :


I forgot: there are errors at the end of the backup just about the folder named after User@ip-server.

It says "the contents of User@ip-server/subfolder/filename1 have not been copied check if you can open the file" for a lot of files in User@ip-server

Revision history for this message
Michael Terry (mterry) said :

Huh... What version of deja-dup are you using?

This sounds like maybe we are confused about what the backup location is - like you are trying to backup to a remove server, but we are instead backing up to ~/User@ip-server/ - does that match up with what you're seeing?

Revision history for this message
Alessandro Cuomo (alessandro-ubuntu-one) said (last edit ):

Hi thak you a lot for the answer.

I don't think this match up with the fact that exploring the server via "File" while it's in my LAN I can see the archives named after "duplicity-full.timestamp.vol_nun_x.difftar.gz" and the "duplicity-fulltimestamp.manifest" file in the place where I expect them to be.

that is my backup that I can restore in every moment, right?

and not the set of folder described in the question.

the version of deja-dup I am using is the 40.7

Revision history for this message
Michael Terry (mterry) said :

Ah OK, so it does sound like we're making nice little backups on your server.

So then it sounds like the issue is that you are seeing an unexpected User@ip-server entry in Files that is another view into your server. That might just be Deja Dup mounting the server so it can drop files into it?

Is it an actual folder under your Home or just an entry in the sidebar of the Files browser?

Revision history for this message
Alessandro Cuomo (alessandro-ubuntu-one) said :

It is an actual folder under my Home.

This folder is there since I setted up this backup, but now I am wondering if it is there because deja-dup creates it or because Ubuntu 20.04LTS creates It for some reason when a stream is setted up between the file system and a server in the LAN.

In any case It would be ok to me except for the fact I get this unaesthetic error about it any time I run a backup xD

thank you a lot for your support

Revision history for this message
Launchpad Janitor (janitor) said :

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Revision history for this message
Alessandro Cuomo (alessandro-ubuntu-one) said (last edit ):

I would like to keep the thread open if possible

I still have the same issue
thank you a lot for your attention

Revision history for this message
Michael Terry (mterry) said :

I guess I'm not sure how to help here. This needs some investigation. It is not normal for you to have another view into the server, I don't think?

- What does the following command say: ls -ld ~/User@ip-server
- Is that folder in the output of `mount`?
- Is Deja Dup creating that folder?
- If you delete / move that folder, does it come back?

I am not sure what's happening on your side, but this folder is not normal or expected.

Revision history for this message
Alessandro Cuomo (alessandro-ubuntu-one) said :

Hi Michael,
Thank you a lot for your answer. The folder wasn't in the output of mount and I didn't figured out yet why it was created in first place and if it was created by Deja Dup or Ubuntu itself.

In any case when I removed the folder from there and ran another backup it was not created anymore so I think I should the problem is solved :)

But i would really appreciate any comment of yours on this type of of behavior.
Glad to be in touch with you,