Can't backup. "waiting for backup USB to connect"

Asked by Hugh Mason

Attempted to backup to a recently formatted (FAT32) Seagate 250GB USB Hard Drive. I get the following message "waiting for backup USB to become connected"
Confirmed HD is formatted and empty.
Should I delete Deja Dup and reinstall it?
Thanks.

Question information

Language:
English Edit question
Status:
Expired
For:
Déjà Dup Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Michael Terry (mterry) said :
#1

Huh, that's frustrating. Sorry Deja Dup is giving you trouble.

What version of Deja Dup are you running? (you can see in the About menu)
What distro are you running?

In versions 42.3 and 42.5, I fixed some bugs in our handling of noticing USB drives - but mostly that would have affected encrypted drives. But maybe the cleaner code would also work for you, if you are on an older version...

Revision history for this message
Hugh Mason (humanx) said :
#2

Michael,

Thanks for your reply.  I'm running version 40.7 of Deja Dup. The USB
drive I am backing to is not encrypted.

I installed version 18.04 of Ubuntu by image and updated it to 20.04.
My laptop HD is encrypted, but I decrypt it by password at boot.

Hugh

On 7/7/21 10:05 AM, Michael Terry wrote:
> Your question #697821 on Déjà Dup changed:
> https://answers.launchpad.net/deja-dup/+question/697821
>
> Status: Open => Needs information
>
> Michael Terry requested more information:
> Huh, that's frustrating. Sorry Deja Dup is giving you trouble.
>
> What version of Deja Dup are you running? (you can see in the About menu)
> What distro are you running?
>
> In versions 42.3 and 42.5, I fixed some bugs in our handling of noticing
> USB drives - but mostly that would have affected encrypted drives. But
> maybe the cleaner code would also work for you, if you are on an older
> version...
>
--
Virus Free Ubuntu 20.04.

Revision history for this message
Michael Terry (mterry) said :
#3

Hmm OK - one thought is to try upgrading Deja Dup by using the snap version instead?

snap install deja-dup --classic

And then you can also remove the distro version if you like:

sudo apt remove deja-dup

There were a fair number of fixes since 40.7, might help. But I've not heard other reports of this issue where 40.7 doesn't notice the USB being plugged in, so I'm not sure.

Revision history for this message
Hugh Mason (humanx) said :
#4

Thank you for the information Michael.  The more I think about my
problem the more I focus on the formatted Seagate USB drive.  It appears
that the entire drive (all 250GB) has been formatted. There are no
partitions and no 'interface files.'  Ubuntu doesn't recognize it
because there nothing on the drive to recognize.  So I guess my next
stupid question is what do I need to put on the formatted drive to make
it work?  And do I need to create a partition first?  Is there a program
I can use to do this?  I formatted the entire drive using the "Disks"
application in Ubuntu.  Did I do something wrong?  Thanks again.  Hugh

On 7/17/21 12:45 PM, Michael Terry wrote:
> Your question #697821 on Déjà Dup changed:
> https://answers.launchpad.net/deja-dup/+question/697821
>
> Status: Open => Answered
>
> Michael Terry proposed the following answer:
> Hmm OK - one thought is to try upgrading Deja Dup by using the snap
> version instead?
>
> snap install deja-dup --classic
>
> And then you can also remove the distro version if you like:
>
> sudo apt remove deja-dup
>
> There were a fair number of fixes since 40.7, might help. But I've not
> heard other reports of this issue where 40.7 doesn't notice the USB
> being plugged in, so I'm not sure.
>
--
Virus Free Ubuntu 20.04.

Revision history for this message
Michael Terry (mterry) said :
#5

Hello again! Two thoughts:

1) To answer your questions about formatting... I'm not sure (and it sounds like maybe you're not sure?) what state your drive is in. It is possible to erase all partitions and have a wholly blank drive. That's not going to be very useful. You want to end up in a place where Disks shows one giant FAT partition for your drive.

2) After formatting, the drive will appear as a new drive to Deja Dup - it tracks drives based off an identifier that gets reset when reformatted. So you'll want to go to Deja Dup preferences and re-select your newly formatted drive as a storage location.

Does that help?

Revision history for this message
Hugh Mason (humanx) said :
#6

Hello Michael,

I tried your suggestions above and got the same error message. Disks says that my USB SD is 'working OK', but I'm thinking now that it might be the problem. Thinking back, that USB drive is 10-12 years old and has seen a lot of work. Since memory is cheaper now, I'm thinking that getting a new USB drive might be the solution. Any specific recommendations on one would be appreciated (250GB).
Thank you again,
Hugh

Revision history for this message
Hugh Mason (humanx) said :
#7

Hello Michael,
I got a new External SSD Drive for backing up (no user manual). Do I need to reformat it for FAT32 and create an Ubuntu recognizable partition in Disks? I received no user manual or instructions with this Drive.
Thank you,
Hugh

Revision history for this message
Michael Terry (mterry) said :
#8

Yeah I'd recommend formatting it for FAT32 in Disks, exactly.

(There are other file systems you could format it as, instead of FAT32, but for external drives, it's the easiest and most readable by every OS.)

Revision history for this message
Hugh Mason (humanx) said :
#9

Michael,
I'm still getting the "unable to connect....." message when I attempt to back up now. I have one big FAT32 partition on the new hard drive. Question: Do I need to use Deja Dup from the beginning to get the USB drive to recognize the new SSD?
Thanks,
Hugh

Revision history for this message
Michael Terry (mterry) said :
#10

If you go to the Deja Dup preferences, you should be able to select your newly formatted drive from the Storage Locations preference dropdown. You may see both the new one and the old one in the dropdown - it's just because Deja Dup remembers your old drive until you pick a new one.

Once you select the new drive, try backing up again.

Revision history for this message
Launchpad Janitor (janitor) said :
#11

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Revision history for this message
Hugh Mason (humanx) said :
#12

Michael Terry,
I tried what you suggested and I still can't get the new SSD device to even be recognized. That is sort of strange because I was able to reformat and create a big partition using Disks on the new SSD drive. I even reformatted the partition from FAT32 to Ext4 and it still wasn't recognized by DejaDup. Help!!
Thanks,
Hugh

Revision history for this message
Hugh Mason (humanx) said :
#13

Michael,
Since I'm backing up my Home folder to the USB SSD, can I just copy that folder to the USB SSD for now?
BTW, I tried your suggestion about installing a new version of Deja-Dup and removing the old version. However, I got an error message when trying to install the new version. What's going on with that?
Thanks,
Hugh

Revision history for this message
Launchpad Janitor (janitor) said :
#14

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Revision history for this message
Michael Terry (mterry) said :
#15

Hello! I didn't mean to ignore you for so long - I just didn't really have any useful suggestions to offer.

> Since I'm backing up my Home folder to the USB SSD, can I just copy that folder to the USB SSD for now?

Sure? That works for a one-off backup, just to make sure you've got copies.

> However, I got an error message when trying to install the new version.

What error did you get?

 > I even reformatted the partition from FAT32 to Ext4 and it still wasn't recognized by DejaDup

You probably want FAT32 - that should work and avoids a lot of permission errors that you might experience with Ext4.

Not recognized by deja-dup is really weird though. I dunno what to do about that... It should be recognized? And I haven't heard other reports of drive oddities...