Deja-dup errors out after abnormal shutdown

Asked by XXCoder

I was updating a backup when power went out. After that it simply silently fails and asks me for password again in order to try backing up again. After lot of help in irc, I got 2 information -

From term after running deja-dup: CRITICAL **: 18:40:13.994: deja_dup_config_location_remove_volume_full: assertion 'uuid != NULL' failed

In .xsession file, there is entry: (deja-dup-monitor:32573): GLib-CRITICAL **: 04:25:18.709: Source ID 570 was not found when attempting to remove it

What is going on? Can I recover without erasing backup? I can erase backup, but I rather keep older files in case.

Question information

English Edit question
Déjà Dup Edit question
No assignee Edit question
Solved by:
Michael Terry
Last query:
Last reply:
Revision history for this message
XXCoder (xxcoder) said :

Forgot to state - Xfce mint, version 37.0 of deja-dup.

Revision history for this message
Best Michael Terry (mterry) said :

Hello! 37.0 is fairly old at this point and subject to a bad bug fixed in 39.1:

So first off, I'd say update to a newer version. If you can't update your distro, Deja Dup ships snap and flatpak versions, depending on what your version of Mint supports:

OK. With that caveat out of the way... I think both the error messages you posted are likely benign. 37.0 is old enough that I don't remember if it had any password problem quirks (besides the above mentioned issue). But your version of duplicity (which we use as the backup tool behind the scenes) could also be very old and might have oddities.

I'm guessing duplicity is having a hard time understanding its own half-completed files for some reason.

Easiest fix would be to rename the folder holding your current backup files, to keep them around if you need them. Then start a new backup. It should start fresh and be OK. Does that help?

Revision history for this message
XXCoder (xxcoder) said :

Thanks for letting me know. I just wish it would just not silently fail and ask for password again. That was extremely annoying that I had to hunt down really hard to find errors.

Revision history for this message
XXCoder (xxcoder) said :

Thanks Michael Terry, that solved my question.