PC locks up when attempting to revert file to previous version

Asked by Jonathan Young on 2020-11-21

Linux Mint MATE 20 on HP Z400 with 8 GB RAM.

The hard drive is showing SMART errors and two small personal data files were corrupted. One no longer has its original name, which I cannot exactly recall.

Having spent some time not realizing that Nautilus was required as the easy route to attempt to restore at least the file which retains its original name, when I try with the correct method my PC locks up after a couple of minutes, with a tiny bit of the progress indicator showing.

I would be grateful for advice on a way forward.

Question information

Language:
English Edit question
Status:
Solved
For:
Déjà Dup Edit question
Assignee:
No assignee Edit question
Solved by:
Michael Terry
Solved:
2020-11-22
Last query:
2020-11-22
Last reply:
2020-11-21

This question was reopened

Best Michael Terry (mterry) said : #1

Yikes OK, let's see if we can figure this out.

You are not the only person that struggled with the nautilus interface. Newer versions have a built-in browse & restore interface that may serve you better.

= Option 1: new version =

You can grab the flatpak or snap versions of Deja Dup here: https://wiki.gnome.org/Apps/DejaDup/Download

These will be the latest and greatest with the new browse interface.

= Option 2: duplicity =

Besides trying a newer version, I'm not sure exactly what to do here. The whole PC locks up? That's not something I've heard reported before. I'm not even sure how Deja Dup would go about causing that. Not doubting you, just demonstrating my uncertainty on where to start to debug it.

I guess you could avoid the graphical interface of Deja Dup and use Duplicity on the command line directly (this is the backup tool that Deja Dup uses behind the scenes). It's command line is a little bit confusing, but it has a good man page. Are you comfortable with the command line? I can help walk you through that if not.

Jonathan Young (catnap53) said : #2

Phew, I've got my files back.

I did the flatpak update from 40.x to 42.6

Using the program interface, there was failure, twice, due to unknown error, reported by Deja Dup.

Still not integrated with Caja, so used Nautilus for the file revert option, which wanted Google login
details, but I use a second hard drive for my backups, so back to the program interface to select the
backup location again, which stopped the Google login request.

I couldn't make any progress without changing from the Nouveau to NVIDIA-340 graphics driver. With the
NVIDIA driver, Chromium-based browsers (Opera and Vivaldi) are unusable after waking my PC from suspension.
Even so, the panel disappeared several times followed by crashes, and Deja Dup needed several tries to
restore the files. For the first, which is only about 3 MB, Deja Dup kept running for about 10 minutes
more, with RAM useage increasing to 1.4 GB before the system crashed. For the other file I had found out
its name and used it for a dummy file, and after I think three attempts the version from a few days ago
was retrieved and Deja Dup was able to be closed correctly.

Just now I opened the main program again and, instead of an unknown error, it managed to populate with
a bunch of file and directory icons, so I hope the updated version has bedded-in and will perform as
intended from now on.

Jonathan Young (catnap53) said : #3

Thanks Michael Terry, that solved my question.