Format of DejaDup Partition

Asked by Ulrich Baustian on 2020-06-20

In no word the format of the DejaDup partition is mentioned anywhere. I have experimented with ext3 and ext4 partitions, but was only successful with NTFS partitions. Is NTFS the only possibility or does DejaDup also work with an ext4 partition as backup destination?

Question information

Language:
English Edit question
Status:
Expired
For:
Déjà Dup Edit question
Assignee:
No assignee Edit question
Last query:
2020-06-25
Last reply:
2020-07-11
Michael Terry (mterry) said : #1

It should have worked with all of those partition types. It just writes files, doesn’t do anything low level enough to care about partition types.

What were the errors you saw with ext3 and ext4?

Ulrich Baustian (uhbaustian) said : #2

I'm using Ubuntu 20.04. Today I have formatted my drive backup drive sdc
to ext4. Then I have mounted the drive via fstab. Then I have run
DejaDup, which started quite normally. When returning to the PC after
some hours, I found an failure message. When opening other locations on
this computer, the backup drive was marked to be full, but when I opened
the drive it was empty.

This does not happen, if the drive is formatted to ntfs. But before
returning to ntfs, I'll wait for further proposals from you.

On 21.06.20 05:45, Michael Terry wrote:
> Your question #691432 on Déjà Dup changed:
> https://answers.launchpad.net/deja-dup/+question/691432
>
> Status: Open => Needs information
>
> Michael Terry requested more information:
> It should have worked with all of those partition types. It just writes
> files, doesn’t do anything low level enough to care about partition
> types.
>
> What were the errors you saw with ext3 and ext4?
>

Ulrich Baustian (uhbaustian) said : #3

I have tried back and forth with EXT4 and NTFS. EXT4 is not working for
Dejadup running under Ubuntu.

On 21.06.20 19:35, Ulrich Baustian wrote:
> Your question #691432 on Déjà Dup changed:
> https://answers.launchpad.net/deja-dup/+question/691432
>
> Status: Needs information => Open
>
> You gave more information on the question:
> I'm using Ubuntu 20.04. Today I have formatted my drive backup drive sdc
> to ext4. Then I have mounted the drive via fstab. Then I have run
> DejaDup, which started quite normally. When returning to the PC after
> some hours, I found an failure message. When opening other locations on
> this computer, the backup drive was marked to be full, but when I opened
> the drive it was empty.
>
> This does not happen, if the drive is formatted to ntfs. But before
> returning to ntfs, I'll wait for further proposals from you.
>
> On 21.06.20 05:45, Michael Terry wrote:
>> Your question #691432 on Déjà Dup changed:
>> https://answers.launchpad.net/deja-dup/+question/691432
>>
>> Status: Open => Needs information
>>
>> Michael Terry requested more information:
>> It should have worked with all of those partition types. It just writes
>> files, doesn’t do anything low level enough to care about partition
>> types.
>>
>> What were the errors you saw with ext3 and ext4?
>>

Michael Terry (mterry) said : #4

Hmm, what was the error message you saw? Anything about permission issues?

Ulrich Baustian (uhbaustian) said : #5

The error message was the same, as that, which I sent you on June 21,
probably with a different date. I have made no further screenshot:

*Backup Faile**d*
Giving up after 5 attempts. Error: Error opening file
"/media/back/duplicity-full. 20200621T53403Z.vol1.difftar.gz":
Permission denied

I tried EXT4 and NTFS formatted partitions on my PC and on my Laptop,
which all run under Ubuntu. On my PC the backup partition is placed on a
separate drive, while on my Laptop, which has of course only one drive,
the backup is on one partition of this drive. The problem is the same on
both computers: Only NTFS formatted partitions are accepted by DejaDup.

On both computers I have formatted the backup drive with GPARTED to NTFS
or EXT4. Then I have changed "fstab" to mount this partition. I have
used two different approaches to do this. The first was to find the uuid
of the Partition via:

/sudo blkid/

and then toopen, edit and save the original fstab in a text editor via:

/sudo //nano ///etc/fstab/

The second approach was to use the UBUNTU Program DISKS, which offers by
hitting the "Additional partition options" icon to modify the fstab file
on the fly.

In both cases I have made of course a restart to get the partition
mounted by reading fstab.

None of these processes made any computer to work DejaDup with EXT4
formated partitions.

Best regards

Ulrich Baustian

On 23.06.20 00:50, Michael Terry wrote:

> Your question #691432 on Déjà Dup changed:
> https://answers.launchpad.net/deja-dup/+question/691432
>
> Status: Open => Needs information
>
> Michael Terry requested more information:
> Hmm, what was the error message you saw? Anything about permission
> issues?
>

Manfred Hampl (m-hampl) said : #6

"Error opening file (filename): Permission denied"

After formatting the backup drive and adding the entry to fstab - have you tested whether you can create a file on the target directory with any other program?

I assume that the protection settings did not allow creating the file.

Ulrich Baustian (uhbaustian) said : #7

I reformatted my Backup partiton to EXT4, changed fstab via DISKS and
checked the fstab entry. The I restarted the Laptop and wrote a text
with LibreOffice Writer. I was not able to save the file in this Backup
partition, though it is mounted. The error message is:

Backup

On 24.06.20 12:41, Manfred Hampl wrote:
> Your question #691432 on Déjà Dup changed:
> https://answers.launchpad.net/deja-dup/+question/691432
>
> Status: Open => Needs information
>
> Manfred Hampl requested more information:
> "Error opening file (filename): Permission denied"
>
> After formatting the backup drive and adding the entry to fstab - have
> you tested whether you can create a file on the target directory with
> any other program?
>
> I assume that the protection settings did not allow creating the file.
>

Ulrich Baustian (uhbaustian) said : #8

I had added the error message as an image. It's not visible here. Were
you able to see it?

On 24.06.20 16:15, Ulrich Baustian wrote:
> Your question #691432 on Déjà Dup changed:
> https://answers.launchpad.net/deja-dup/+question/691432
>
> Status: Needs information => Open
>
> You gave more information on the question:
> I reformatted my Backup partiton to EXT4, changed fstab via DISKS and
> checked the fstab entry. The I restarted the Laptop and wrote a text
> with LibreOffice Writer. I was not able to save the file in this Backup
> partition, though it is mounted. The error message is:
>
> Backup
>
>
> On 24.06.20 12:41, Manfred Hampl wrote:
>> Your question #691432 on Déjà Dup changed:
>> https://answers.launchpad.net/deja-dup/+question/691432
>>
>> Status: Open => Needs information
>>
>> Manfred Hampl requested more information:
>> "Error opening file (filename): Permission denied"
>>
>> After formatting the backup drive and adding the entry to fstab - have
>> you tested whether you can create a file on the target directory with
>> any other program?
>>
>> I assume that the protection settings did not allow creating the file.
>>

Ulrich Baustian (uhbaustian) said : #9

The missing error message is:

Error saving document Untitled 1: /mnt/sda3/BackupTest.odt does not exist.

On 24.06.20 12:41, Manfred Hampl wrote:
> Your question #691432 on Déjà Dup changed:
> https://answers.launchpad.net/deja-dup/+question/691432
>
> Status: Open => Needs information
>
> Manfred Hampl requested more information:
> "Error opening file (filename): Permission denied"
>
> After formatting the backup drive and adding the entry to fstab - have
> you tested whether you can create a file on the target directory with
> any other program?
>
> I assume that the protection settings did not allow creating the file.
>

Manfred Hampl (m-hampl) said : #10

Adding a new file system to the fstab file and not adding access rights leads to the situation that only root can access that partition. You have to grant access right to all users who should be able to read respectively write to that file system.

What is the output of the commands (to be executed in a terminal window):

ls -la /mnt/
ls -la /mnt/sda3/

Ulrich Baustian (uhbaustian) said : #11

ulrich@lenovo:~$ ls -la /mnt/

total 16

drwxr-xr-x 4 root root 4096 Jun 22 22:21 .

drwxr-xr-x 20 root root 4096 Mai 25 20:27 ..

drwxr-xr-x 2 root root 4096 Jun 22 22:21
5884ccc1-7605-4ee0-b495-250210f11ae2

drwxr-xr-x 3 root root 4096 Jun 24 15:57 sda3

ulrich@lenovo:~$ ls -la /mnt/sda3/

total 24

drwxr-xr-x 3 root root 4096 Jun 24 15:57 .

drwxr-xr-x 4 root root 4096 Jun 22 22:21 ..

drwx------ 2 root root 16384 Jun 24 15:57 lost+found

On 24.06.20 17:50, Manfred Hampl wrote:
> ls -la/mnt/
> ls -la /mnt/sda3/

Manfred Hampl (m-hampl) said : #12

Try creating a directory for the backups and set the access rights that you can create files there.

My suggestions:

sudo mkdir /mnt/sda3/backups
sudo chown ulrich:ulrich /mnt/sda3/backups
touch /mnt/sda3/backups/testfile
ls -l /mnt/sda3/backups/

What is the output of the last command?

Ulrich Baustian (uhbaustian) said : #13

ulrich@lenovo:~$ sudo mkdir /mnt/sda3/backups
[sudo] password for ulrich:
ulrich@lenovo:~$ sudo chown ulrich:ulrich /mnt/sda3/backups
ulrich@lenovo:~$ touch /mnt/sda3/backups/testfile
ulrich@lenovo:~$ ls -l /mnt/sda3/backups/
total 0
-rw-rw-r-- 1 ulrich ulrich 0 Jun 24 22:08 testfile

On 24.06.20 21:45, Manfred Hampl wrote:
> Your question #691432 on Déjà Dup changed:
> https://answers.launchpad.net/deja-dup/+question/691432
>
> Status: Open => Answered
>
> Manfred Hampl proposed the following answer:
> Try creating a directory for the backups and set the access rights that
> you can create files there.
>
> My suggestions:
>
> sudo mkdir /mnt/sda3/backups
> sudo chown ulrich:ulrich /mnt/sda3/backups
> touch /mnt/sda3/backups/testfile
> ls -l /mnt/sda3/backups/
>
> What is the output of the last command?
>

Manfred Hampl (m-hampl) said : #14

Ok, you see that you were able to create a test file.

And now start dejadup to see whether it works as desired.

Ulrich Baustian (uhbaustian) said : #15

I have started DejaDup, but it stopped soon saying:

/Backup Failed/

/Giving up after 5 attempts. Error: Error opening file
“/mnt/sda3/duplicity-full.20200624T211124Z.vol1.difftar.gz”: Permission
denied/

Lokking into my "Backup" partition sda3 I found a folder named "backups"
which contained one file named "testfile". There is nothing else in this
partition.

On 24.06.20 22:25, Manfred Hampl wrote:
> Your question #691432 on Déjà Dup changed:
> https://answers.launchpad.net/deja-dup/+question/691432
>
> Status: Open => Answered
>
> Manfred Hampl proposed the following answer:
> Ok, you see that you were able to create a test file.
>
> And now start dejadup to see whether it works as desired.
>

Manfred Hampl (m-hampl) said : #16

This is still an access rights issue.

Which user-ID is used for running the backup job? Your own one?

The commands in comment #13 have created a "backups" directory, where you ("ulrich") have write access.
Up to now you do not have write access to the root directory of sda3.

You should use the backups subdirectory as target for the dejadup backup files (and not “/mnt/sda3/").

Another option would be to change access rights to the root directory /mnt/sda3

Ulrich Baustian (uhbaustian) said : #17

I was able to create a DejaDup backup in the directory /mnt/sda3/backups/.

Can you tell me, how I can get access right to sda3 without the
complicated commands you were asking me to run from terminal. When
formatting sda3 to NTFS then I have these access rights, why not when
formatted to EXT4?

On 25.06.20 09:41, Manfred Hampl wrote:
> Your question #691432 on Déjà Dup changed:
> https://answers.launchpad.net/deja-dup/+question/691432
>
> Status: Open => Answered
>
> Manfred Hampl proposed the following answer:
> This is still an access rights issue.
>
> Which user-ID is used for running the backup job? Your own one?
>
> The commands in comment #13 have created a "backups" directory, where you ("ulrich") have write access.
> Up to now you do not have write access to the root directory of sda3.
>
> You should use the backups subdirectory as target for the dejadup backup
> files (and not “/mnt/sda3/").
>
> Another option would be to change access rights to the root directory
> /mnt/sda3
>

Manfred Hampl (m-hampl) said : #18

NTFS is a propritetary format from Microsoft and does not care about Ubuntu access rights.
This is the reason that mounting NTFS partitions on Ubuntu may give full access for everybody.

Ulrich Baustian (uhbaustian) said : #19

Is it really that complicated to use DejaDup with Ubuntu's EXT4
formatted drives? Isn't there a command to be implemented in fstab,
which gives access rights to a partition. There is no other user than me
on this Laptop.

On 25.06.20 12:45, Manfred Hampl wrote:
> Your question #691432 on Déjà Dup changed:
> https://answers.launchpad.net/deja-dup/+question/691432
>
> Status: Open => Answered
>
> Manfred Hampl proposed the following answer:
> NTFS is a propritetary format from Microsoft and does not care about Ubuntu access rights.
> This is the reason that mounting NTFS partitions on Ubuntu may give full access for everybody.
>

Manfred Hampl (m-hampl) said : #20

There is a security concept in Ubuntu with a segregation of user areas (where each user has access to his own files and directories), and the system area where "normal users" have only read access or even no access at all, and only the administrators have read and write access.

/mnt belongs to the system area, and if you want to have user access below that, this has to be set up once (by a user with admin rights) with commands similar to the ones that I have given.

Ulrich Baustian (uhbaustian) said : #21

I thank you for your help.

 From this conversation you can learn, why Ubuntu will not become a
popular operating system. I'm a retired electronics engineer and know
computers well. I have been using Ubuntu for at least 8 years. Because
DejaDup did only work for me, when formatting the backup drive with
NTFS, I have used it that way.

Recently I looked into the Ubuntu Wiki and found no word about the
format of the backup destination. So I asked and got as a first answer,
that it should work with any format, what contradicted my experience.
Now you tell me, that I have to provide user access to the backup drive,
but you don't tell me how I get this access. Instead to tell me a way
around, by not using the hole drive, but generating a folder on that
drive with administrative rights, which then allows me to use this
folder as backup destination. Do you understand, that such a complicate
way deters every normal person to use Ubuntu?

I will return to NTFS and use DejaDup as I have used it before.

Ulrich

On 25.06.20 14:01, Manfred Hampl wrote:
> Your question #691432 on Déjà Dup changed:
> https://answers.launchpad.net/deja-dup/+question/691432
>
> Status: Open => Answered
>
> Manfred Hampl proposed the following answer:
> There is a security concept in Ubuntu with a segregation of user areas
> (where each user has access to his own files and directories), and the
> system area where "normal users" have only read access or even no access
> at all, and only the administrators have read and write access.
>
> /mnt belongs to the system area, and if you want to have user access
> below that, this has to be set up once (by a user with admin rights)
> with commands similar to the ones that I have given.
>

Launchpad Janitor (janitor) said : #22

This question was expired because it remained in the 'Open' state without activity for the last 15 days.