Could not log on to Google servers. OK

Asked by Stacy Vlasits on 2020-02-27

I have been successfully backing up my computer to Google Drive using Deja Dup from October 29, 2019 to February 13, 2020, when I upgraded from Ubuntu 19.04 to Ubuntu 19.10. Since then, I always get the "Could not log on to Google servers. OK" error message when my computer attempts to back up.

Things that have not changed:
1. My google password and account.
2. My permissions on Google Drive.
3. The location of my backup folder

What I have tried:
1. Rebooting.
2. Disconnecting and reconnecting my Google account from "Online Accounts"

Question information

Language:
English Edit question
Status:
Solved
For:
Déjà Dup Edit question
Assignee:
No assignee Edit question
Solved by:
Stacy Vlasits
Solved:
2020-03-04
Last query:
2020-03-04
Last reply:
2020-03-04
Michael Terry (mterry) said : #1

Hmm, so one big change in those two versions of deja-dup is that we changed from using GNOME's Google API keys to our own (per GNOME's request that third party apps use their own keys). So our login code for Google changed a fair bit.

Can you try the snap version (which has a few more bug fixes for Google drive support since Ubuntu 19.10 came out, which might come into play here) and see if that helps?

sudo apt remove deja-dup
snap install deja-dup --classic

Stacy Vlasits (stacyvlasits) said : #2

That worked, thanks!

Does this difference have implications for updating over the medium term? Should I avoid updating for the time begin?

Michael Terry (mterry) said : #3

If you stick with the snap version, you’ll be fine regardless of updates.

If you upgrade to Ubuntu 20.04 when it comes out, you could go back to using the distro copy if you like, but I don’t believe there’s any advantage to doing so.