deja-dup on Ubuntu 19.04 Mate Kernel 4.18 - local backup path fail

Asked by Richard Lee on 2020-01-07

I have a newly installed Ubuntu 19.04 Mate, Kernel Linux 4.18.0-25-generic x86_64

Installing Deja-dup from Snap or Terminal only installs Deja-dup 38.4 although Snap Store says the latest is 40.6
Snap says that Deja-dup 40.6 is installed, but opening shows only 38.4 installed. Does 38.4 have any bugs running on this Ubuntu build?

The problem is that the backup location always reverts to Google (cloud?). Creating a local backup location on this or any other box on the network results in a failure of the backup "Storage location not available. Waiting for Google to be configured ....".

Inspecting the Storage Location, my local location is again switched to Google.

I have uninstalled Deja-dup completely in Synaptic and command line so there are no config settings, and then reinstalling with the same result. I've done this several times doing update and upgrade between.

I've looked everywhere for a solution, and failed to find an answer. Your help is appreciated.

I have Deja-dup 37.0 running fine on a really old Acer Revo Ubuntu 16.04 LTS, and this is just fine.

Regards,
Richard lee

Question information

Language:
English Edit question
Status:
Solved
For:
Déjà Dup Edit question
Assignee:
No assignee Edit question
Solved by:
Michael Terry
Solved:
2020-01-22
Last query:
2020-01-22
Last reply:
2020-01-22
Best Michael Terry (mterry) said : #1

You might want to uninstall the system version of Deja Dup? Sounds like it’s still trying to launch that?

sudo apt remove deja-dup

Richard Lee (rlee-elite) said : #2

Thanks Michael.
I've removed deja-dup and duplicity, then reinstalled and it now works just fine
Thank you.
Richard