save &restaure vdi

Asked by pourre on 2018-03-22

I ave saved virtrualbox vdi ,and I tried to restore them , but when I open machines it looks like they do not exist anymore

Ubuntu 16.04, Virtualbox 5.04 ,guest windows 7

Question information

Language:
English Edit question
Status:
Answered
For:
Déjà Dup Edit question
Assignee:
No assignee Edit question
Last query:
2018-03-25
Last reply:
2018-03-26
Manfred Hampl (m-hampl) said : #1

Did you only backup the *.vdi file, or the whole contents of the directory (e.g. also the *.vbox file)?

pourre (jean-paul-pourre) said : #2

i tried even to restore only the vdi and also the machine itself it does not work anyway : file is not in the backup

Manfred Hampl (m-hampl) said : #3

There are different aspects to your question:

1. Was the backup process successful, such that all required files (*.vdi and *.vbox) are available inside the backup, such that they can be restored?
2. Is the restore successful?
3. How is your virtualbox system set up, e.g. what is defined as directory for the VMs; is this is line with the location to which you tried restoring the vdi (and vbox) files?

pourre (jean-paul-pourre) said : #4

The restore was not successfull : no file found !
Itried with the gui and in command line it is rhe sam .
 : file :/home/jeanpaul/VirtualBox VMs/seven 16.04 and /home/jeanpaul/VirtualBox VMs/seven 16.04/seven-16.04.vbox
So I suppose I did a wrong command when I had problems with update of VB and all has been wiped off

Manfred Hampl (m-hampl) said : #5

If you are using a file name with embedded space character on the command line, you have to mask the file name (either by enclosing it in quotes or by putting a backslash character in formt of the space character(s))
Before you give up, you should check this again.

Did you try creating a full backup, or is this an incremental backup?
You could try to check with a command like "tar tf duplicity-full.dateofbackup.vol1.difftar | grep VMs" whether the VM files/directories are contained in the backup files.

pourre (jean-paul-pourre) said : #6

I tried to look in a full backup but i may have done an error in the synthaxis:

jeanpaul@G41M-2SH:~$ tar tf '/media/jeanpaul/56825d5d-9526-4486-8de8-141bedfe5cc3/Nouvelle sauvegarde ssd/duplicity-full.20180215T084833Z.vol1.difftar | grep VMs
>
 Please Could you give me a right cammandso as to find :/home/jeanpaul/VirtualBox VMs/seven 16.04/seven-04.vdi in my backup disk before 20180301

Manfred Hampl (m-hampl) said : #7

The command that you gave is missing the closing quote (') after the file name.

try
tar tf '/media/jeanpaul/56825d5d-9526-4486-8de8-141bedfe5cc3/Nouvelle sauvegarde ssd/duplicity-full.20180215T084833Z.vol1.difftar' | grep VMs

pourre (jean-paul-pourre) said : #8

thanks I tried but tells me : no such file or folder
 jeanpaul@G41M-2SH:~$ tar tf '/media/jeanpaul/56825d5d-9526-4486-8de8-141bedfe5cc3/Nouvelle sauvegarde ssd/duplicity-full.20180215T084833Z.vol1.difftar' | grep VMs
tar: /media/jeanpaul/56825d5d-9526-4486-8de8-141bedfe5cc3/Nouvelle sauvegarde ssd/duplicity-full.20180215T084833Z.vol1.difftar : open impossible: Aucun fichier ou dossier de ce type
tar: Error is not recoverable: exiting now
jeanpaul@G41M-2SH:~$

The media in witch I am searching is the media of my backup . is that correct?

Manfred Hampl (m-hampl) said : #9

It seems that the file name of the backup was not correct, or maybe the external medium was not available at that moment.

Can you help with this problem?

Provide an answer of your own, or ask pourre for more information if necessary.

To post a message you must log in.