duplicity does not restore

Asked by Richard Müller on 2018-02-15

I have a new computer I copied all my files to - beside one I forgot. Unfortunately the original disk is formatted again so I have no access to the original file. But I have a backup on an external disk, made with deja dup. When trying to restore , I get the following error:
---------------------------------------------------------------------------
richard@nuc:~$ duplicity --no-encrypt --gio file:///media/richard/HD6-BACKUP-RI ~/restore
Achtung: Parameter --gio ist veraltet und wird in einer der nächsten Versionen entfernt.
Bitte verwenden Sie Standarddateinamen.
BackendException: Hintergrundprogramm konnte nicht initialisiert werden: No module named gi.repository
---------------------------------------------------------------------------
The OSes on the previous and the new computer are the same: Ubuntu 16.04

Is there hope?

-richard

Question information

Language:
English Edit question
Status:
Solved
For:
Déjà Dup Edit question
Assignee:
No assignee Edit question
Solved by:
Richard Müller
Solved:
2018-02-16
Last query:
2018-02-16
Last reply:
2018-02-16
Vej (vej) said : #1

Hello Richard,

can you please try to reinstall deja-dup with all recommendations and suggestions:

 sudo apt-get --reinstall --install-suggests install deja-dup

Afterwards try to restore again, and tell us if this solved your problem.

Best Regards

Vej

The error message showed up also after reinstalling. But

sudo apt-get install python-gi

solved the problem. Now I have the missing file back.
Thank you!