Backup failed with "Operation failed", unable to find any further messages

Asked by Gord on 2017-04-02

I have been using Déjà Dup on two Ubuntu 16.04 LTS systems for quite a long time. The target for the backups is a FTP server on the same network.

This week my ISP replaced my router. After this change, backups continued to work on one of the Ubuntu systems, but on the other the backup fails immediately after I respond to the password prompt with the message "Operation failed". The password is correct, and works from the other Ubuntu system. The FTP server does not log any messages that indicate that a connection was ever received. I can ping the machine with the FTP server. On the Ubuntu system, a subdirectory is created in ~/cache/deja-dup, but nothing is written in it. I have tested with the firewall disabled on the FTP server system, but the result is the same. I have tried running deja-dup --backup from the command line with environment variable DEJA_DUP_DEBUG=1 set, but the result is the same, and no information is displayed. I haven't tried running duplicity directly, because I don't know what command line Deja Dup is sending to duplicity, and I don't want to screw up my existing backups.

I expect that I have missed a change somewhere that is resulting in this failure, but I can't find any log that would help me to identify the problem.

Any suggestions as to how I can obtain more information from Deja Dup so that I can fix my problem?

Thanks!

Question information

Language:
English Edit question
Status:
Answered
For:
Déjà Dup Edit question
Assignee:
No assignee Edit question
Last query:
2017-04-02
Last reply:
2017-04-02
Vej (vej) said : #1

Hello Gord!

> Any suggestions as to how I can obtain more information from Deja Dup so that I can fix my problem?

You could have a look at your full settings

gsettings list-recursively org.gnome.DejaDup

and compare them to the output from the other computer to look for differences.

If you open a bug report, you should also note, if the prompt comes back after running "DEJA_DUP_DEBUG=1 deja-dup --backup" or if the program runs (i.e. waits) forever.

Gord (gord-tomlin) said : #2

Full settings from the failing machine:

gord@CSI09-Ubuntu:~$ gsettings list-recursively org.gnome.DejaDup
org.gnome.DejaDup last-restore ''
org.gnome.DejaDup periodic true
org.gnome.DejaDup full-backup-period 90
org.gnome.DejaDup backend 'file'
org.gnome.DejaDup last-run '2017-03-24T16:46:08.174079Z'
org.gnome.DejaDup nag-check '2016-12-21T19:42:36.134680Z'
org.gnome.DejaDup prompt-check 'disabled'
org.gnome.DejaDup root-prompt true
org.gnome.DejaDup include-list ['$HOME']
org.gnome.DejaDup exclude-list ['$TRASH', '$DOWNLOAD']
org.gnome.DejaDup last-backup '2017-03-24T16:46:08.174079Z'
org.gnome.DejaDup periodic-period 7
org.gnome.DejaDup delete-after 182
org.gnome.DejaDup.S3 id ''
org.gnome.DejaDup.S3 bucket ''
org.gnome.DejaDup.S3 folder 'CSI09-Ubuntu'
org.gnome.DejaDup.OpenStack authurl ''
org.gnome.DejaDup.OpenStack tenant ''
org.gnome.DejaDup.OpenStack username ''
org.gnome.DejaDup.OpenStack container 'CSI09-Ubuntu'
org.gnome.DejaDup.GCS id ''
org.gnome.DejaDup.GCS bucket ''
org.gnome.DejaDup.GCS folder 'CSI09-Ubuntu'
org.gnome.DejaDup.GDrive email ''
org.gnome.DejaDup.GDrive folder '/deja-dup/CSI09-Ubuntu'
org.gnome.DejaDup.Rackspace username ''
org.gnome.DejaDup.Rackspace container 'CSI09-Ubuntu'
org.gnome.DejaDup.File path 'ftp://backupuserid@192.168.2.10:21/CSI09/Ubuntu'
org.gnome.DejaDup.File short-name ''
org.gnome.DejaDup.File uuid ''
org.gnome.DejaDup.File icon ''
org.gnome.DejaDup.File relpath @ay []
org.gnome.DejaDup.File name ''
org.gnome.DejaDup.File type 'normal'

Settings are the same on the non-failing machine, except for time stamps, system names, and subfolder on the FTP server.

Running "DEJA_DUP_DEBUG=1 deja-dup --backup" results: in:
1. "Connect to Server" window is displayed.
2. Enter password and check "Remember password" and click "Continue"
3. "Backup Failed" window with message "Operation failed" is displayed.
4. Click "Close"
5. The command prompt comes back. No messages are displayed in the command window.

Can you help with this problem?

Provide an answer of your own, or ask Gord for more information if necessary.

To post a message you must log in.