'Software is not from a trusted location - do not install unless you are sure it is safe to do so' error message in Ubuntu 16.10

Asked by John Camp on 2017-03-19

I have recently installed Ubuntu 16.10 on my HP desktop. (Well, via an ext HDD)

I clicked on the Backups 'safe' icon within System Settings and then clicked on the icon next to the instruction to 'download some necessary software'. The brings up a prompt to install the software, but with a warning that 'the software is not from a trusted source - do not install unless you are sure that it is safe to do so'. I'm still finding my way around Ubuntu so I'm not sure and opted to cancel. Everything else seems fine apart from that.

Has anyone else had this problem? Is there a fix?

BTW - I have Ubuntu 16.04 installed on my laptop and the same backup software works fine on that machine.

(I should mention that I'm pretty new to Ubuntu - just finding my way around at the moment really.)

Thanks in anticipation.

John

Question information

Language:
English Edit question
Status:
Solved
For:
Déjà Dup Edit question
Assignee:
No assignee Edit question
Solved by:
John Camp
Solved:
2017-03-21
Last query:
2017-03-21
Last reply:
2017-03-20
Manfred Hampl (m-hampl) said : #1

On the machine that shows that message open a terminal window (e.g. by simultaneously pressing ctrl-alt-t) and issue the command

sudo apt-get update

Provide your password when asked.
What output do you receive?

John Camp (john60) said : #2

Hi Manfred

Thanks for quick reply.
I've copied this manually so apologies if there are any errors:

Hit:1 http://gbarchive.ubuntu.com/ubuntu yakkety InRelease
Get: 2 http://security.ubuntu.com/ubuntu yakkety-security InRelease [102 KB]
Get: 3 http://gb.archive.ubuntu.com/ubuntu yakkety-updates InRelease [102 KB]
Get: 4 http://gb.archive.ubuntu.com/ubuntu-backports InRelease [102KB]
Fetched 306 Kb in 1s (284 KB/s]
Reading package lists...Done

(BTW - the ctrl-alt-d command didn't do anything so I just opened up the terminal via the Dash)

Manfred Hampl (m-hampl) said : #3

(It is ctrl-alt-t, not ctrl-alt-d for opening a terminal window.
You could have used copy and paste by using the terminal window's menu entries "edit - select all" and "edit - copy")

the output of the apt-get update command does not show any problem with verifying the repository sources.
Is there any additional information in the window when it shows that "untrusted source" warning?

John Camp (john60) said : #4

OK. Sorry - I don't know what happened there.

Well, apart from the untrusted source warning (with a red ! mark) there is what looks like a standard 'authentication required' message above the box to enter the password to allow the installation.

Then below the password box there's a 'details' flag, and after clicking on that I get two links:

Action: org.freedesktop.packagekit.package-install-untrusted

Vendor: The Packagekit Project

Vej (vej) said : #5

@John Déjà Dup uses PackageKit to install that piece of software (see bug #1641423).

@Manfred: If you do not want to trust that source, you might close it and try "sudo apt-get deja-dup-backend-gvfs" from your terminal. After rebooting your machine Déjà Dup should recognize the installed backend and allow you to use it without further installations.

Vej (vej) said : #6

Sorry, for mixing you names in my last comment!

Manfred Hampl (m-hampl) said : #7

No problem for me with mixing uo the names.

The command most probably has to be

sudo apt-get install deja-dup-backend-gvfs

John Camp (john60) said : #8

I've now gone into the terminal and used Manfred's version of the command above (ie, with 'install' included) and that seems to have sorted it out. I rebooted the machine and was then able to open deja dup straight away and run the backup with no further problem or error messages.

Many thanks to you both for your help and patience..!

I'm now signing it off as Problem Solved.