Déjà Dup Backup Tool

I lost the manifest file of my backup. What can I do?

Asked by David Gomes on 2011-09-16

I backed up a lot of folders into my USB Drive. I saved the content of the USB drive to a computer (I didn't restore it, I just saved all the files). Then I formatted the USB Drive, used it for other stuff, and went back to get all the files onto the USB Drive.

Basically, I had all the original files. However, I think I don't have the "manifest" file, I just have a lot of .difftar.gz folders.

When I open Déjà Dup and press "Restore", I get "No backups to restore", and all the .difftar.gz folders are merged into one .sigtar.gz folder.

This sigtar.gz folder is extractable, I extracted all the files. At first, I was happy that I still had my files. However, I can't open any of the files. Icons are missing, pictures are not viewable, text files are not openable, binary files can't be opened.

What can I do to get my files back? I know they're there, they have the original size, I just can't open them. They are not "empty".

Thanks.

Question information

Language:
English Edit question
Status:
Answered
For:
Déjà Dup Edit question
Assignee:
No assignee Edit question
Last query:
2011-09-19
Last reply:
2011-09-19
Michael Terry (mterry) said : #1

It sounds like originally you only copied anything that ended in .gz? Which missed the manifest file.

Then, when you tried to restore from that set of files, Deja Dup noticed that you had an incomplete backup set (i.e. without the manifest file) and kindly (it thought) decided to delete the files for you, since it isn't restorable. (In the development version of Deja Dup, it no longer does this -- it will never delete files when in restore mode.)

I believe that while it deleted the difftar.gz volumes, it left the sigtar.gz file alone. So it's not that the files got merged into that one file, just that the difftar.gz files got deleted.

When extracting the sigtar.gz file, yes, you can see all the files, but that's not their real data. It's just some metadata about each one. That's why the icons are missing and they are not viewable.

So, I'm sorry, but it seems like Deja Dup ate your files because of the missing manifest file. Do you have another copy of the volume files?

David Gomes (davidgomes) said : #2

Fortunately, I made a backup of the backup and I have all the files. I have all the difftar.gz files. I have tried several times to restore them, but it always "eats" the files and creates a sigtar.gz.

But I have all the difftar.gz files, what can I do?

Michael Terry (mterry) said : #3

Oh, great. Good caution. :)

So, I don't know of a way to manually recreate the manifest file, but I do know how to manually extract the difftar.gz files:
https://live.gnome.org/DejaDup/Help/Restore/WorstCase#Restoring_by_Hand

Jarl Arntzen (jarl-arntzen) said : #4

That's just crazy scary. I was going to pose a question about the robustness of the backup files: how much it would take to render your backed up files totally useless. Seems like it only takes one failed manifest file and your files are not only harder to recover, but they're also being actively deleted by Deja.

Deja, what happened? You seemed so friendly with your uncomplicated user interface.... :)

Can you help with this problem?

Provide an answer of your own, or ask David Gomes for more information if necessary.

To post a message you must log in.