Change logs for ipe source package in Sid

  • ipe (7.2.17-2) unstable; urgency=medium
    
      [ Steve Robbins ]
      * push to unstable.
    
     -- Steve M. Robbins <email address hidden>  Sun, 21 Jun 2020 11:49:39 -0500
  • ipe (7.2.15-1) unstable; urgency=medium
    
      [ Steve Robbins ]
      * New upstream version 7.2.15
      * Rebase patches
    
     -- Steve M. Robbins <email address hidden>  Mon, 27 Apr 2020 00:51:26 -0500
  • ipe (7.2.13-2) unstable; urgency=medium
    
      [ Steve Robbins ]
      * Adhere to environment PKG_CONFIG setting, to enable cross-build.
        Closes: #888522. Thanks to Helmut Grohne for the patch.
    
     -- Steve M. Robbins <email address hidden>  Sun, 19 Jan 2020 13:23:26 -0600
  • ipe (7.2.13-1) unstable; urgency=medium
    
      [ Steve Robbins ]
      * New upstream version 7.2.13.  Closes: #942780.
    
     -- Steve M. Robbins <email address hidden>  Fri, 17 Jan 2020 12:48:55 -0600
  • ipe (7.2.9-1) unstable; urgency=medium
    
      [ Steven Robbins ]
      * New upstream.
      * [b1a5fd4] Update packaging for IPE version 7.2.9.
      * [9bd4957] ipe depends on sensible-utils
    
     -- Steve M. Robbins <email address hidden>  Sun, 27 Jan 2019 23:43:18 -0600
  • ipe (7.2.7-3) unstable; urgency=medium
    
      * Team upload.
      * Moved packaging from SVN to Git
      * cme fix dpkg-control
      * debhelper 11
      * Standards-Version: 4.1.3
      * Fix build issue with glibc >= 2.26
        Closes: #887693
      * hardening=+all
    
     -- Andreas Tille <email address hidden>  Thu, 25 Jan 2018 14:23:21 +0100
  • ipe (7.2.7-2) unstable; urgency=medium
    
      * Team upload.
      * patches/wheel-zoom-debug.patch: New patch; removes unwanted noisy debug
        output. Closes: #851303.
    
     -- James Clarke <email address hidden>  Wed, 18 Jan 2017 14:18:03 +0000
  • ipe (7.2.7-1) unstable; urgency=medium
    
      * New upstream.
      * Remove obsolete debian/ipe.png.uu.
    
     -- Steve M. Robbins <email address hidden>  Tue, 27 Dec 2016 21:42:30 -0600
  • ipe (7.2.6-1) unstable; urgency=medium
    
      * New upstream.
      * patches/default-browser.patch: Drop.  Now uses xdg-open for prefs.
    
     -- Steve M. Robbins <email address hidden>  Mon, 10 Oct 2016 04:00:55 -0500
  • ipe (7.2.4-1) unstable; urgency=medium
    
      * New upstream.
      * patches/build-nostrip.patch: Remove.  Applied upstream.
      * Refreshed other patches.
    
     -- Steve M. Robbins <email address hidden>  Fri, 24 Jun 2016 21:57:11 -0500
  • ipe (7.1.10-2) unstable; urgency=medium
    
      * patches/fix-moc.patch: Remove.  Use QT_SELECT to tell qtchooser which
        version of Qt we want.
    
      * control: Revert back to libjpeg-dev.  Appreciate the gentle prodding
        by all.  Closes: #805852, #814873.
    
     -- Steve M. Robbins <email address hidden>  Tue, 03 May 2016 23:04:20 -0500
  • ipe (7.1.10-1.1) unstable; urgency=medium
    
      * Non-maintainer upload.
      * Change libpng12-dev build-dependency to libpng-dev, to ease libpng
        transition. (Closes: #810188)
    
     -- Gianfranco Costamagna <email address hidden>  Fri, 22 Jan 2016 11:09:34 +0100
  • ipe (7.1.10-1) unstable; urgency=medium
    
      * New upstream.
      * control: adjust build-dependencies.  Now builds with Qt5.
      * patches/fPIC.patch: Remove.  Applied upstream.
      * patches/default-browser.patch: New.  Configure to use sensible-browser.
      * patches/fix-moc.patch: New.  Temporary workaround for #805726.
      * patches/default-editor.patch: Fix error in patch.  Closes: #728480.
    
     -- Steve M. Robbins <email address hidden>  Sat, 21 Nov 2015 10:15:22 -0600
  • ipe (7.1.8-1) unstable; urgency=medium
    
      * New upstream.
    
     -- Steve M. Robbins <email address hidden>  Sun, 13 Sep 2015 09:27:23 -0500
  • ipe (7.1.4-2.1) unstable; urgency=medium
    
      * Non-maintainer upload.
      * Rename library packages for g++5 ABI transition. (Closes: #791079)
    
     -- Martin Pitt <email address hidden>  Wed, 05 Aug 2015 12:02:06 +0200
  • ipe (7.1.4-2) unstable; urgency=low
    
    
      * copyright: Updated with patch from Felix Geyer.  Closes: #729740.
      * patches/default-editor.patch: New.  Change hardcoded default editor
        (when EDITOR not defined) to "xterminal-emulator -e editor", as
        suggested by Francesco Poli.  Closes: #728480.
    
     -- Steve M. Robbins <email address hidden>  Sat, 30 Nov 2013 22:28:30 -0600
  • ipe (7.1.4-1) unstable; urgency=low
    
    
      * New upstream.  Closes: #703269.
    
     -- Steve M. Robbins <email address hidden>  Mon, 04 Nov 2013 23:10:27 -0600
  • ipe (7.1.3-1) unstable; urgency=low
    
    
      * New upstream.  Update to standards-version 3.9.4, debhelper compat
        level 9.
    
     -- Steve M. Robbins <email address hidden>  Mon, 21 Jan 2013 00:11:36 -0600
  • ipe (7.1.2-1) unstable; urgency=low
    
    
      * New upstream.
      
      * ipe.preinst: New.  Remove old directory /usr/share/doc/ipe/doc if it
        exists on upgrade.  That path is now a symlink, but linking fails if
        the directory is there.  Closes: #654922.
    
     -- Steve M. Robbins <email address hidden>  Sun, 15 Jan 2012 22:33:06 -0600
  • ipe (7.1.1-1) unstable; urgency=low
    
    
      * New upstream.
        - Re-enabled compilation of omitted image ipelet.  Closes: #651594
      
      * debian/patches/fPIC.patch: New.  Build using -fPIC instead of -fpic.
        Closes: #641082.
    
     -- Steve M. Robbins <email address hidden>  Sat, 10 Dec 2011 16:55:09 -0600
  • ipe (7.1.0-1) unstable; urgency=low
    
    
      * New upstream version.
    
     -- Steve M. Robbins <email address hidden>  Tue, 30 Aug 2011 00:20:55 -0500
  • ipe (7.0.14-1) unstable; urgency=low
      * New upstream.  Update control, rules.    * libipe7.0.13.install:  * ipe.links: Remove.  Replace with explicit calls in rules using    $(IPEVERS).  Fixes lua link.  Closes: #611560. -- Steve M. Robbins <email address hidden>  Tue, 15 Feb 2011 23:06:48 -0600
  • ipe (7.0.10-2) unstable; urgency=low
    
    
      * control(ipe): Change dependency on lua interpreter (lua5.1) from
        depends to recommends.  Closes: #561721.
      
      * patches/build-nostrip.patch: New.  Install in staging directory
        without stripping, so that DEB_BUILD_OPTION 'nostrip' can be honoured.
        Closes: #437230.
      
      * rules: Install fontmap.xml correctly. Install ipe.so symlink in lua's
        package.cpath so that lua scripts can find ipe.  Closes: #562785.
    
     -- Steve M. Robbins <email address hidden>  Sun, 27 Dec 2009 18:11:32 -0600
  • ipe (7.0.10-1) unstable; urgency=low
    
    
      * New upstream.  Closes: #551192.
        - New build-depends: libcairo2-dev, liblua5.1-0-dev, gsfonts
        - patches/config.diff: Remove.  Upstream build system replaced.
        - Runtime lib package changed to libipe7.0.10 from libipe1c2a
        - Devel package renamed to libipe-dev (from libipe1-dev)
        - Package ipe depends on lua5.1 due to ipe-update-master.
      
      * rules: Re-write to use dh.
    
     -- Steve M. Robbins <email address hidden>  Fri, 11 Dec 2009 21:22:35 -0600
  • ipe (6.0pre32patch1-1) unstable; urgency=low
    
    
      * New upstream.
        - debian/patches/fix-version.diff: Remove.  Applied upstream.
        - debian/control: Remove conflicts with libfreetype6; upstream has
          removed run-time checks.
    
     -- Steve M. Robbins <email address hidden>  Sat, 09 May 2009 12:15:53 -0500
  • ipe (6.0pre32-2) unstable; urgency=low
    
    
      * debian/control: Update to build with freetype 2.3.9.  Update
        Standards-Version to 3.8.1.0; no changes required.
    
     -- Steve M. Robbins <email address hidden>  Sun, 15 Mar 2009 00:09:40 -0500
  • ipe (6.0pre32-1) unstable; urgency=low
    
    
      * New upstream.
        - debian/patches/fix-version.diff: New.  Set IPEVERS correctly.
        - debian/patches/update-webpages.diff: Remove.  Applied upstream.
    
     -- Steve M. Robbins <email address hidden>  Sun, 30 Nov 2008 22:10:26 -0600
  • ipe (6.0pre31-1) unstable; urgency=low
    
    
      * New upstream.
        - debian/patches/gcc43.diff
        - debian/patches/ipe-bug-253.diff:
        - debian/patches/decimal-point.patch: Remove.  Applied upstream.
        - debian/patches/config.diff: Remove IPEBROWSER hunk; upstream changed
          it to sensible-browser.
    
     -- Steve M. Robbins <email address hidden>  Fri, 07 Nov 2008 04:25:40 -0600
  • ipe (6.0pre30-5) unstable; urgency=low
    
    
      * debian/control: Adjust dependencies for freetype 2.3.7.  Replace
        recommends of "latex-ucs" by "texlive-latex-recommended".
    
     -- Steve M. Robbins <email address hidden>  Fri, 04 Jul 2008 21:59:45 -0500