Change logs for inkscape source package in Sid

  • inkscape (1.0-5) unstable; urgency=medium
    
      * Add patch from upstream to allow users to resize the document property
        dialog again.  Closes: #962185
    
     -- Mattia Rizzolo <email address hidden>  Thu, 30 Jul 2020 14:37:18 +0200
  • inkscape (1.0-4) unstable; urgency=medium
    
      * Add patch from upstream to fix crash using some cursors under Wayland.
        Closes: #965969
    
     -- Mattia Rizzolo <email address hidden>  Wed, 22 Jul 2020 12:13:47 +0200
  • inkscape (1.0-3) unstable; urgency=medium
    
      [ shouhuanxiaoji ]
      * d/rules: Fix typo in dh_missing override.  MR: !2
    
      [ Mattia Rizzolo ]
      * d/rules: Drop now unneeded dh_missing override.
      * Rebuild against glibmm2.4/2.64.2-2 to pick up the proper versioned
        dependency.  Closes: #964390
    
     -- Mattia Rizzolo <email address hidden>  Mon, 06 Jul 2020 19:53:49 +0200
  • inkscape (1.0-2) unstable; urgency=medium
    
      * d/rules:
        + Don't run dwz when building for buster-backports.
        + Build with -DCMAKE_BUILD_TYPE=Release.  Closes: #960955, #962934
    
     -- Mattia Rizzolo <email address hidden>  Wed, 24 Jun 2020 18:29:43 +0200
  • inkscape (1.0-1) unstable; urgency=medium
    
      [ Mattia Rizzolo ]
      * New upstream version 1.0.  LP: #1876996
        https://wiki.inkscape.org/wiki/index.php/Release_notes/1.0
        https://inkscape.org/release/inkscape-1.0/
        https://inkscape.org/news/2020/05/04/introducing-inkscape-10/
      * d/watch: Update to point at the new source archive.
      * Update Marc Jeanmougin's upstream gpg key.
      * Refresh patches.
      * Bump debhelper compat level to 13.
    
      [ Gianfranco Costamagna ]
      * Increase test timeout to 3 minutes instead of 1, to avoid failures when
        a slow machine runs tests (such as riscv64 that is emulated in Ubuntu).
    
     -- Mattia Rizzolo <email address hidden>  Thu, 07 May 2020 20:57:39 +0200
  • inkscape (1.0~rc1-4) unstable; urgency=medium
    
      * d/rules: Fix architecture match, only make the testsuite fata on little
        endian architectures.
    
     -- Mattia Rizzolo <email address hidden>  Mon, 27 Apr 2020 22:58:01 +0200
  • inkscape (1.0~rc1-3) unstable; urgency=medium
    
      * d/rules:
        + Use the correct variable used as cmake's build directory.
        + Only consider the testsuite fatal on amd64 and arm64.
    
     -- Mattia Rizzolo <email address hidden>  Mon, 27 Apr 2020 14:40:49 +0200
  • inkscape (1.0~rc1-2) unstable; urgency=medium
    
      * Add a patch to add -latomic to the linker flags when needed.
        This should fix FTBFS in armel, mipsel, m68k and sh4.
      * Run the testsuite at build time, add Build-Dep on imagemagick for that.
      * Upload to unstable.
    
     -- Mattia Rizzolo <email address hidden>  Mon, 27 Apr 2020 11:58:44 +0200
  • inkscape (0.92.5-1) unstable; urgency=medium
    
      * New upstream version 0.92.5.
        https://wiki.inkscape.org/wiki/index.php/Release_notes/0.92.5
        This is only a bugfix release.
      * d/upstream/signing-key.asc:
        + Add back Marc Jeanmougin's upstream key.
        + Refresh upstream signing keys.
      * Drop patches applied upstream
      * debian/inkscape.mime: drop quoting around filename placeholder.
        See lintian's quoted-placeholder-in-mailcap-entry.
      * d/control: Bump Standards-Version to 4.5.0, no changes needed.
    
     -- Mattia Rizzolo <email address hidden>  Mon, 13 Apr 2020 15:10:28 +0200
  • inkscape (0.92.4-5) unstable; urgency=medium
    
      * Fix syntax error in a patch that would prevent building the package
        against an older version of cairo.
        Thanks to Thomas Arendsen Hein <email address hidden> for reporting.
    
     -- Mattia Rizzolo <email address hidden>  Thu, 06 Feb 2020 14:43:49 +0100
  • inkscape (0.92.4-4) unstable; urgency=medium
    
      * Add patch from upstream to fix FTBFS with poppler 0.76.
      * d/control: Bump Standards-Version to 4.4.1, no changes needed.
    
     -- Mattia Rizzolo <email address hidden>  Fri, 04 Oct 2019 22:33:06 +0200
  • inkscape (0.92.4-3) unstable; urgency=medium
    
      * Add patch from upstream master branch to output a useful error if the
        tutorials aren't installed.  LP: #1803021
      * d/control: switch Recommends from non-existent transfig to fig2dev.
        Closes: #925171
    
     -- Mattia Rizzolo <email address hidden>  Wed, 20 Mar 2019 21:54:39 +0100
  • inkscape (0.92.4-2) unstable; urgency=medium
    
      [ Matteo F. Vescovi ]
      * debian/control: drop myself from Uploaders.
    
      [ Mattia Rizzolo ]
      * Add a patch to update the appstream data file.  Closes: #920338
    
     -- Mattia Rizzolo <email address hidden>  Thu, 24 Jan 2019 19:29:41 +0100
  • inkscape (0.92.4-1) unstable; urgency=medium
    
      * New upstream version 0.92.4.
        http://wiki.inkscape.org/wiki/index.php/Release_notes/0.92.4
        https://inkscape.org/news/2019/01/17/inkscape-launches-version-0924/
      * d/patches:
        + Remove patches applied upstream.
        + Add patch to fix a spelling error.
      * d/control:
        + Bump debhelper compat level to 12.
        + Bump Standards-Version to 4.3.0, no changes needed.
        + Add a Build-Depends on libgmock-dev.
      * Update upstream signing key.
    
     -- Mattia Rizzolo <email address hidden>  Thu, 17 Jan 2019 20:46:29 +0100
  • inkscape (0.92.3-7) unstable; urgency=medium
    
      * Team upload.
      * Add patch from upstream to fix build with poppler 0.71
    
     -- Jeremy Bicha <email address hidden>  Sun, 25 Nov 2018 08:08:16 -0500
  • inkscape (0.92.3-6) unstable; urgency=medium
    
      * d/watch: fix a few syntax errors.  Thanks to yadd for pointing them out.
      * Add patch from upstream to fix crashes during shift/ctrl+click actions.
        Closes: #911652
      * Override lintian tag autotools-pkg-config-macro-not-cross-compilation-safe,
        as we are not using autotools.
    
     -- Mattia Rizzolo <email address hidden>  Mon, 05 Nov 2018 20:23:06 +0100
  • inkscape (0.92.3-5) unstable; urgency=medium
    
      * Re-arrenge the patch files.
      * Add patch from upstream to fix build with poppler 0.69.  Closes: #910867
      * Use the new debhelper-compat(=11) notation and drop d/compat.
      * Try to simplify d/watch using substitution patterns.
    
     -- Mattia Rizzolo <email address hidden>  Sat, 13 Oct 2018 12:48:22 +0200
  • inkscape (0.92.3-4) unstable; urgency=medium
    
      [ Mattia Rizzolo ]
      * d/bash-completion: fix completion to use the runtime-evaluating _have()
        instead of the static check have().  LP: #1792835
      * Mark inkscape-tutorials as Multi-Arch:foreign (from the m-a hinter).
      * Bump Standards-Version to 4.2.1, no changes needed.
      * Add patch from upstream to make the command-line PDF output reproducible.
        Thanks to Chris Lamb <email address hidden> for the patch!  Closes: #893314
    
      [ Andrej Shadura ]
      * Add patch from upstream to fix crash when resizing elements with snapping
        enabled.  Closes: #910379; LP: #1796046
    
     -- Mattia Rizzolo <email address hidden>  Mon, 08 Oct 2018 11:27:04 +0200
  • inkscape (0.92.3-3) unstable; urgency=medium
    
      * Team upload.
      * Backport 2 patches to fix build with poppler 0.65
    
     -- Jeremy Bicha <email address hidden>  Sat, 25 Aug 2018 10:29:08 -0400
  • inkscape (0.92.3-2) unstable; urgency=medium
    
      * d/control: Bump Standards-Version to 4.1.4, no changes needed.
      * Split the tutorials on their own inkscape-tutorials binary, and don't
        install them by default.  Closes: #471076; LP: #238276
    
     -- Mattia Rizzolo <email address hidden>  Mon, 21 May 2018 16:22:40 +0200
  • inkscape (0.92.3-1) unstable; urgency=medium
    
      * New upstream version 0.92.3.
        http://wiki.inkscape.org/wiki/index.php/Release_notes/0.92.3
        https://inkscape.org/en/news/2018/03/22/announcing-0923-release-inkscape
    
     -- Mattia Rizzolo <email address hidden>  Fri, 23 Mar 2018 17:43:46 +0100
  • inkscape (0.92.3~pre0-1) unstable; urgency=medium
    
      [ Mattia Rizzolo ]
      * New upstream version 0.92.3~pre0.
        http://wiki.inkscape.org/wiki/index.php/Release_notes/0.92.3
        + Compact layout for Document Properties.  Closes: #867083; LP: #1510831
      * d/control: Update Maintainer address to move away from alioth.
      * Rename d/mime to d/inkscape.mime for consistency.
      * Drop patch for poppler 0.58, applied upstream.
    
      [ Ondřej Nový ]
      * d/control: Set Vcs-* to salsa.debian.org
    
     -- Mattia Rizzolo <email address hidden>  Mon, 05 Mar 2018 21:53:25 +0100
  • inkscape (0.92.2-3) unstable; urgency=medium
    
      * Bump debhelper compat level to 11.
      * Stop using gnome-pkg-tools.
        inkscape in Ubuntu has been demoted from main to universe, so there is
        no need to do anything regarding language packs.  Closes: #885108
      * Rename d/docs to d/inkscape.docs for clearity.
      * debian/control:
        + Drop unused build-dependency on libart-2.0-dev.  Closes: #885794
        + Bump Standards-Version to 4.1.3, no changes needed.
        + Set Rules-Requires-Root: no.
    
     -- Mattia Rizzolo <email address hidden>  Sat, 30 Dec 2017 23:15:28 +0100
  • inkscape (0.92.2-2) unstable; urgency=medium
    
      * debian/control:
        + Remove alternative suggestion of dia-gnome, not available anymore
          Closes: #878585
        + Bump Standards-Version 4.1.2, no changes needed.
      * Add patch from upstream to fix build with poppler 0.58.  Closes: #883519
    
     -- Mattia Rizzolo <email address hidden>  Mon, 04 Dec 2017 21:02:35 +0100
  • inkscape (0.92.2-1) unstable; urgency=medium
    
      * New upstream version 0.92.2.
        http://wiki.inkscape.org/wiki/index.php/Release_notes/0.92.2
        + Fix PDF+TeX output for text inside groups with clip/mask.
          Closes: #823953; LP: #1417470
      * Update the upstream signing keys.
      * Bump Standards-Version to 4.0.1, no changes needed.
    
     -- Mattia Rizzolo <email address hidden>  Wed, 09 Aug 2017 11:36:38 +0200
  • inkscape (0.92.2~pre0-1) unstable; urgency=medium
    
      * New upstream version 0.92.2~pre0.
        http://wiki.inkscape.org/wiki/index.php/Release_notes/0.92.2
        + Fix an integer overflow.  Closes: #838654
        + Fix compilation with GCC 7.  Closes: #853453
      * d/dirs: remove, useless.
      * d/patches: drop 15484 patch, applied upstream.
      * d/control: bump Standards-Version to 4.0.0, no changes needed.
    
     -- Mattia Rizzolo <email address hidden>  Wed, 26 Jul 2017 16:07:58 +0200
  • inkscape (0.92.1-1) unstable; urgency=medium
    
      * New upstream version 0.92.1.
        http://wiki.inkscape.org/wiki/index.php/Release_notes/0.92.1
        + Fixes a bug involving the line-height CSS property.  Closes: #852837
      * Remove patches applied upstream.
      * Backport patch from upstream trunk:
        + 15848: support for old scour 0.26.  Closes: #852290
    
     -- Mattia Rizzolo <email address hidden>  Thu, 16 Feb 2017 11:32:16 +0100
  • inkscape (0.92.0-4) unstable; urgency=medium
    
      * Backport more patches from upstream 0.92.x branch
        + 15320: Fix regression on selecting objects after locking layers
        + 15323: Fix crash on ungrouping in v0.92
        + 15324: Fix nsane memory leak and crash with pattern along path
        + 15325: Fixes bugs in copy LPE's
      * Move patches from upstream's 0.92.x branch under the upstream/0.92.x
        directory, and the ones from trunk under upstream/trunk,
        and name them after the upstream commit number.
    
     -- Mattia Rizzolo <email address hidden>  Sun, 22 Jan 2017 20:45:39 +0100
  • inkscape (0.92.0-3) unstable; urgency=medium
    
      * d/rules: don't run dh_scour, to avoid breaking internal SVGs (markers, …).
        LP: #1638373
    
     -- Mattia Rizzolo <email address hidden>  Thu, 12 Jan 2017 01:05:44 +0100
  • inkscape (0.92.0-2) unstable; urgency=medium
    
      * Upload to unstable.
      * Gbp: back to master.
      * d/control:
        + require a new enough version of bash-completion, so backports users will
          still have bash completion after the upgrade.
        + Recommend python-scour to enable the feature "save as optimized svg".
      * New patches from upstream trunk:
        + 0002-Fix-lintian-s-executable-not-elf-or-script.patch
        + 0003-Install-the-localized-manpages-in-the-correct-path.patch
        + 0006-Suppress-warnings-on-symbols-dialog.patch
      * New patches waiting to be upstreamed:
        + 0004-typos-libcroco.patch
        + 0005-Fix-typo-in-a-variable-name.patch
      * d/inkscape.lintian-overrides: drop, lintian warnings fixed by properly
        installing the manpages.
    
     -- Mattia Rizzolo <email address hidden>  Mon, 09 Jan 2017 15:03:04 +0100
  • inkscape (0.91-12) unstable; urgency=medium
    
      [ Daniel Kahn Gillmor ]
      * d/control: Use https for the Homepage field.
    
      [ Mattia Rizzolo ]
      * Add patch to fix cursor colors when running in a Big Endian systems.
        Thanks to Steven Gawroriski <email address hidden> for the patch.
        Closes: #841853
      * Mark the reproducible-builds patch as forwarded (and applied).
    
     -- Mattia Rizzolo <email address hidden>  Fri, 11 Nov 2016 16:57:07 +0000
  • inkscape (0.91-11) unstable; urgency=medium
    
      * Build with gnome-pkg-tools for automatic langpack support in Ubuntu.
        This will allow to drop the last delta between Debian and Ubuntu.
        Thanks to Jeremy Bicha <email address hidden> for the patch.
    
     -- Mattia Rizzolo <email address hidden>  Tue, 06 Sep 2016 08:50:37 +0000
  • inkscape (0.91-10) unstable; urgency=medium
    
      * Add patch to fix compilation with gcc-6 (with --std=c++14).  Closes: #835716
    
     -- Mattia Rizzolo <email address hidden>  Fri, 02 Sep 2016 15:04:34 +0000
  • inkscape (0.91-9) unstable; urgency=medium
    
      * Disable gnome-vfs support.  Closes: #822912
      * debian/rules:
        + Remove dh_auto_configure override: those are default options anyway.
        + Remove useless variable definitions.
    
     -- Mattia Rizzolo <email address hidden>  Fri, 29 Apr 2016 15:45:03 +0000
  • inkscape (0.91-8) unstable; urgency=medium
    
      * debian/control:
        + Use my @debian.org email address.
        + Bump Standards-Version to 3.9.8, no changes needed.
        + Use HTTPS in Vcs-Git.
        + Demote pstoedit to Suggests.
        + Document suggested packages.  Closes: #771807
      * debian/watch: rewrite, using format=4 and pgpmode=next/prev to allow gpg
        verification of the tarball.
        Thanks to Osamu Aoki <email address hidden> for the help and for implementing
        all this new stuff in devscripts.
      * debian/inkscape.menu: remove, after CTTE's decision in #741573.
      * debian/patches/fix-FTBFS.patch: backport patch from upstream to fix FTBFS
        with a glibmm without Glib::ScopedPtr.  Closes: #822392
    
     -- Mattia Rizzolo <email address hidden>  Tue, 26 Apr 2016 22:06:31 +0000
  • inkscape (0.91-7) unstable; urgency=medium
    
      * debian/control: change build-dependency on libgsl0-dev to libgsl-dev.
        Closes: #806833
    
     -- Mattia Rizzolo <email address hidden>  Wed, 02 Dec 2015 06:48:27 +0000
  • inkscape (0.91-6) unstable; urgency=medium
    
      * debian/rules: stop handling DEB_BUILD_OPTIONS=noopt on our own, nowadays
        dpkg takes care of that.
      * debian/watch: rewrite to point at launchpad.net and improve it.
      * use dh_bash-completion to handle the bash completion. (This also fixes the
        package-installs-into-obsolete-dir lintian warning when using
        bash-completion >= 1:2.1-4.2).
        + debian/inkscape.maintscript: also remove the bash completion from /etc.
      * debian/upstream/signing-key.asc: add, with the key of the 3 inkscape
        release managers. We can't currently automate the signature check in
        debian/watch because they seems to do not use a costant suffix for the
        signature (sometimes .asc, sometimes .sig).
        Add the key anyway, so the tarball can easily be verified manually or by
        other means.
      * debian/inkscape.lintian-overrides: add to override a couple of
        spelling-error-in-manpage due to French words.
    
     -- Mattia Rizzolo <email address hidden>  Tue, 27 Oct 2015 10:54:44 +0100
  • inkscape (0.91-5) unstable; urgency=medium
    
      [ Matteo F. Vescovi ]
      * debian/control: dh-python b-dep added
      * debian/README.source: file dropped (Closes: #696924)
    
      [ Mattia Rizzolo ]
      * debian/patches/reproducible-build.patch: add to allow reproducible build.
      * debian/rules: enable hardening.
      * debian/control: Replace recommends on perlmagick (which is a transitional
        package) by libimage-magick-perl.
        Thanks to Martin Michlmayr <email address hidden> for reporting (Closes: #789232)
    
     -- Mattia Rizzolo <email address hidden>  Fri, 19 Jun 2015 08:05:18 +0000
  • inkscape (0.91-4) unstable; urgency=medium
    
      * Upload to unstable
    
      [ Matteo F. Vescovi ]
      * debian/control: set DMM Team as Maintainer
      * debian/gbp.conf: git-dch -> dch parameter fixed
    
      [ Mattia Rizzolo ]
      * debian/control: add myself to Uploaders
      * debian/control: update Vcs-* links to point
        the repo in the pkg-multimedia namespace
    
     -- Matteo F. Vescovi <email address hidden>  Thu, 30 Apr 2015 08:39:35 +0200
  • inkscape (0.48.5-3) unstable; urgency=medium
    
    
      * debian/patches/: patchset updated
        - 0006-Update_to_new_libwpg.patch refreshed
        - 0007-Fix_API_mismatch.patch added (Closes: #754716)
          Thanks to Pino Toscano (pino) for the patch.
    
     -- Matteo F. Vescovi <email address hidden>  Fri, 19 Sep 2014 11:11:07 +0200
  • inkscape (0.48.5-2) unstable; urgency=medium
    
    
      * debian/patches/: patchset updated
        - 0006-Update_to_new_libwpg.patch added (Closes: #753430)
          Thanks to Rene Engelhard (rene) for the patch.
      * debian/control: build-dependencies updated
        - librevenge-dev added
        - libwpd-dev (>= 0.9.0) dropped
        - libwpg-dev (>= 0.2.0) bumped to libwpg-dev (>= 0.3.0)
      * debian/: dh-autoreconf usage applied
    
     -- Matteo F. Vescovi <email address hidden>  Sat, 09 Aug 2014 14:22:26 +0200
  • inkscape (0.48.5-1) unstable; urgency=medium
    
    
      [ Luca Bruno ]
      * debian/rules: fix FTBFS on alpha (Closes: #738155)
    
      [ Mattia Rizzolo ]
      * debian/patches/: patchset updated against v0.48.5
        - 0004-Fix_FTBFS_on_gcc-4.8.patch refreshed
        - 0005-Fix_FreeType_include.patch dropped (applied upstream)
        - 0006-Fix_FTBFS_on_poppler-0.26.patch dropped (applied upstream)
        - 0005-Fix_FTBFS_due_to_tests.patch added
    
      [ Matteo F. Vescovi ]
      * Imported Upstream version 0.48.5
    
     -- Matteo F. Vescovi <email address hidden>  Tue, 08 Jul 2014 15:49:42 +0200
  • inkscape (0.48.4-5) unstable; urgency=medium
    
    
      * debian/patches/: patchset updated
        - 0006-Fix_FTBFS_on_poppler-0.26.patch added
    
     -- Matteo F. Vescovi <email address hidden>  Thu, 05 Jun 2014 09:05:43 +0200
  • inkscape (0.48.4-4) unstable; urgency=medium
    
    
      * debian/: python dependency fixed
      * debian/control: b-dep bump liblcms1-dev => liblcms2-dev (Closes: #745533)
    
     -- Matteo F. Vescovi <email address hidden>  Wed, 23 Apr 2014 09:22:50 +0200
  • inkscape (0.48.4-3) unstable; urgency=medium
    
    
      * debian/control: S-V bump 3.9.4 => 3.9.5 (no changes needed)
      * debian/control: Uploader e-mail address updated
      * debian/patches/: patchset updated
        - 0005-Fix_FreeType_include.patch added (Closes: #733118)
          Thanks to Adam Conrad for the patch.
    
     -- Matteo F. Vescovi <email address hidden>  Fri, 27 Dec 2013 09:45:37 +0100
  • inkscape (0.48.4-2) unstable; urgency=low
    
    
      * debian/control: fields update
        - Duplicate Homepage field removed
        - VCS-* fields repositioned
      * debian/watch: path updated
      * debian/: dh bump 7 => 9
      * debian/source/format: 3.0 (quilt) file added
      * debian/patches/: patchset re-worked using gbp-pq
        - patches re-worked using gbp-pq (authorships kept)
        - debian/control: quilt b-dep dropped
        - debian/rules: quilt usage dropped
      * debian/gbp.conf: file added
      * debian/control: autotools-dev b-dep added
      * debian/rules: drastic simplification
      * debian/control: S-V bump 3.8.3 => 3.9.4 (no changes needed)
      * debian/control: python-lxml Suggests => Recommends (Closes: #389540)
      * debian/control: python-numpy Suggests => Recommends (Closes: #440566)
      * debian/control: libgnomevfs2-extra Suggests => Recommends
        (Closes: #602599)
      * debian/control: skencil Suggests dropped.
        The package has been removed from unstable
        on 2010-09-03 and from testing on 2010-09-04. (Closes: #712192)
      * debian/control: transfig added to Recommends (Closes: #601770)
      * debian/control: python dropped from Suggests (Closes: #628009)
      * debian/control: Package description updated.
        Thanks to Phil Bull <email address hidden> for the new description.
        (Closes: #635244) (LP: #811634)
    
     -- Matteo F. Vescovi <email address hidden>  Tue, 02 Jul 2013 17:25:52 +0200
  • inkscape (0.48.4-1) unstable; urgency=low
    
    
      * Upload to unstable
      * debian/control: added myself to Uploaders
      * debian/patches/: patchset updated
        - 04-Fix_FTBFS_on_gcc-4.8.patch added (Closes: #701297)
    
     -- Matteo F. Vescovi <email address hidden>  Fri, 21 Jun 2013 15:13:32 +0200
  • inkscape (0.48.3.1-1.3) unstable; urgency=low
    
    
      * Non-maintainer upload.
      * Add Debian patch to fix relative filename vulnerability (Closes: #654341).
    
     -- John Paul Adrian Glaubitz <email address hidden>  Sat, 29 Dec 2012 19:15:46 +0100
  • inkscape (0.48.3.1-1.2) unstable; urgency=low
    
    
      * Non-maintainer upload.
      * Add Debian patch to fix vulnerability CVE-2012-5656 (Closes: #696485).
    
     -- John Paul Adrian Glaubitz <email address hidden>  Mon, 24 Dec 2012 00:58:56 +0100
  • inkscape (0.48.3.1-1.1) unstable; urgency=low
    
    
      * Non-maintainer upload.
      * Switch the libpng12-dev build dependency to libpng-dev (closes: #662378)
      * Add the libpoppler-private-dev build dependency (closes: #660987)
    
     -- Pino Toscano <email address hidden>  Fri, 15 Jun 2012 16:40:22 +0200
  • inkscape (0.48.3.1-1) unstable; urgency=low
    
    
      * [cb1a6e2] delete 01-libwpg0.2.dpatch since proper patch appied upstream
      * [041bdd7] delete 02-add-shebangs-and-fix-permissions.dpatch (applied
        upstream)
      * [518e31b] delete 03-add-missing-mimetypes.dpatch (applied upstream)
      * [df995c3] add datamatrix patch from ubuntu (closes: #618835)
      * [169ca97] Imported Upstream version 0.48.3.1, this handles the following
        debian bugs:
        - closes: #665560: inkscape: Including individual glib headers no longer
                           supported
        - closes: #627637: JessyInk: Embedded Javascript Broken
        - closes: #559332: inkscape: Cairo rendering broken for "use" elements
                           with scaling or a viewBox
        - closes: #596836: clipart search spews messages in console
        - closes: #628035: inkscape: in the pdf export dialog a wrong pdf version
                           is reported
        - closes: #651196: French manpage has accents replaced by some garbage
        - closes: #633150: inkscape: New upstream version 0.48.3 is available
      * [3f6e27a] use quilt instead of dpatch for patch handling
      * [dd10775] Acknowledge NMU, inkscape doesn't register for handling of pdf
        and ps anymore (closes: #613752)
      * upload sponsored by Guido Guenther <email address hidden>
        Thank you very much!
    
     -- Wolfram Quester <email address hidden>  Sun, 25 Mar 2012 13:51:37 +0200
  • inkscape (0.48.1-2.2) unstable; urgency=low
    
    
      * Non-maintainer upload.
      * Drop postscript and pdf from inkscape.desktop (closes: #613752)
    
     -- Julien Cristau <email address hidden>  Sat, 18 Feb 2012 16:42:15 +0100
  • inkscape (0.48.1-2.1) unstable; urgency=high
      * Non-maintainer upload.  * Fix FTBFS with gcc 4.6 (Closes: #624770), Thanks to Alex Valavanis    for the patch.    - added 04-fix-build-with-gcc4.6.dpatch  * Fix build issues due to missing includes (Closes: #628226), patch    taken from upstream.    - added 05-add-missing-includes.dpatch -- Mehdi Dogguy <email address hidden>  Mon, 30 May 2011 17:07:11 +0200
  • inkscape (0.48.1-2) unstable; urgency=low
      * upload to unstable (closes: #611626)  * [d364fdc] link against libwpg0.2/libwpd0.9 (closes: 604825)    Thanks to Rene Engelhard <email address hidden> for his work and the patch!  * upload sponsored by Guido Guenther <email address hidden>    Thank you very much! -- Wolfram Quester <email address hidden>  Mon, 14 Feb 2011 13:48:21 +0100
  • inkscape (0.47.0-2) unstable; urgency=low
    
    
      * Build depend on libaspell-dev, recommend aspell, add explanation to
        package description (closes: #562060)
      * update debian/watch patch by Kees Cook, many thanks to him
        (closes: #562225)
      * process DEB_BUILD_OPTIONS for "parallel=N" flag patch by Kees Cook,
        many thanks to him. (Closes: #562226)
      * Add patch to update man-page (closes:#570494)
      * remove old unneeded patches
      * upload sponsored by Guido Guenther <email address hidden>
    
     -- Wolfram Quester <email address hidden>  Fri, 19 Feb 2010 19:21:33 +0100
  • inkscape (0.47.0-1) unstable; urgency=low
    
    
      * Imported Upstream version 0.47
      * This is upstream version  0.47, I added the .0 because 
        I forget the ~ in the -pre versions.
      * add proper Vcs-fields to debian/control
      * upload sponsored by Guido Guenther <email address hidden>
    
     -- Wolfram Quester <email address hidden>  Mon, 30 Nov 2009 17:23:20 +0100
  • inkscape (0.47pre4-1) unstable; urgency=low
    
    
      * Imported Upstream version 0.47pre4
      * upload sponsored by Guido Guenther <email address hidden>
    
     -- Wolfram Quester <email address hidden>  Fri, 06 Nov 2009 12:31:05 +0100
  • inkscape (0.47pre2-2) unstable; urgency=low
    
    
      * fix installation of usr/share/application-
        registry/inkscape.applications
      * upload sponsored by Guido Guenther <email address hidden>
    
     -- Wolfram Quester <email address hidden>  Tue, 27 Oct 2009 08:16:59 +0100
  • inkscape (0.46-9) unstable; urgency=low
    
    
      * add 13_slider.dpatch by Marco Presi <email address hidden>
        to allow the full range of values for r/g/b/alpha channels
        (closes: #525100)
      * upload sponsored by Guido Guenther <email address hidden>
    
     -- Wolfram Quester <email address hidden>  Fri, 24 Apr 2009 18:35:32 +0200
  • inkscape (0.46-8) unstable; urgency=low
    
    
      * Try to workaround libpng-bug by 11_libpng.dpatch
        (closes: #522477).
      * upload sponsored by Guido Guenther <email address hidden>
    
     -- Wolfram Quester <email address hidden>  Mon, 20 Apr 2009 19:26:39 +0200
  • inkscape (0.46-7) unstable; urgency=low
    
    
      * apply patch Arthur Loiret to fix GPREL16 relocation errors on
        alpha (Closes: #521767).
      * Acknowledge NMU for 0.46-5.1 by Josselin Mouette, which happened quite
        parallel to the upload of 0.46-6
      * raise Standards-Version to 3.8.1
      * raise debhelper compat mode and dependency to 7
      * add dh_desktop to install target in debian/rules
        to fix lintian warning desktop-mimetype-without-update-call
      * fix lintian warnings description-contains-homepage
        and debian-rules-ignores-make-clean-error
      * fix config changes in .diff.gz
      * upload sponsored by Guido Guenther <email address hidden>
    
     -- Wolfram Quester <email address hidden>  Thu, 02 Apr 2009 19:12:05 +0200
  • inkscape (0.46-6) unstable; urgency=low
    
    
      * fix typo: suggest python-uniconvertor instead of python-uniconverter
        (Closes: #506217)
      * add 09_gtk-clist.patch to work around a gtk bug (closes: #518633)
        patch taken from https://bugs.launchpad.net/inkscape/+bug/238223
      * upload sponsored by Guido Guenther <email address hidden>
      * add 10_belarussian.dpatch by Hleb Valoshka
        (closes: #514549)
    
     -- Wolfram Quester <email address hidden>  Sun, 08 Mar 2009 12:16:45 +0100
  • inkscape (0.46-5.1) unstable; urgency=low
    
    
      * Non-maintainer upload.
      * 03-gtk-includes.dpatch: patch from Ubuntu to fix FTBFS caused by 
        wrong GTK+ includes. Closes: #518633.
    
     -- Josselin Mouette <email address hidden>  Mon, 23 Mar 2009 20:35:51 +0100
  • inkscape (0.46-5) unstable; urgency=low
    
    
      * Fix error in bash completion file introduced in the last upload.
        Thanks to Salvatore Bonaccorso for spotting this.
      * Include patch by Thomas Viehmann, which fixes a crash with pdf import in
        some cases (Closes: #510234).
      * upload sponsored by Guido Guenther <email address hidden>
    
     -- Wolfram Quester <email address hidden>  Tue, 30 Dec 2008 23:40:25 +0100
  • inkscape (0.46-4) unstable; urgency=low
    
    
      * Fix lintian warning: menu-item-uses-apps-section (Closes: #508692). 
      * Add debian/watch file (Closes: #508690).
      * Add support in bash completion file for jpeg, svgz, and pdf
        (Closes: #428226).
      * Add patch to give back LaTeX formula rendering option 
        (Closes: #464154, #506285).
      * Thanks Salvatore Bonaccorso for his patches :-)
      * Add patch by Martin Michlmayr <email address hidden> to make inkscape compile
        with gcc 4.4 (Closes: #505660)
      * Suggest python-uniconvertor and add patch by Andreas Wenning to use it in
        the .cdr input plugin instead of the old uniconv (Closes: #471109, #506217). 
      * Suggest libgnomevfs2-extra which is needed to make 
        "Import From Open Clip Art Library" work (Closes: #496785).
      * Suggest libsvg-perl , as the txt2svg extension needs it (Closes: #504469).
      * upload sponsored by Guido Guenther <email address hidden>
    
     -- Wolfram Quester <email address hidden>  Sun, 28 Dec 2008 17:35:10 +0100
  • inkscape (0.46-3) unstable; urgency=low
    
    
      * suggest ttf-bitstream-vera (Closes: #496784)
      * add a patch by Thomas Viehmann <email address hidden> to only use valid font
        families in the text tool. Many thanks to him and Charles Plessy
        <email address hidden> for debugging this stuff.
      * Acknowledge NMU by Thomas Viehmann <email address hidden> 
      * upload sponsored by Guido Guenther <email address hidden>
    
     -- Wolfram Quester <email address hidden>  Tue, 28 Oct 2008 19:46:24 +0100
  • inkscape (0.46-2.1) unstable; urgency=low
    
    
      * Non-maintainer upload.
      * Add upstream patch fixing a crash in the open dialog
        in the zh_CN.utf8 locale. Closes: #487623.
        Thanks to Luca Bruno for the patch.
    
     -- Thomas Viehmann <email address hidden>  Tue, 09 Sep 2008 23:29:02 +0200
  • inkscape (0.43-5) unstable; urgency=low
    
    
      * move handling of debian-specific patches to dpatch (and build-depend on
        it), little cleanup of debian/rules.
      * remove "g++ (>= 4:4.0.2-2) [arm m68k hppa]" from build-dependencies
      * added no-freetype-internals.diff submitted upstream by David Turner to
        clean up inkscape's dealing with freetype. This patch also allows to build
        inkscape using freetype 2.2.1. Thanks David!
      * added gcc-4.1.diff submitted by Martin Michlmayr and Brian M. Carlson to fix 
        compilation with gcc-4.1. Thanks Martin and Brian!
        (closes: #357112)
      * upload sponsored by Martin Michlmayr <email address hidden>
    
     -- Wolfram Quester <email address hidden>  Mon, 29 May 2006 11:47:43 +0200