I am using DDRescue -GUI ver 2.0.1, it stuck at getting new disk information

Asked by ʌǝǝɹn on 2019-02-11

As a newbie at Linux i m using ddrescue on graphical interface only.

My device info is
Dell Inspiron 1TB HDD with Windows 10 and Linux dual boot.
               120GB SDD with another windows 10.

I was trying this ddrescue to check whether data is present in my ext 3TB HDD with a lot of bad sectors.

Even with the ext HDD disconnected the DDRescue-GUI stuck at getting new disk information..

I checked other questions where you mention to open getdevinfo.py however that specific folder 'GetDevInfo' is missing over here..

Question information

Language:
English Edit question
Status:
Solved
For:
DDRescue-GUI Edit question
Assignee:
Hamish McIntyre-Bhatty Edit question
Solved by:
ʌǝǝɹn
Solved:
2019-02-14
Last query:
2019-02-14
Last reply:
2019-02-13

Hello,

Thanks for providing lots of detail - makes my life a lot easier :)

What Linux distro and what version are you using?

Yeah, those older questions won't be relevant any more because the GetDevInfo-related functionality is a separate program now.

Do you have getdevinfo installed? If not, you can find it at https://launchpad.net/getdevinfo. I need to know what Linux distro you're using to let you know which version to install.

Hamish

ʌǝǝɹn (brahmajivv) said : #2

I m using ubuntu 18.04 LTS.

I didn't install getdevinfo, should I install it. Right now I m out, will revert installing it asap, any more information specifically you would like to get fr me.

Also thankyou a lot for prompt reply.

Yeah, you should install the python 3 version, then it should work.

Hamish

ʌǝǝɹn (brahmajivv) said : #4

I did install gets v1.0.4 py3

Python ver.3.6.7 is already in use.

Still same issue persisting.

Sorry to hear that. I'm not immediately able to reproduce this on my end.

Could you open the Terminal (CRTL + ALT + T), and paste the following code in, without the quotes:

"sudo python3 -m getdevinfo.getdevinfo"

And then press enter. You may be prompted for you password.

After that has run, could you copy and paste the output from that command here please?

Thanks,
Hamish

ʌǝǝɹn (brahmajivv) said : #7

/usr/lib/python3.6/runpy.py:125: RuntimeWarning: 'getdevinfo.getdevinfo' found in sys.modules after import of package 'getdevinfo', but prior to execution of 'getdevinfo.getdevinfo'; this may result in unpredictable behaviour
  warn(RuntimeWarning(msg))
Traceback (most recent call last):
  File "/usr/lib/python3.6/runpy.py", line 193, in _run_module_as_main
    "__main__", mod_spec)
  File "/usr/lib/python3.6/runpy.py", line 85, in _run_code
    exec(code, run_globals)
  File "/usr/lib/python3/dist-packages/getdevinfo/getdevinfo.py", line 112, in <module>
    diskinfo = get_info()
  File "/usr/lib/python3/dist-packages/getdevinfo/getdevinfo.py", line 97, in get_info
    linux.get_info()
  File "/usr/lib/python3/dist-packages/getdevinfo/linux.py", line 125, in get_info
    host_disk = get_device_info(node)
  File "/usr/lib/python3/dist-packages/getdevinfo/linux.py", line 176, in get_device_info
    DISKINFO[host_disk]["Product"] = get_product(node)
  File "/usr/lib/python3/dist-packages/getdevinfo/linux.py", line 436, in get_product
    if isinstance(node.vendor.string, bytes):
AttributeError: 'NoneType' object has no attribute 'string'

Thanks.

This is a bug in getdevinfo that I knew about, but I hadn't released the fix for it because I didn't think it affected anyone in the real world. I shall release it in the next few days, and then you should be able to download the update and all will be fine.

Sorry about this and please bear with me :)

Hamish

ʌǝǝɹn (brahmajivv) said : #9

Ok. Well noted. Thanks

Okay, if you install the new version of GetDevInfo - 1.0.5 - that should fix the issue.

Hamish

ʌǝǝɹn (brahmajivv) said : #11

Yep Its Solved..

Thanks for Prompt Support.. :)

Excellent, thanks for letting me know.