Can't search in Active Mode

Asked by Michael Edwards on 2017-12-20

I've set up a pair of ports which have both been forwarded properly (confirmed with https://www.yougetsignal.com/tools/open-ports/), I'm using the proper external IP address (gained from asking "what's my ip" into google), I'm registered with all my hubs, I'm showing as being in active mode in all my hubs, I've added DC++ exceptions to my virus protection software and firewall, everything seems to be set up perfectly for DC++ to work in active mode, in fact up until about two months ago (the last time I used DC++) it was working fine. Now, however, it has suddenly stopped working. I've tried everything I can think of to get it working, but it should be working perfectly fine. What could i have missed? Has something been recently added to DC++ that could have screwed up my ability to go to active mode? I really hate how frustrating and delicate active mode seems to be. It seems like every time i take my eyes of DC++ for even a second active mode gets screwed up somehow, even though nothing has changed.

Question information

Language:
English Edit question
Status:
Answered
For:
DC++ Edit question
Assignee:
No assignee Edit question
Last query:
2017-12-20
Last reply:
2017-12-20
eMTee (realprogger) said : #1

Well, the only item that's missing from your list of checked things are your internal (local) IP address where the ports forwarded to. Check whether it has changed during the last 2 months. If your local ip is randomly assigned then that can be the reason of your problems.
But why won't you use just one of the automatic port mapping features? They are really working well in most cases and save you from the trouble...

Michael Edwards (shad0wdrag0n) said : #2

My internal ip is fixed and hasn't changed. All the port mappings go to the correct ip. I've tried doing Active Mode (let DC++ configure my router with NAT-PMP / UPnP, and even though it successfully does the port mapping (according to the System Log) I still get nothing when I try to search. Passive mode gives me search results just fine, but for some reason active mode just doesn't work, even though everything suggests that it should work.

Michael Edwards (shad0wdrag0n) said : #3

I can't seem to edit my last message so: I also tried using Let DC++ determine the best connectivity settings. It worked without any errors, but again I cannot get anything to show when I do a search.

eMTee (realprogger) said : #4

Alright, try removing and readding DC++ exceptions to your virus protection software / firewall. Sometimes it does the trick especially after upgrading DC++ to a new version. Also please make sure you're using the latest DC++ downloaded from http://dcplusplus.sourceforge.net/download.html

eMTee (realprogger) said : #5

Also make sure you do the same reset in your AV's firewall part (if it has one). Make sure Windows firewall is disabled if your AV has its own firewall.
If your AV solution comes without a firewall service then try resetting the exception for DC++ in the Windows firewall.

Michael Edwards (shad0wdrag0n) said : #6

I tried readding the exceptions, didn't work. I tried turning off my avg firewall and my windows firewall, didn't work. I'm guessing that if i turn all my firewalls off and it still doesn't show anything when i search, it can't be a problem with my virus protection.

eMTee (realprogger) said : #7

Most probably, yeah. Though something clearly blocking the inward data flow to reach DC++ in your opened UDP (Search) port. Sometimes in the old days happened that this kind of UDP data flow from many responders to the same port at the same time triggered an anti-DDOS protection in some routers or ISPs' network devices. Which may gives you a clue. You may try a direct internet connection without the router to see if the search responds are actually reaching you that way. Or maybe checking other programs using the UDP protocol whether they're working well or not.
Otherwise I'm out of ideas.

Can you help with this problem?

Provide an answer of your own, or ask Michael Edwards for more information if necessary.

To post a message you must log in.