Cannot browse DC++ users.......ever

Asked by Mic on 2017-02-07

I've been trying to get LinuxDC++ working for the last 2 years with no success. I'm using Mint as my main OS. There is no firewall. The IP address is correct. I can see hubs/users quite fine but can never browse any files. Right click browse and nothing happens other than a message saying "a file with different tth root already exists in the queue" Interestingly, none of the forums with this problem have any solution other than go back and read the set up. EVERYTHING IS SET UP! Active/passive/manual... And how could ports be a issue if I can already get hubs and user lists? Doesn't make any sense as browsing would just be pulling up another list. Its all still technically browsing right? Ahh this is crazy. Frostwire use to be my go to back in the days. God I miss the simplicity of that program.

Anyhoo, I'd give my right nut to find a solution to this problem. People have been reporting this same problem since 2008! C'mon theres gotta be someone out there who knows what the deal is by now.

Question information

Language:
English Edit question
Status:
Answered
For:
DC++ Edit question
Assignee:
No assignee Edit question
Last query:
2017-02-07
Last reply:
2017-02-12
poy (poy) said : #1

hey,

as far as I'm aware, LinuxDC++ hasn't been updated in quite a while, so I'm not surprised such issues creep in.

personnally I use DC++ (Windows program) with Linux Mint under Wine. with a few tweaks here and there (such as not hiding the window when minimizing to icon, using standard menus) that works quite well. support of Wine in DC++ is intentionally being kept as good as possible until we have a proper Linux version. ;)

Mic (minnibus) said : #2

thanks for the tip Poy

I tried to get frostwire going under wine a couple years ago with no success. I'll give this a try with the windows DC++. May I ask which version of Mint you are using?

Mic (minnibus) said : #3

Hmmm, WINE is proving to be very annoying so far. When you open it, it gives you the option of adding a app or game or etc. When you click on add app, Wine just gives you a list of pre selected apps to choose from instead of browsing your own computer for the DC++ exe which I have downloaded on Mint. The only other option is configure wine which also has the add application feature, but when I select the DC++(that I had to move onto the fake wine c drive) and then click apply, nothing happens.

You know for an application thats touted as being easy to use, nothing could be farther from the truth. Its another one of those linux toys that only linux people seem to "get" how to use. Going to install virtual box and put on winxp and then install DC++. Not sure if this will work though as I have limited 1 gb ram on my crap laptop.

The saga continues.....

poy (poy) said : #4

hey,

I'm on Linux Mint 18 at the moment but this worked on Linux Mint 17 as well. using the MATE desktop.

using DC++ with Wine is very easy here; no "add app" to use. use the relocatable version of DC++: from <https://sourceforge.net/projects/dcplusplus/files/DC%2B%2B%200.865/>, grab the "-x64.zip" pack and extract it somewhere.

then in my case, I right-click the .exe and select "Open With > Wine".

to have a shortcut on my desktop, I right-click in the desktop, select "Create launcher" then enter the following command:
    wine /home/poy/dcpp/DCPlusPlus-x64/DCPlusPlus.exe

(change the path to where your DC++ zip has been extracted.)

I'm no Wine expert; I guess there may be various other ways of running the app through Wine.

one particular setting I disable in DC++: Settings > Appearance > Minimize to tray (otherwise the window gets lost when minimizing the app).

hope that helps.

Can you help with this problem?

Provide an answer of your own, or ask Mic for more information if necessary.

To post a message you must log in.