dc++ windows 10 port issues after .860 upgrade

Asked by pat on 2016-09-27

I upgraded to .860 with win 10 that i had to manually forward ports. It was working fine. i upgraded & IVp6 was added, now i cannot get active again

Question information

Language:
English Edit question
Status:
Solved
For:
DC++ Edit question
Assignee:
No assignee Edit question
Solved by:
pat
Solved:
2016-09-29
Last query:
2016-09-29
Last reply:
2016-09-29
eMTee (realprogger) said : #1

Again, the latest version of DC++ is 0.861, which fixes issues related to manually forwarded ports.

Please update to 0.861, try again and if it doesn't work then also try the default Automatic connectivity setup. It creates logs, paste them here so we can have more ideas what went wrong.

pat (pneal1965) said : #2

ok, installed .861. forwarding ports worked until i upgraded. i chose a log directory but every time i log out & back in, the directory is gone. so no logs. uploading is working, not d/l though. see default automatic connectivity setup results below

IPv4: Determining the best connectivity settings...
IPv4: Local network with possible NAT detected, trying to map the ports...
IPv6: Determining the best connectivity settings...
IPv6: Public IP address detected, selecting active mode with direct connection
IPv4: Port mapping: Failed to initialize the MiniUPnP interface
IPv4: Port mapping: Failed to map the Transfer port (60589 TCP) with the NAT-PMP interface
IPv4: Port mapping: Failed to create port mappings

i am not an expert by any means, thanks for helping!!

eMTee (realprogger) said : #3

This is the log we needed and nothing else.
The automatic connectivity setup detection log from which it's clear there was no successful port mapping attempt.
If you can't do it manually then a downgrade to 0.851 is your best option for the time being.

pat (pneal1965) said : #4

i cannot give you a log showing i attempted to map the ports. there isn't any. i tried at least 50 different combos to fix it, map the ports. I have been trying manually change the settings after the upgrade from .860 to .861 that's why i am here. i have win 10, that's the main reason for upgrading.

only option is "this solved my problem"?

eMTee (realprogger) said : #5

You can keep this open not need to set to solve.

We have one report similar to yours, the problem is clear from the log you provided so we need to find the cause and it needs a fix but until a fix is made and released, the easiest option to you is to go back to an earlier version than 0.860.

A reply if a simple downgrade fixed your issue or not would be most welcomed.

pat (pneal1965) said : #6

I am using .851 & having the same issue. maybe it was the IPv4 & IPV6 fields in .861?

eMTee (realprogger) said : #7

It's not. The IPV6 settings are additions that do not affect the IPv4 ones. Additionally, automatic connectivity setup hasn't changed for IPv4 so it should work the same.
Please go through this FAQ to see if it's not a common problem that can happen in case of any upgrade:
FAQ #83: “I've just upgraded to the newest version of DC++. Now I can't connect / search / download. What happened?”.

poy (poy) said : #8

hi,

one thing I can think of that has changed in version 0.861 and the effects of which may linger even if you go back to version 0.851:

- please install version 0.861 again;
- in settings > Connectivity, click "Edit detected settings" (button below the log text);
- in settings > Connectivity > Manual configuration, in the "IPv4" group, under "Bind address", what do you see in the list?

pat (pneal1965) said : #9

i can see that screen in my sleep @poy. what might i see in the list? just 1 example. thank you

@eMTee i went through the FAQ's 1st thing. I wouldn't just come and ask when someone took the time to list all the possible questions. I had tried all the steps listed. I should have pasted a bunch code & gotten some detailed answers. lol

eMTee (realprogger) said : #10

Alright pat, sorry, most users ask even the simplest things before reading anything. I'm glad that you're not one of them :P

pat (pneal1965) said : #11

you guys are awesome!!! I love the client and it's worth any extra tweaking. I got passive in .851, i will work from there. Thanks for the prompt responses!!!

poy (poy) said : #12

hey,

a couple of things:

- my question was not random; I was not asking you for that manual config screen, but specifically for the values you see listed in a selector called "Bind address". I asked because this is one of the few things that has changed in the new version.
(to be more specific, the way we determine what your local IP is has slightly changed and if it has been wrongly deduced, you can tweak it using that "Bind address" selector.)

- if passive mode works for you in version 0.851, it will also work just as well in version 0.861. so I highly suggest upgrading to version 0.861 again and settling on passive mode for now. :)