Manual portforwading does not work in v0.770

Asked by LoRenZo on 2010-12-23

Hi,

I don't know if it's OS related or not, or if it's a known issue, but I recently attached my old router to my system, and ever since then I am not able to make DC++ work as it was working with "my computer is directly connected to Internet (no router)".

I know how to make portforwarding work, and I also have a 3rd party firewall (works flawlessly with direct connection), it only doesn't seems to work when I'm using my router - which I unfortunetly need to use now.

My OS is Windows 7 Ultimate N x64. I recently installed it, and as far as I remember, I had no issues previously with Windows XP x64 and with the same router. (Not sure though that I were using DC++ after 0.770 got released with my router.)

I also read that somebody made a bugreport about UPnP doesn't seems to work either, but my router does not support this function, so I do portforwarding munally. I don't have any issues with uTorrent - I'm only telling this because I have tried to filter to the given ports (with netstat -n | find "portnumber") and I get no results at all when searching for DC++'s port(s); unlike when it comes to uTorrent's.

Hope this gets fixed in the upcomming version, which I am really looking forward to getting released soon.

Question information

Language:
English Edit question
Status:
Solved
For:
DC++ Edit question
Assignee:
No assignee Edit question
Solved by:
LoRenZo
Solved:
2010-12-28
Last query:
2010-12-28
Last reply:
2010-12-27

This question was originally filed as bug #693926.

eMTee (realprogger) said : #1

Manual port forwarding means you need to do the port(s!) forwarding to the correct local ip adress manually and also take care of firewalls etc... then set up them in the client. If it doesn't work for you then you missed some steps in the configuration, there's nothing to do with manual port forwarding in DC++. If they forwarded, enabled and specified in DC++, then DC++ will use them.

There is a complete FAQ in the DC++ built in help covering the needed steps for port forwarding and ways of how to check that a port is really forwarded and unblocked. Its called 'How to setup active mode' and also available online at http://dcplusplus.sourceforge.net/webhelp/faq_activemode.html

LoRenZo (lorenzo-mailbox) said : #2

Contacted user on Dev hub, followed his instructions and finally could manage to get it work.