Do we always have to use the newest cmake?

Asked by Benjamin Kluck on 2009-06-04

Hi Everybody,

I tried to compile the new cuniform 0.7 and ran into a problem.

Recently I installed cmake 2.6.0 to compile cuneiform 0.6 but the new cuneiform 0.7 CMakeLists.txt says: "cmake_minimum_required(VERSION 2.6.2)". I changed that back to "cmake_minimum_required(VERSION 2.6.0)" and it worked like a charm.

I'm on Debian Lenny and it's a pain in the neck to install cuneiform 0.7 with cmake 2.6.2:
To install cuneiform 0.7 you need cmake 2.6.2.
To install cmake 2.6.2 you need debhelper >= 7
To install debhelper 7 you need...

My question is now:
Do we always have to use the newest cmake? Shouldn't it be enough to use the latest stable version (>=2.6)?


Question information

English Edit question
Cuneiform for Linux Edit question
No assignee Edit question
Solved by:
Jussi Pakkanen
Last query:
Last reply:
Revision history for this message
Yury V. Zaytsev (zyv) said :

I think that the requirement for 2.6.2 was introduced because of the ImageMagick package detection code. If you don't use it at all I think it's safe enough to use 2.6.0. Actually, if I were you, I would request to backport the latest CMake, because e.g. on Ubuntu Hardy LTS they backported it w/o any problems.

Revision history for this message
Best Jussi Pakkanen (jpakkane) said :

ImageMagick is the reason, yes. Earlier versions only detected the IM command line binaries, not headers+libraries. I think there were also some CMake policy settings that I removed because they were no longer necessary (though this may have been a part of the 2.4 -> 2.6 transition, I don't remember the details).

Revision history for this message
Benjamin Kluck (benjamin-kluck) said :

Thanks JussiP, that solved my question.