Do we always have to use the newest cmake?

Asked by Benjamin Kluck on 2009-06-04

Hi Everybody,

I tried to compile the new cuniform 0.7 and ran into a problem.

Recently I installed cmake 2.6.0 to compile cuneiform 0.6 but the new cuneiform 0.7 CMakeLists.txt says: "cmake_minimum_required(VERSION 2.6.2)". I changed that back to "cmake_minimum_required(VERSION 2.6.0)" and it worked like a charm.

I'm on Debian Lenny and it's a pain in the neck to install cuneiform 0.7 with cmake 2.6.2:
To install cuneiform 0.7 you need cmake 2.6.2.
To install cmake 2.6.2 you need debhelper >= 7
To install debhelper 7 you need...
etc.

My question is now:
Do we always have to use the newest cmake? Shouldn't it be enough to use the latest stable version (>=2.6)?

Cheers
Ben

Question information

Language:
English Edit question
Status:
Solved
For:
Cuneiform for Linux Edit question
Assignee:
No assignee Edit question
Solved by:
Jussi Pakkanen
Solved:
2009-07-01
Last query:
2009-07-01
Last reply:
2009-07-01
Yury V. Zaytsev (zyv) said : #1

I think that the requirement for 2.6.2 was introduced because of the ImageMagick package detection code. If you don't use it at all I think it's safe enough to use 2.6.0. Actually, if I were you, I would request to backport the latest CMake, because e.g. on Ubuntu Hardy LTS they backported it w/o any problems.

Best Jussi Pakkanen (jpakkane) said : #2

ImageMagick is the reason, yes. Earlier versions only detected the IM command line binaries, not headers+libraries. I think there were also some CMake policy settings that I removed because they were no longer necessary (though this may have been a part of the 2.4 -> 2.6 transition, I don't remember the details).

Thanks JussiP, that solved my question.