not found after install

Asked by Xose on 2010-02-11

I'm trying to get version 0.9.0 installed on debian, but i'm allways getting this error message when I try to execute cuneiform:

cuneiform: error while loading shared libraries: cannot open shared object file: No such file or directory

All the installation process is OK, at least It doesn't dump any error.
The file is compiled on the /builddir/cuneiform_src/Kern/puma directory.
I tried to copy the library to the /usr/lib/cuneiform/ directory, but it didn't work.

Thanks for your time and attention.

Question information

English Edit question
Cuneiform for Linux Edit question
No assignee Edit question
Last query:
Last reply:
Yury V. Zaytsev (zyv) said : #1

What about running ldconfig?

Simon (herrbert-hans-fobg) said : #2

1. add a .conf file to /etc/
2. It content is the path to the .so files. At my 64 bit system this is: /usr/local/lib64
3. run ldconfig

Check that you have the lib file installed after you have done the installation.
After a typical sudo make install you should see :

ls -l /usr/local/lib/
lrwxrwxrwx 1 root root 21 2010-04-06 15:40 /usr/local/lib/ ->

Simply running 'ldconfig' after the 'make install' worked, thank you.

Can you help with this problem?

Provide an answer of your own, or ask Xose for more information if necessary.

To post a message you must log in.