upgrade systemd from 337 to 342

Asked by ibrahim bondokji


i am trying to upgrade systemd version to a specific feature i need.

i am following this document to achieve this: https://gist.github.com/Jiab77/7df6e80804567f6f599b227cf2fafd00

when i follow the steps in a regular installation all goes well, but when i apply it inside cubic the procedure fails at the compilation step with this error:

Summary of Failures:

245/438 test-condition FAIL 0.12s killed by signal 6 SIGABRT
431/438 test-execute FAIL 2.09s killed by signal 6 SIGABRT

Ok: 425
Expected Fail: 0
Fail: 2
Unexpected Pass: 0
Skipped: 11
Timeout: 0

Full log written to /root/systemd-242/build-deb/meson-logs/testlog.txt
debian/rules:297: recipe for target 'override_dh_auto_test' failed
make[1]: *** [override_dh_auto_test] Error 2
make[1]: Leaving directory '/root/systemd-242'
debian/rules:303: recipe for target 'binary' failed
make: *** [binary] Error 2
dpkg-buildpackage: error: debian/rules binary subprocess returned exit status 2
root@cubic:~/systemd-242# nano build-deb/meson-logs/testlog.txt

would appreciate any insight regarding this issue or suggesting a different approach to upgrade systemd

ps: i was also wondering if upgrading systemd with approach is safe or could cause any issues.


Question information

English Edit question
Cubic Edit question
No assignee Edit question
Solved by:
ibrahim bondokji
Last query:
Last reply:
Revision history for this message
ibrahim bondokji (ibrahimbond) said :

i executed the compilation as follow and it worked :

DEB_BUILD_OPTIONS=nocheck dpkg-buildpackage -us -uc -d

does this have any consequences? it is basically compiling without unit testing...


Revision history for this message
Cubic PPA (cubic-wizard) said (last edit ):

I suspect the reason it is not working is that the build process may rely on some services running.
A clue is that the build dependencies actually require systemd.

As you know, services do not run in Cubic's Terminal, because it is just a file system that you have root access to.

May be you can build the package outside of Cubic.
Then, once the build is complete, do not install it.
Instead, copy all the files into Cubic, and execute the install step.
(You can just drag you folder onto the Terminal page in Cubic to copy files).

You may still get an error during `dpkg --auto-deconfigure -i *.deb` (because it probably needs systemd running, but it might be OK after you boot into the generated ISO).

Revision history for this message
Cubic PPA (cubic-wizard) said :

Also, take a look at this Question:


Specifically notice step [4] in comment # 8 of the above question.

We had to manually create a link for the service to run, because the the apt post install script was relying on a service to create that symlink.

Revision history for this message
ibrahim bondokji (ibrahimbond) said :

thank you!