Can't autostart gnome extensions

Asked by Chadley Jon

Hi, I am trying to install gnome shell extensions like openweather and some others. I have added the extensions to the gnome-shell/extensions directory, then created a custom override file (90_ubuntu etc), and in this file I have added the extension to the enabled-extensions list. Doing a 'ls /usr/share/gnome-shell/extensions/' shows the extensions, but a 'gnome-extensions list' command in the chroot returns nothing.

Question information

English Edit question
Cubic Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Cubic PPA (cubic-wizard) said :

gnome-extensions list will only work once you've booted into the Live ISO or you have installed the customized OS to disk.

gnome-extensions relies on services (such as org.gnome.Extensions.service) and services do not run in Cubic's virtual environment. It is simply an isolated file system where you have root privileges to safely modify files in your custom OS.

(If you think about it, you wouldn't want services running in that environment, because services can/will modify system files, potentially undoing or overriding your customizations or simply creating unnecessary files that will be copied to your installed OS).

Revision history for this message
Chadley Jon (chadjaver) said :

Thanks for your reponse Cubic PPA. I think I did a poor job at explaning my issue. My issue was autostarting the gnome extensions on the Live ISO and Install. When booting into the Live ISO, the installed extensions weren't enabled. I have since sorted out the issue by using your extension installation python script and then enabling those in the extensions in the 90_*.override file. I am struggling to set a custom default theme and icons now, I have copied the theme folder to usr/share/themes/ and then added this override in the file:

gtk-theme = 'WhiteSur-dark'
icon-theme = 'Nordic'

But it is not working, could you please point me in the right direction?

Revision history for this message
Cubic PPA (cubic-wizard) said :

In your 90_*.override file, try using


...instead of...


Also, make sure...



Revision history for this message
Chadley Jon (chadjaver) said (last edit ):

Great, the icons and application themes are working now, thank you! I am struggling with getting the shell theme to also work. I installed the user-themes extension using the python script like this:

./ 19

Then in my override file I have added the following:

disable-user-extensions = false
enabled-extensions = ['<email address hidden>', '<email address hidden>', '<email address hidden>', '<email address hidden>']

name = 'WhiteSur-dark'

It didn't work. So I installed the gnome-tweaks-tool in the chroot environment so I can see what is going on when the LiveCD is booted. When I open the tweaks tool on the LiveCD, it said the user-themes extension wasn't installed correctly.

In the Live CD, I opened up a terminal and entered "gsettings get name" and this returns a "No such schema . . "

Not sure where the problem lies.

Revision history for this message
Cubic PPA (cubic-wizard) said :

I see some comments at...
...where people are complaining that the extension wont install or is not working.

May be you need to download an older version of the extension for it to work?

I don't use this extension, so I can't offer much more help.

If you do find out how to resolve this, please be sure to post the solution.

Revision history for this message
Chadley Jon (chadjaver) said :

Thanks Cubic-PPA. I noticed none of the extension preferences in the override files work either. For example, the openweather extension override doesn't work and this is the section I have added in the override file:

actual-city = 0
center-forecast = true
city = '-33.928992,18.417396>Cape Town, City of Cape Town, Western Cape, 8001, South Africa >-1'
days-forecast = 2
decimal-places = 1
geolocation-provider = 'openstreetmaps'
menu-alignment = 77
position-in-panel = 'right'
pressure-unit = 'bar'
show-comment-in-panel = true
show-text-in-panel = true
translate-condition = false
unit = 'celsius'
use-default-owm-key = true
use-symbolic-icons = false
use-text-on-buttons = false
weather-provider = 'openweathermap'
wind-direction = true
wind-speed-unit = 'kph'

So I suspect it doesn't just have to do with the user-themes extension

Revision history for this message
Cubic PPA (cubic-wizard) said :

Try putting your extension preferences in the gschema.xml files located in /usr/share/glib-2.0/schemas/.

I think most of the extensions use something called "relocatable schemas" (in contrast to the global default preferences you place in your 90_*.override file).

The files named...
        /usr/share/glib-2.0/schemas/<extension name>.gschema.xml
...are the default preferences for each extension.

For example,...
...contains preferences for the Dash to Dock extension.

When you modify these files, you'll have to follow the XML format of the file, but it is not difficult to figure out.

First, install your extension.
This will also install the corresponding extension *.xml file in /usr/share/glib-2.0/schemas/.
Next, edit this file with the parameters of your choosing.

(Remember, after you install your OS, if you update your extension, your changes will be overwritten by the preferences that come with the extension. Of course it's not easy for a regular user to update an extension that exists in /usr/share/gnome-shell/extensions/ because it requires root privileges).

Revision history for this message
Chadley Jon (chadjaver) said :

Thanks for taking the time to answer my questions, Cubic-PPA. I'll give it a go and try figure it out.

Can you help with this problem?

Provide an answer of your own, or ask Chadley Jon for more information if necessary.

To post a message you must log in.