Custom ISO failing to install without internet

Asked by Sarthak on 2021-04-16

I have created a custom Ubuntu 18.04 server based ISO. When I try to install the custom image on a VM without an internet connection it fails to install and is rebooted to the initial install screen (language selection). I tried creating the ISO image to see if I messed up any setting but even with all default settings it is failing.

I am able to install the original ISO without iternet but not the custom one. Can any expert on CUBIC help me out here?

Question information

Language:
English Edit question
Status:
Solved
For:
Cubic Edit question
Assignee:
No assignee Edit question
Solved by:
Sarthak
Solved:
Last query:
Last reply:
Sarthak (drac049) said : #1

Update 1: On looking deep in the installation logs it seems that the dpkg-reconfigure command is failing because package "grup-pc" is not installed.

Sarthak (drac049) said : #2

I solved the problem so sharing the resolution here just in case someone else faces it. The problem was exactly as mentioned in the logs. The grub packages were not persent although they were required for install without internet. I ran the below commands to resolve the same:

    $ apt update
    $ apt upgrade
    $ apt install grub-efi-amd64-signed grub-common grub-pc grub-pc-bin grub2-common

Thanks for the help in the thread: https://answers.launchpad.net/cubic/+question/680446