autoinstall server iso not loading local user-data config

Asked by Dalik

Created a working installer for the Desktop ISO (20.04) now trying to configure a server installer using the server installer ISO (20.04).

I have a basic autoinstall script just to see if the installer picks up anything in it as a starting point.

in the user-data file which is placed in the preseed folder I have a basic autoinstall script I pulled from the internet. I also have a meta-user file that is empty.

My grub.cfg looks like this as I want to load the file from local.

menuentry "Server Installer" {
  set gfxpayload=keep
  linux /casper/vmlinuz boot=casper autoinstall ds=nocloud;s=/cdrom/preseed locale=en_US quiet ---
  initrd /casper/initrd.lz

txt.cfg file has this.

label auto-install
  menu label ^Installer
  kernel /casper/vmlinuz
  append boot=casper autoinstall ds=nocloud;s=/cdrom/preseed initrd=/casper/initrd.lz quiet ---

Installer runs but it takes me through all of the screens, nothing is filled out. After the first boot, it's a clean install, my autoinstall file didn't take. This is on real hardware.

Is there a way to confirm if autoinstall actually loaded/worked in log files, if so which log file?

Question information

English Edit question
Cubic Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Dalik (tek2001x) said :

Issue is resolved.

In the grub menu, I've updated the boot string to look like this..

Escaping the semi-colon and adding a forward slash to the preseed path.


Revision history for this message
Cubic PPA (cubic-wizard) said :

Thanks for posing the solution!