Custom Grub Entry Menu after installing the custom OS

Asked by saini on 2020-09-16

HI, Cubic PPA team

I just created a customized Ubuntu distro. Everything is fine, i am quite satisfied using cubic for customization.

But i still have an issue left. When i booted from my custom distro (to install the OS) the grub menu is correctly showing my custom OS name. But after the installation, the GRUB Menu and EFI entry of my motherboard is still showing "ubuntu ".

Is there any way i can force the ubiquity installer to show my custom OS name in the GRUB Menu rather than ubuntu. I know i can edit /boot/grub/grub.cfg later on. But i want to know how can i make my distro to automatically show custom OS name in GRUB Entry.

Thanks in advance :)

Question information

Language:
English Edit question
Status:
Solved
For:
Cubic Edit question
Assignee:
No assignee Edit question
Solved by:
saini
Solved:
2020-09-18
Last query:
2020-09-18
Last reply:
saini (theindian) said : #1

After doing a lot of research on GRUB & on how does grub.cfg configuration file is generated.

I find a solution for my problem.

Please note that the following workaround will help you to apply a custom boot name in GRUB Menu ( GRUB menu shown after installing the custom distro) and the EFI Default entry name (ubuntu) on your motherboard should not be changed at all. As being stated in a linux mint forum, ubuntu is signed by canonical which means it can be run on a secure-boot enabled system.

So, Follow the steps given below to customize the boot menu of your custom distro.

1. Go to /etc/default/grub.d directory in your cubic terminal panel.

     $ cd /etc/grub.d/

2. Edit 10_linux file to set your custom grub entry name instead of Ubuntu.

     $ nano 10_linux

3. Set your own custom OS name in this file as shown in this pic

      Pic Link :- https://imgur.com/hVLKNaA

This solution solved my problem !

Sharing the solution for others who maybe searching for the solution :)

After all, Thanks Cubic PPA Team for this amazing tool.

Cubic PPA (cubic-wizard) said : #2

Thanks for sharing this solution!
This is good research.

==================================================

In case the above link stops working, Sani's solution is to edit...
    /etc/grub.d/10_linux
...and change the OS= value in the is this section...

    - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    case ${GRUB_DISTRIBUTOR} in
        Ubuntu|Kubuntu)
          OS="${GRUB_DISTRIBUTOR}"
          ;;
        *)
    - - - - - - - - - - - - - - - - - - - - - - - - - - - -

==================================================

Sani,

Have you tired modifying the values in...

    /etc/lsb-release

    - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=20.04
    DISTRIB_CODENAME=focal
    DISTRIB_DESCRIPTION="Ubuntu 20.04 LTS"
    - - - - - - - - - - - - - - - - - - - - - - - - - - - -

If you get a chance, see if that works?

saini (theindian) said : #3

Yes, i had tried to modify the value of DISTRIB_ID:

in those files
/etc/lsb-release
/usr/lib/lsb-release

Everything is pretty fine but when i booted from this custom distro. Grub Menu got blank
saying Grub Minimal edition supports only minimal text editing & did not worked.

It also changed the EFI Entry name but GRUB Menu stopped working.