Two errors: unstable memory warning and disc menu looping after customisation

Asked by RobertX on 2020-06-29

When using Cubic to customise Linux Mint 20.0 (Ubuntu 20.04 Focal Fossa), I ran into two problems:

1. When I add a PPA, I was warned that a unstable memory was used, but was still able to add the PPA.
2. After customisation, the disc installer menu, not to be confused with the boot-up menu in the hard drive after installation, keeps looping itself both when the countdown to select an option expires and when an option is selected. For example, when I pick an option to "Start Linux Mint," the disc installer menu would just stay and loop itself. As well, another example: once a countdown to select an option expires, the counter goes back to another ten seconds.

Is Focal Fossa still in the formative stage? If so, that must be the only explanation possible that the menu is being so buggy; The Mint 20 series is to be based on the Focal Fossa release of the Ubuntu OS.

I have tried burning the customised distro to DVD, placing the image to USB thumb drive, and testing the image on Virtualbox. All the results are the same.

If you are curious on the software I'm using, I shall now present them:
1. Linux Mint 20 ISO
2. Cubic 2020-06-28
3. What more do you seek?

Thank you for your answer and I hope this question finds you well.

Question information

Language:
English Edit question
Status:
Solved
For:
Cubic Edit question
Assignee:
No assignee Edit question
Solved by:
RobertX
Solved:
2020-07-01
Last query:
2020-07-01
Last reply:
2020-07-01

This question was reopened

Cubic PPA (cubic-wizard) said : #1

Robert, I see your bug report as well as this question.
I'll download the ISO and see if I experience the same.
(I may not be able to get to this for a couple of days).

RobertX (bobbyyu1) said : #2

Thank you.

Sorry about posting twice. I did it only to increase the likelihood of a response; it wasn't meant to cause spam.

And it's Linux Mint 20, Ulyana.

Cubic PPA (cubic-wizard) said : #3

I experience this same problem with linuxmint-20-xfce-64bit.iso...

I tried two experiments:

1. Boot the linuxmint-20-xfce-64bit.iso directly in VirtualBox.

    The live environment boots just fine.

2. Customize Linux Mint 20 using Cubic and attempt to boot the generated ISO in VirtualBox.

    I see the counter at the bottom of the boot screen.
    After 10, it restarts.

Cubic PPA (cubic-wizard) said : #4

You will need to take advantage of an advanced feature of Cubic...

(1)
Make sure Cubic is not running.

(2)
In a text editor, open <Your Cubic Project>/cubic.conf

(Edit this file as a regular user, *not* as root, *not* using sudo).

Add the following at the end of the "boot_configurations" line:

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
",isolinux/isolinux.cfg
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Be sure to include the preceding comma, and do not add spaces.

The full line should now look exactly like this:

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
boot_configurations = boot/grub/grub.cfg,boot/grub/loopback.cfg,isolinux/txt.cfg,isolinux/isolinux.cfg
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

(3)
Save and close the file.

(4)
Start Cubic.

Click Next until you get to the Options page.

(5)
Click on the "ISO Boot" tab.

You will now see three files.

    1. /boot/grub/grub.cfg
    2. /boot/grub/loopback.cfg
    3. /isolinux/txt.cfg

(Previously, only the first two files were listed).

(6)
Click on "/isolinux/txt.cfg" to verify this file.

You will *not* need to make any changes, since Cubic automatically edited this file for you.

- Confirm that "/casper/vmlinuz" and "/casper/initrd" appear in the file.
- Confirm that the file names ("vmlinuz" and "initrd") match the ISO Kernel tab, Notes section.

(7)
Click Next, Generate, and Finish buttons to generate the customized ISO.

The generated ISO should now work.

RobertX (bobbyyu1) said : #5

Regarding your last post on this thread, these sets of instructions would take place [b]after[/b] I generated the ISO and would have reload the ISO and save the settings made from these instructions. True or false?

Well, better get to work. Thanks for everything.

I do hope that you can add this feature, but, of course, it's your program and I never helped you code it. So thanks for everything.

RobertX (bobbyyu1) said : #6

Thanks Cubic PPA, that solved my question.

Cubic PPA (cubic-wizard) said : #7

I was assuming you already had an existing project that you just wanted to fix.

However, if you are starting from scratch with a new project, you don't have to actually generate an ISO before updating the cubic.conf file. You can quit Cubic, and update the cubic.conf file. (Cubic needs to restart to read the file, so you can't modify it while Cubic is running).

Simply create a new project.
On the Project page, select the ISO you want to customize.
Accept the defaults on the project page, or make change to the fields as you like.
Click the Next button to extract the original ISO and copy files.
At this point, you have a valid cubic.conf file.
Once you are on the Terminal page, exit Cubic.
Edit the cubic.conf file as described above.
Then open your Cubic project, make your customizations in the Terminal page, and proceed from there.

RobertX (bobbyyu1) said : #8

More trouble:

The system doesn't loop, but there are more errors.

During bootup, the system says "initramfs (Unable to find a medium containing a live file system)

Then it boots to command line mode instead of the liveCD.

I'm running the MATE version of Linux Mint 20.0 Ulyana.

RobertX (bobbyyu1) said : #9

Please ignore!

It was just a matter of using different USB writers.

I used Rufus and the problem happened.

Then I used the USB Formatter/Writer and it worked like a charm.

Thank you everyone for your help!