Unable to boot custom image: "No root device specified"

Asked by Francisco Gómez on 2019-11-28

I'm trying to create a custom Kubuntu image, where the only major difference is the usage of a custom kernel. Even when not uninstalling the original ISO's kernel, when booting up, I get a BusyBox shell. When removing `quiet splash` from the boot parameters, the following error appears:

No root device specified. Boot arguments must include a root= parameter.

A screenshot made with a QEMU virtual machine: https://i.imgur.com/4dtTGwR.png

Question information

Language:
English Edit question
Status:
Solved
For:
Cubic Edit question
Assignee:
No assignee Edit question
Solved by:
Cubic PPA
Solved:
2020-01-23
Last query:
2020-01-23
Last reply:
2020-01-19
Francisco Gómez (xerz) said : #1

Hey, the issue persists, any way this could further be debugged and investigated? Anyone has a clue?

Launchpad Janitor (janitor) said : #2

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Francisco Gómez (xerz) said : #3

This remains unsolved, any solutions?

Cubic PPA (cubic-wizard) said : #4

This is just a guess, but adding...

    boot=casper

...might help?

See https://bugs.launchpad.net/cubic/+bug/1849100.
Comment #13 has a nice graphic of the change.

Best Cubic PPA (cubic-wizard) said : #5

Cubic version 2020.01-60 automatically adds "boot=casper" to the ISO boot config files, so you can try this latest version and see if it solves your issue.

Francisco Gómez (xerz) said : #6

Thanks Cubic PPA, that solved my question.