Cubic does not launch the GUI

Asked by Raghu Raman Nagarajan on 2019-09-19

Hi Cubic team,

I am Raghu Raman, working for ABB in USA.

When I tried to launch cubic from my ubuntu vm, I get the following error logs in syslog:

Sep 19 16:25:59 ubuntu gnome-software[2046]: Only 0 apps for recent list, hiding
Sep 19 16:26:00 ubuntu PackageKit: resolve transaction /3146_abeebeda from uid 1000 finished with success after 437ms
Sep 19 16:26:00 ubuntu gnome-software[2046]: hiding category audio-video featured applications: found only 0 to show, need at least 9
Sep 19 16:26:00 ubuntu gnome-software[2046]: g_path_get_basename: assertion 'file_name != NULL' failed
Sep 19 16:26:00 ubuntu gnome-software[2046]: g_regex_match_full: assertion 'string != NULL' failed
Sep 19 16:26:00 ubuntu gnome-software[2046]: g_path_get_basename: assertion 'file_name != NULL' failed
Sep 19 16:26:00 ubuntu gnome-software[2046]: g_regex_match_full: assertion 'string != NULL' failed
Sep 19 16:26:00 ubuntu gnome-software[2046]: tried overwriting io.snapcraft.gcompris-QC7aattxeOlCUpGwG4BzvMZxeprZm7Wy key GnomeSoftware::FeatureTile-css from border-color: #000000;#012text-shadow: 0 1px 1px rgba(255,255,255,0.5);#012color: #000000;#012outline-offset: 0;#012outline-color: alpha(#ffffff, 0.75);#012outline-style: dashed;#012outline-offset: 2px;#012background: url('/home/kmyork/.cache/gnome-software/cssresource/84686cdf07fe94a29f777d42db719e7cdaa15afd-gcompris-qt.png') left center / auto 100% no-repeat, #FFFFFF;; to border-color: #000000;#012text-shadow: 0 1px 1px rgba(255,255,255,0.5);#012color: #000000;#012outline-offset: 0;#012outline-color: alpha(#ffffff, 0.75);#012outline-style: dashed;#012outline-offset: 2px;#012background: url('https://dashboard.snapcraft.io/site_media/appmedia/2019/08/gcompris-qt.png') left center / auto 100% no-repeat, #FFFFFF;;
Sep 19 16:26:02 ubuntu cubic.desktop[2242]: Cubic (Custom Ubuntu ISO Creator) is a graphical user interface application and should be run using the application launcher. See "man cubic" for more information.
Sep 19 16:26:02 ubuntu cubic.desktop[2242]: pkexec must be setuid root

Can you please help me resolve this issue at the earliest?

Thank you.

With Regards,
N.Raghu Raman.

Question information

Language:
English Edit question
Status:
Answered
For:
Cubic Edit question
Assignee:
No assignee Edit question
Last query:
2019-09-20
Last reply:
2019-09-20
Cubic PPA (cubic-wizard) said : #1

What version and Ubuntu-based distro are you running Cubic in?
How did you install Cubic?
How did you launch or start Cubic?

Linux version where Cubic is installed:

Linux ubuntu 4.15.0-64-generic #73-Ubuntu SMP Thu Sep 12 13:16:13 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Commands used to install cubic:

    $ sudo apt-add-repository ppa:cubic-wizard/release
    $ sudo apt update
    $ sudo apt install cubic
    $ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys B7579F80E494ED3406A59DF9081525E2B4F1283B

How did you launch or start Cubic?

I tried to launch Cubic from my Linux desktop menu

Hi,

I got it working.

Thr peoblem was:

kmyork@ubuntu:/mnt/data$ sudo id
uid=0(root) gid=0(root) groups=0(root)

Hence for me,
echo

if [ $(id -u) = 0 ]; then
    echo "Error: Cubic may not be run as a privileged user. Run Cubic using an account with sudo (superuser) membership, and you will be prompted for the superuser password. See \"man cubic\" for more information."
    echo
    exit 1
else

became true.

Commenting out this, resolved the problem.

Thanks.

Cubic PPA (cubic-wizard) said : #4

Humm...
You should not be running Cubic as a root user.
You need to run it as a regular user who belongs to the sudoers group.

When I run as a regular user in sudoers group, I get the issue:

admin@ubuntu:~$ cubic

Cubic (Custom Ubuntu ISO Creator) is a graphical user interface application and should be run using the application launcher. See "man cubic" for more information.

pkexec must be setuid root

When I run the command using "sudo cubic"
I get the error:

Error: Cubic may not be run as a privileged user. Run Cubic using an account with sudo (superuser) membership, and you will be prompted for the superuser password. See \"man cubic\" for more information."

Thanks.

With Regards,
N.Raghu Raman.

Manfred Hampl (m-hampl) said : #6

The important hint is

"pkexec must be setuid root"

It seems that someone has tampered with attributes and protection settings of a file that enables running programs with admin rights.

The command "ls -l /usr/bin/pkexec" should show
-rwsr-xr-x 1 root root (size) (date) /usr/bin/pkexec

I assume that you do not have an "s" in the fourth position or file ownership different from root.

My suggestion is reinstalling the package with that file
sudo apt install --reinstall policykit-1

Thank you very much for the quick resolution.

Cubic PPA (cubic-wizard) said : #8

@Manfred, thanks for jumping in and helping answer this question!!! :)

Can you help with this problem?

Provide an answer of your own, or ask Raghu Raman Nagarajan for more information if necessary.

To post a message you must log in.