Cubic drops file extensions on Pop OS

Asked by Taylor Strange on 2019-06-25

I am trying to use Cubic to create a customized Pop! OS it seemed to work for the most part but when I tried to boot to the USB drive it failed to find the boot loader. it failed to find:
/casper_pop-os_18.04_amd64_nvidia_debug_157/vmlinuz.efi

looking at the list of files in the ISO I have:
-r--r--r-- 1 root root 60578 Jun 24 15:36 filesystem.manifest
-r--r--r-- 1 root root 462 Jun 24 15:38 filesystem.manifest-remove
-r--r--r-- 1 root root 10 Jun 24 15:42 filesystem.size
-rw-r--r-- 1 root root 2397552640 Jun 24 15:42 filesystem.squashfs
-rw-r--r-- 1 root root 75391560 May 23 09:30 initrd
-rw-r--r-- 1 root root 8555920 May 23 09:30 vmlinuz

So you see the ending of .efi is not on vmlinuz and that tar.gz is not on the initrd.

When I pointed the boot loader to the file not ending in .efi it seemed to progress some and then failed. My guess would be for the same reason.

A couple questions I have:
1) Has anyone tried to use this tool on Pop! OS?
2) Has anyone come across this issue before? and what did you try?

Thanks for any help!

Question information

Language:
English Edit question
Status:
Solved
For:
Cubic Edit question
Assignee:
No assignee Edit question
Solved by:
Taylor Strange
Solved:
2019-06-27
Last query:
2019-06-27
Last reply:
2019-06-26
Cubic PPA (cubic-wizard) said : #1

In Cubic, on the Boot Kernels tab, how many kernels are listed?
If there are more than one, try selecting the last one in the list and then click the Generate button.

The note next to the selected kernel will show you the file names that will be used to refer to the initrd and vmlinuz files.
These same names must also appear in the grub.cfg, loopback.cfg, and txt.cfg files on the Boot Configurations tab.
Cubic updates these file names automatically for you, but it would be good to check, since you are experiencing an issue.

(When I get a chance, I'll download PopOS and see what's going on. In the mean time try selecting the last kernel in the list, if available, and see if that helps. I may not be able to get to this for a few days though, but feel free to add additional posts to this question if you come across more information).

Thank you for the help! I did choose the second kernel in the list which was:

vmlinuz-4.18.0-20-generic
initrd.img-4.18.0-20-generic

I checked the grub.cfg and did in fact contain the correct filename. However I didn't find a loopback.cfg or txt.cfg file.

I am about to test the image on machine and will report back with the results soon.

At boot I got the same error. It is still looking for vmlinuz.efi.

Next time, I am going to try the first kernel in the ISO Boot Kernel list, which lists the Boot Files as vmlinuz.efi and initrd.gz.

I have the same error with the first kernel in the list as well.

Sorry! It was a BIOS setting, set to skip UEFI boot. Thanks again for the help!