Can't resize Cubic main window

Asked by Singtoh on 2019-05-23

The main window is to large and I can't find a way to resize it. The window goes from the top of the screen to the bottom of the screen and when installing packages ect. I am unable to see the command line, ah, where you input commands and do things. It really is unusable like this and I have tried everything I can think of to resize the window. The maximize button doesn't work and dragging on the edges top and bottom doesn't work. Dragging on the sides of the window allows resizing to the sides but this is not helpful. I am using the normal ppa, not the developer ppa and I am on Ubuntu 18.04 LTS.

Any ideas?? I like the program but it is just not useable as it is. Help if you can please.

Singtoh

Question information

Language:
English Edit question
Status:
Answered
For:
Cubic Edit question
Assignee:
No assignee Edit question
Last query:
2019-05-23
Last reply:
2019-05-24
Cubic PPA (cubic-wizard) said : #1

What size is your screen resolution set to?
Also, would you please share a picture of your desktop with cubic running? (You could upload it to pastebin and supply the link here).

Singtoh (singtoh) said : #2

Hello and thanks for the reply. My screen res is set to 1366X768 16:9, it is the highest res that my old machine can muster. It's a Dell Optiplex-790 with a Dell Monitor and integrated graphics, and yes I will upload a screenshot for you but I don't like signing up to anything/most things. I have no "Socialist" accounts or any of that garbage.Sorry, I'm kinda strange when it comes to spreading my life around :) Where can I upload too without having to signup to anything??

Thanks again for the help,
Singtoh

Cubic PPA (cubic-wizard) said : #3

Singtoh,

No need to paste...

It would have been good if you had included your screen resolution in the original post.

I was able to set my resolution to match yours and I see the problem...

The last 3 lines of the terminal are below the bottom edge of your screen.

Cubic's main window area is 726 pixels high. Even though this is below the 768 pixel limit of your resolution, the Window Header Bar and the Gnome Shell Top Bar take up almost 80 pixels. This only leaves around 688 pixels available for Cubic's main window area.

Currently, the minimum height of the window is fixed for all pages in Cubic. The size can be increased, but it can not reduced. This is because information on the "Existing Project Page", the "Delete Project Page", the "Repackage Project Page" must fit in the window without being cut-off, and without the Cubic window constantly resizing itself as the user navigates between pages.

I'll look into what can be done to reduce the height of the the "Existing Project Page", the "Delete Project Page", and the "Repackage Project page" so they fit reasonably within 688 pixels (high). If this can be done, then Cubic's "Terminal Page" will be smaller (in height) as well.

In the mean time, however, you can work around this issue by hovering over the Cubic window and pressing the mouse-button-modifier key (<Super> or <Windows> or <Alt> key) while dragging the window up using the left mouse button.

        Clicking a window while holding down this modifier key will move the
        window (left click), resize the window (middle click), or show the
        window menu (right click). The middle and right click operations may
        be swapped using the “resize-with-right-button” key. Modifier is
        expressed as <Alt> or <Super> for example.

This will allow you to make the full chroot terminal visible, so you can work. When you are done, simply drag the window down while pressing the <Super> (or <Window> or <Alt>) key to make the the Header Bar visible, so you can click the "Next" button.

Singtoh (singtoh) said : #4

Yeah I have tried the modifier keys and the scaling and it doesn't rezize the window. The modifier keys work for other programs on this computer but not Cubic for some reason. I work around this issue by quitting and reopening Cubic so it has a clear chroot screen that I can kinda work with.

Another problem I am having that just cropped up is that I do all of the editing and try to build out the iso and it gets to "Generate the customized disk image" and just spins and sits at 0% and does nothing else. I waited for an hour and it sill sits at 0%. Any ideas on that one?? I haven't looked thru the bug postings, maybe something similar has been reported.

Anyway, thanks for trying with these things, it is much appreciated.

Cheers,
Singtoh

Cubic PPA (cubic-wizard) said : #5

There is nothing special or different between Cubic and other windows in Gnome shell.
The modifier key and mouse click should work to move the window, just as any other window.

Make sure Cubic is in windowed mode (not maximized) when you try to move it with the modifier key.

Also double check what your your modifier key is:
    gsettings get org.gnome.desktop.wm.preferences mouse-button-modifier

Regarding the "Generate the customized disk image", you can see log output if you run cubic from the command-line. (Just type "cubic" and press enter). If there is an error during the generate step, it should print something that would be helpful to debug what is going on.

The most common cause I have seen is people running Cubic in a virtual machine without enough disk space. You need around ~20GB free to keep all of the flies Cubic needs.

You can copy and paste the output here from runing Cubic from the command-line, and I can look to see if there is any relevant error.

Can you help with this problem?

Provide an answer of your own, or ask Singtoh for more information if necessary.

To post a message you must log in.