apt update & upgrade in chroot but still get prompt after install that updates are available

Asked by Casey on 2019-05-10

In the chroot environment, I do "apt update" and "apt upgrade" before building my ISO. When I install the custom ISO, almost immediately after login on first boot, it prompts with "Updated software has been issued since Ubuntu 18.04 was released. Do you want to install it now?" (even with network disconnected). It wants to update Ubuntu base. How do I properly upgrade during the customization process to avoid this on first boot? My Cubic build environment is Ubuntu 18.04 Desktop and that's also the ISO I am customizing. Thanks!

Question information

Language:
English Edit question
Status:
Solved
For:
Cubic Edit question
Assignee:
No assignee Edit question
Solved by:
Casey
Solved:
2019-05-23
Last query:
2019-05-23
Last reply:
2019-05-17
Cubic PPA (cubic-wizard) said : #1

Let's see what Ubuntu thinks needs to be updated.
Boot to the customized ISO and open a terminal.

What is the output of...
$ sudo apt update
$ apt list --upgradable

Casey (gagnorak) said : #2

Hello! Here's the information you requested. Thanks!

orchid@ubuntu:~$ sudo apt update
[sudo] password for orchid:
Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease
Get:2 http://us.archive.ubuntu.com/ubuntu bionic InRelease [242 kB]
Get:3 http://dl.google.com/linux/chrome/deb stable Release [943 B]
Get:4 http://security.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB]
Get:5 http://dl.google.com/linux/chrome/deb stable Release.gpg [819 B]
Get:6 http://dl.google.com/linux/chrome/deb stable/main amd64 Packages [1,104 B]
Get:7 http://us.archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]
Get:8 http://us.archive.ubuntu.com/ubuntu bionic-backports InRelease [74.6 kB]
Get:9 http://us.archive.ubuntu.com/ubuntu bionic/main i386 Packages [1,007 kB]
Get:10 http://us.archive.ubuntu.com/ubuntu bionic/main amd64 Packages [1,019 kB]
Get:11 http://us.archive.ubuntu.com/ubuntu bionic/main Translation-en [516 kB]
Get:12 http://us.archive.ubuntu.com/ubuntu bionic/main amd64 DEP-11 Metadata [477 kB]
Get:13 http://us.archive.ubuntu.com/ubuntu bionic/main DEP-11 48x48 Icons [118 kB]
Get:14 http://us.archive.ubuntu.com/ubuntu bionic/main DEP-11 64x64 Icons [245 kB]
Get:15 http://us.archive.ubuntu.com/ubuntu bionic/restricted i386 Packages [9,156 B]
Get:16 http://us.archive.ubuntu.com/ubuntu bionic/restricted amd64 Packages [9,184 B]
Get:17 http://us.archive.ubuntu.com/ubuntu bionic/restricted Translation-en [3,584 B]
Get:18 http://us.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages [8,570 kB]
Get:19 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages [334 kB]
Get:20 http://us.archive.ubuntu.com/ubuntu bionic/universe i386 Packages [8,531 kB]
Get:21 http://us.archive.ubuntu.com/ubuntu bionic/universe Translation-en [4,941 kB]
Get:22 http://us.archive.ubuntu.com/ubuntu bionic/universe amd64 DEP-11 Metadata [3,287 kB]
Get:23 http://us.archive.ubuntu.com/ubuntu bionic/universe DEP-11 48x48 Icons [2,151 kB]
Get:24 http://us.archive.ubuntu.com/ubuntu bionic/universe DEP-11 64x64 Icons [8,420 kB]
Get:25 http://security.ubuntu.com/ubuntu bionic-security/main i386 Packages [255 kB]
Get:26 http://us.archive.ubuntu.com/ubuntu bionic/multiverse i386 Packages [144 kB]
Get:27 http://us.archive.ubuntu.com/ubuntu bionic/multiverse amd64 Packages [151 kB]
Get:28 http://us.archive.ubuntu.com/ubuntu bionic/multiverse Translation-en [108 kB]
Get:29 http://us.archive.ubuntu.com/ubuntu bionic/multiverse amd64 DEP-11 Metadata [49.7 kB]
Get:30 http://us.archive.ubuntu.com/ubuntu bionic/multiverse DEP-11 48x48 Icons [8,931 B]
Get:31 http://us.archive.ubuntu.com/ubuntu bionic/multiverse DEP-11 64x64 Icons [225 kB]
Get:32 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages [599 kB]
Get:33 http://us.archive.ubuntu.com/ubuntu bionic-updates/main i386 Packages [506 kB]
Get:34 http://us.archive.ubuntu.com/ubuntu bionic-updates/main Translation-en [221 kB]
Get:35 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 DEP-11 Metadata [276 kB]
Get:36 http://us.archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 48x48 Icons [66.7 kB]
Get:37 http://us.archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 64x64 Icons [123 kB]
Get:38 http://us.archive.ubuntu.com/ubuntu bionic-updates/restricted i386 Packages [6,960 B]
Get:39 http://us.archive.ubuntu.com/ubuntu bionic-updates/restricted amd64 Packages [6,996 B]
Get:40 http://us.archive.ubuntu.com/ubuntu bionic-updates/restricted Translation-en [3,076 B]
Get:41 http://us.archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages [933 kB]
Get:42 http://us.archive.ubuntu.com/ubuntu bionic-updates/universe i386 Packages [922 kB]
Get:43 http://us.archive.ubuntu.com/ubuntu bionic-updates/universe Translation-en [273 kB]
Get:44 http://us.archive.ubuntu.com/ubuntu bionic-updates/universe amd64 DEP-11 Metadata [227 kB]
Get:45 http://us.archive.ubuntu.com/ubuntu bionic-updates/universe DEP-11 48x48 Icons [193 kB]
Get:46 http://us.archive.ubuntu.com/ubuntu bionic-updates/universe DEP-11 64x64 Icons [396 kB]
Get:47 http://us.archive.ubuntu.com/ubuntu bionic-updates/multiverse amd64 Packages [6,636 B]
Get:48 http://us.archive.ubuntu.com/ubuntu bionic-updates/multiverse i386 Packages [6,784 B]
Get:49 http://us.archive.ubuntu.com/ubuntu bionic-updates/multiverse Translation-en [3,556 B]
Get:50 http://us.archive.ubuntu.com/ubuntu bionic-updates/multiverse amd64 DEP-11 Metadata [2,468 B]
Get:51 http://us.archive.ubuntu.com/ubuntu bionic-updates/multiverse DEP-11 48x48 Icons [29 B]
Get:52 http://us.archive.ubuntu.com/ubuntu bionic-updates/multiverse DEP-11 64x64 Icons [2,638 B]
Get:53 http://us.archive.ubuntu.com/ubuntu bionic-backports/main amd64 Packages [1,024 B]
Get:54 http://us.archive.ubuntu.com/ubuntu bionic-backports/main i386 Packages [1,024 B]
Get:55 http://security.ubuntu.com/ubuntu bionic-security/main Translation-en [120 kB]
Get:56 http://us.archive.ubuntu.com/ubuntu bionic-backports/main Translation-en [448 B]
Get:57 http://us.archive.ubuntu.com/ubuntu bionic-backports/universe i386 Packages [3,492 B]
Get:58 http://us.archive.ubuntu.com/ubuntu bionic-backports/universe amd64 Packages [3,492 B]
Get:59 http://us.archive.ubuntu.com/ubuntu bionic-backports/universe Translation-en [1,604 B]
Get:60 http://us.archive.ubuntu.com/ubuntu bionic-backports/universe amd64 DEP-11 Metadata [7,156 B]
Get:61 http://us.archive.ubuntu.com/ubuntu bionic-backports/universe DEP-11 48x48 Icons [29 B]
Get:62 http://us.archive.ubuntu.com/ubuntu bionic-backports/universe DEP-11 64x64 Icons [29 B]
Get:63 http://security.ubuntu.com/ubuntu bionic-security/main amd64 DEP-11 Metadata [14.9 kB]
Get:64 http://security.ubuntu.com/ubuntu bionic-security/restricted amd64 Packages [4,296 B]
Get:65 http://security.ubuntu.com/ubuntu bionic-security/restricted i386 Packages [4,280 B]
Get:66 http://security.ubuntu.com/ubuntu bionic-security/restricted Translation-en [2,192 B]
Get:67 http://security.ubuntu.com/ubuntu bionic-security/universe i386 Packages [239 kB]
Get:68 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages [243 kB]
Get:69 http://security.ubuntu.com/ubuntu bionic-security/universe Translation-en [139 kB]
Get:70 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 DEP-11 Metadata [35.8 kB]
Get:71 http://security.ubuntu.com/ubuntu bionic-security/universe DEP-11 48x48 Icons [16.4 kB]
Get:72 http://security.ubuntu.com/ubuntu bionic-security/universe DEP-11 64x64 Icons [92.5 kB]
Get:73 http://security.ubuntu.com/ubuntu bionic-security/multiverse i386 Packages [4,148 B]
Get:74 http://security.ubuntu.com/ubuntu bionic-security/multiverse amd64 DEP-11 Metadata [2,464 B]
Fetched 46.8 MB in 5s (9,321 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
51 packages can be upgraded. Run 'apt list --upgradable' to see them.
orchid@ubuntu:~$ apt list --upgradable
Listing... Done
busybox-static/bionic-updates,bionic-security 1:1.27.2-2ubuntu3.2 amd64 [upgradable from: 1:1.27.2-2ubuntu3]
console-setup/bionic-updates,bionic-updates 1.178ubuntu2.9 all [upgradable from: 1.178ubuntu2.8]
console-setup-linux/bionic-updates,bionic-updates 1.178ubuntu2.9 all [upgradable from: 1.178ubuntu2.8]
cups-browsed/bionic-updates,bionic-security 1.20.2-0ubuntu3.1 amd64 [upgradable from: 1.20.2-0ubuntu3]
cups-filters/bionic-updates,bionic-security 1.20.2-0ubuntu3.1 amd64 [upgradable from: 1.20.2-0ubuntu3]
cups-filters-core-drivers/bionic-updates,bionic-security 1.20.2-0ubuntu3.1 amd64 [upgradable from: 1.20.2-0ubuntu3]
distro-info-data/bionic-updates,bionic-updates,bionic-security,bionic-security 0.37ubuntu0.5 all [upgradable from: 0.37ubuntu0.4]
firefox/bionic-updates,bionic-security 66.0.5+build1-0ubuntu0.18.04.1 amd64 [upgradable from: 66.0.3+build1-0ubuntu0.18.04.1]
firefox-locale-en/bionic-updates,bionic-security 66.0.5+build1-0ubuntu0.18.04.1 amd64 [upgradable from: 66.0.3+build1-0ubuntu0.18.04.1]
firefox-locale-fr/bionic-updates,bionic-security 66.0.5+build1-0ubuntu0.18.04.1 amd64 [upgradable from: 66.0.3+build1-0ubuntu0.18.04.1]
ghostscript/bionic-updates,bionic-security 9.26~dfsg+0-0ubuntu0.18.04.9 amd64 [upgradable from: 9.26~dfsg+0-0ubuntu0.18.04.8]
ghostscript-x/bionic-updates,bionic-security 9.26~dfsg+0-0ubuntu0.18.04.9 amd64 [upgradable from: 9.26~dfsg+0-0ubuntu0.18.04.8]
gir1.2-nm-1.0/bionic-updates 1.10.14-0ubuntu2 amd64 [upgradable from: 1.10.6-2ubuntu1.1]
gnome-shell/bionic-updates,bionic-security 3.28.3+git20190124-0ubuntu18.04.2 amd64 [upgradable from: 3.28.3+git20190124-0ubuntu18.04.1]
gnome-shell-common/bionic-updates,bionic-updates,bionic-security,bionic-security 3.28.3+git20190124-0ubuntu18.04.2 all [upgradable from: 3.28.3+git20190124-0ubuntu18.04.1]
gnome-software/bionic-updates 3.28.1-0ubuntu4.18.04.10 amd64 [upgradable from: 3.28.1-0ubuntu4.18.04.9]
gnome-software-common/bionic-updates,bionic-updates 3.28.1-0ubuntu4.18.04.10 all [upgradable from: 3.28.1-0ubuntu4.18.04.9]
gnome-software-plugin-snap/bionic-updates 3.28.1-0ubuntu4.18.04.10 amd64 [upgradable from: 3.28.1-0ubuntu4.18.04.9]
grub-common/bionic-updates 2.02-2ubuntu8.13 amd64 [upgradable from: 2.02-2ubuntu8.12]
grub-pc/bionic-updates 2.02-2ubuntu8.13 amd64 [upgradable from: 2.02-2ubuntu8.12]
grub-pc-bin/bionic-updates 2.02-2ubuntu8.13 amd64 [upgradable from: 2.02-2ubuntu8.12]
grub2-common/bionic-updates 2.02-2ubuntu8.13 amd64 [upgradable from: 2.02-2ubuntu8.12]
isc-dhcp-client/bionic-updates,bionic-security 4.3.5-3ubuntu7.1 amd64 [upgradable from: 4.3.5-3ubuntu7]
isc-dhcp-common/bionic-updates,bionic-security 4.3.5-3ubuntu7.1 amd64 [upgradable from: 4.3.5-3ubuntu7]
keyboard-configuration/bionic-updates,bionic-updates 1.178ubuntu2.9 all [upgradable from: 1.178ubuntu2.8]
libavcodec57/bionic-updates,bionic-security 7:3.4.6-0ubuntu0.18.04.1 amd64 [upgradable from: 7:3.4.4-0ubuntu0.18.04.1]
libavformat57/bionic-updates,bionic-security 7:3.4.6-0ubuntu0.18.04.1 amd64 [upgradable from: 7:3.4.4-0ubuntu0.18.04.1]
libavresample3/bionic-updates,bionic-security 7:3.4.6-0ubuntu0.18.04.1 amd64 [upgradable from: 7:3.4.4-0ubuntu0.18.04.1]
libavutil55/bionic-updates,bionic-security 7:3.4.6-0ubuntu0.18.04.1 amd64 [upgradable from: 7:3.4.4-0ubuntu0.18.04.1]
libcupsfilters1/bionic-updates,bionic-security 1.20.2-0ubuntu3.1 amd64 [upgradable from: 1.20.2-0ubuntu3]
libfontembed1/bionic-updates,bionic-security 1.20.2-0ubuntu3.1 amd64 [upgradable from: 1.20.2-0ubuntu3]
libgs9/bionic-updates,bionic-security 9.26~dfsg+0-0ubuntu0.18.04.9 amd64 [upgradable from: 9.26~dfsg+0-0ubuntu0.18.04.8]
libgs9-common/bionic-updates,bionic-updates,bionic-security,bionic-security 9.26~dfsg+0-0ubuntu0.18.04.9 all [upgradable from: 9.26~dfsg+0-0ubuntu0.18.04.8]
libnm0/bionic-updates 1.10.14-0ubuntu2 amd64 [upgradable from: 1.10.6-2ubuntu1.1]
libpostproc54/bionic-updates,bionic-security 7:3.4.6-0ubuntu0.18.04.1 amd64 [upgradable from: 7:3.4.4-0ubuntu0.18.04.1]
libswresample2/bionic-updates,bionic-security 7:3.4.6-0ubuntu0.18.04.1 amd64 [upgradable from: 7:3.4.4-0ubuntu0.18.04.1]
libswscale4/bionic-updates,bionic-security 7:3.4.6-0ubuntu0.18.04.1 amd64 [upgradable from: 7:3.4.4-0ubuntu0.18.04.1]
linux-firmware/bionic-updates,bionic-updates 1.173.5 all [upgradable from: 1.173.3]
linux-generic/bionic-updates 4.15.0.48.50 amd64 [upgradable from: 4.15.0.45.47]
linux-headers-generic/bionic-updates 4.15.0.48.50 amd64 [upgradable from: 4.15.0.45.47]
linux-image-generic/bionic-updates 4.15.0.48.50 amd64 [upgradable from: 4.15.0.45.47]
netplan.io/bionic-updates 0.96-0ubuntu0.18.04.4 amd64 [upgradable from: 0.40.1~18.04.4]
network-manager/bionic-updates 1.10.14-0ubuntu2 amd64 [upgradable from: 1.10.6-2ubuntu1.1]
network-manager-config-connectivity-ubuntu/bionic-updates,bionic-updates 1.10.14-0ubuntu2 all [upgradable from: 1.10.6-2ubuntu1.1]
nplan/bionic-updates,bionic-updates 0.96-0ubuntu0.18.04.4 all [upgradable from: 0.40.1~18.04.4]
ubuntu-software/bionic-updates,bionic-updates 3.28.1-0ubuntu4.18.04.10 all [upgradable from: 3.28.1-0ubuntu4.18.04.9]
ubuntu-standard/bionic-updates 1.417.1 amd64 [upgradable from: 1.417]
ufw/bionic-updates,bionic-updates 0.36-0ubuntu0.18.04.1 all [upgradable from: 0.35-5]
unattended-upgrades/bionic-updates,bionic-updates 1.1ubuntu1.18.04.11 all [upgradable from: 1.1ubuntu1.18.04.10]
ureadahead/bionic-updates 0.100.0-21 amd64 [upgradable from: 0.100.0-20]
wpasupplicant/bionic-updates,bionic-security 2:2.6-15ubuntu2.3 amd64 [upgradable from: 2:2.6-15ubuntu2.2]
orchid@ubuntu:~$

Casey (gagnorak) said : #3

Please ignore last post. I just realized I hopped on the wrong IP. Here's the correct information requested. Thanks!

busybox-static/bionic-updates,bionic-security 1:1.27.2-2ubuntu3.2 amd64 [upgradable from: 1:1.27.2-2ubuntu3]
grub-common/bionic-updates 2.02-2ubuntu8.13 amd64 [upgradable from: 2.02-2ubuntu8.12]
grub-pc/bionic-updates 2.02-2ubuntu8.13 amd64 [upgradable from: 2.02-2ubuntu8.12]
grub-pc-bin/bionic-updates 2.02-2ubuntu8.13 amd64 [upgradable from: 2.02-2ubuntu8.12]
grub2-common/bionic-updates 2.02-2ubuntu8.13 amd64 [upgradable from: 2.02-2ubuntu8.12]
linux-firmware/bionic-updates,bionic-updates 1.173.5 all [upgradable from: 1.173.3]
linux-generic/bionic-updates 4.15.0.48.50 amd64 [upgradable from: 4.15.0.45.47]
linux-headers-generic/bionic-updates 4.15.0.48.50 amd64 [upgradable from: 4.15.0.45.47]
linux-image-generic/bionic-updates 4.15.0.48.50 amd64 [upgradable from: 4.15.0.45.47]
ubuntu-standard/bionic-updates 1.417.1 amd64 [upgradable from: 1.417]
ufw/bionic-updates,bionic-updates 0.36-0ubuntu0.18.04.1 all [upgradable from: 0.35-5]
ureadahead/bionic-updates 0.100.0-21 amd64 [upgradable from: 0.100.0-20]

Cubic PPA (cubic-wizard) said : #4

Thanks, so there are not a lot of packages remaining to be updated.

YOu mentioned that you are starting out with 18.04 ISO.

We know their are three point releases for 18.04 (See http://old-releases.ubuntu.com/releases/ and https://www.ubuntu.com/download/desktop)...
    18.04.0
    18.04.1
    18.04.2

This is a hunch, but I wonder if `apt upgrade` wants you to step through all of the updates for each point release sequentially. In other words, upgrade to all of the packages for 18.04.1 from 18.04.0, then upgrade to all of the packages for 18.04.2 from 18.04.1? At that point apt will consider your 18.04 up-to-date.

What happens inside Cubic's chroot terminal if you do?...
    apt update
    apt upgrade
    apt update

After the second `apt update`, does apt notify you that "packages can be upgraded" or does it just say all packages are up to date?

Casey (gagnorak) said : #5

Sorry, my fault for not specifying the full version. I am using the 18.04.2 ISO (server version).

# apt update
Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:2 http://dl.google.com/linux/chrome/deb stable Release
Hit:3 http://security.ubuntu.com/ubuntu bionic-security InRelease
Hit:4 http://archive.ubuntu.com/ubuntu bionic InRelease
Hit:5 http://archive.ubuntu.com/ubuntu bionic-updates InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.

Thanks!

Cubic PPA (cubic-wizard) said : #6

I had the same result...

I downloaded ubuntu-18.04.2-live-server-amd64.iso.
I executed `apt update` in Cubic and the executed `apt upgrade`.
It updated 101 packages.
Afterwards, if I execute `apt update`, I get the message "All packages are up to date."

However, I checked what versions of packages were installed, using the list you provided in Comment #3.

I was surprised to see that only four packages were installed. The others were missing.
All four packages that were installed had the correct version (so they should not require updating at all)!

# dpkg-query --showformat='${Package;-22}${Version}\n' --show busybox-static grub2-common grub-common grub-pc grub-pc-bin linux-firmware linux-generic linux-headers-generic linux-image-generic ubuntu-standard ufw ureadahead

busybox-static 1:1.27.2-2ubuntu3.2
ubuntu-standard 1.417.1
ufw 0.36-0ubuntu0.18.04.1
ureadahead 0.100.0-21
dpkg-query: no packages found matching grub2-common
dpkg-query: no packages found matching grub-common
dpkg-query: no packages found matching grub-pc
dpkg-query: no packages found matching grub-pc-bin
dpkg-query: no packages found matching linux-firmware
dpkg-query: no packages found matching linux-generic
dpkg-query: no packages found matching linux-headers-generic
dpkg-query: no packages found matching linux-image-generic

Cubic PPA (cubic-wizard) said : #7

If you open ubuntu-18.04.2-live-server-amd64.iso using Archive Mounter (or similar extraction tool), you will notice the following structure:
.
├── boot
├── casper
├── dists
├── EFI
├── install
├── isolinux
├── md5sum.txt
├── pics
├── pool
├── preseed
├── README.diskdefines
└── ubuntu -> .

The pool directory contains packages that the installer uses. I think these packages are used if you choose not to download packages while installing, or if you do not have a network connection.

Cubic PPA (cubic-wizard) said : #8

In your case, it looks like the packages that need to be upgraded are available in the pool directory...

$ cd .../pool/main

$ find . -name busybox-static* -or -name grub2-common* -or -name grub-common* -or -name grub-pc* -or -name grub-pc-bin* -or -name linux-firmware* -or -name linux-generic* -or -name linux-headers-generic* -or -name linux-image-generic* -or -name ubuntu-standard* -or -name ufw* -or -name ureadahead*
./g/grub2/grub2-common_2.02-2ubuntu8.12_amd64.deb
./g/grub2/grub-common_2.02-2ubuntu8.12_amd64.deb
./g/grub2/grub-pc_2.02-2ubuntu8.12_amd64.deb
./g/grub2/grub-pc-bin_2.02-2ubuntu8.12_amd64.deb
./l/linux-firmware/linux-firmware_1.173.3_all.deb
./l/linux-meta/linux-generic_4.15.0.45.47_amd64.deb
./l/linux-meta/linux-headers-generic_4.15.0.45.47_amd64.deb
./l/linux-meta/linux-image-generic_4.15.0.45.47_amd64.deb
./l/linux-meta-hwe/linux-generic-hwe-18.04_4.18.0.15.65_amd64.deb
./l/linux-meta-hwe/linux-headers-generic-hwe-18.04_4.18.0.15.65_amd64.deb
./l/linux-meta-hwe/linux-image-generic-hwe-18.04_4.18.0.15.65_amd64.deb

Cubic PPA (cubic-wizard) said : #9

Oops, my `find` command listed a few more packages than i wanted it to...

Here is a better list with superfluous packages removed...

./g/grub2/grub2-common_2.02-2ubuntu8.12_amd64.deb
./g/grub2/grub-common_2.02-2ubuntu8.12_amd64.deb
./g/grub2/grub-pc_2.02-2ubuntu8.12_amd64.deb
./g/grub2/grub-pc-bin_2.02-2ubuntu8.12_amd64.deb
./l/linux-firmware/linux-firmware_1.173.3_all.deb
./l/linux-meta/linux-generic_4.15.0.45.47_amd64.deb
./l/linux-meta/linux-headers-generic_4.15.0.45.47_amd64.deb
./l/linux-meta/linux-image-generic_4.15.0.45.47_amd64.deb

Cubic PPA (cubic-wizard) said : #10

You can see that the packages in the pool directory are outdated.

For example, after your install, apt is telling you that the package

    linux-generic

can be upgraded from version

    4.15.0.45.47

to version

    4.15.0.48.50

(But version 4.15.0.45.47 is what was in the pool directory).

Cubic PPA (cubic-wizard) said : #11

So why did the installer install these packages from the pool directory?

Honestly, I'm not sure.

I checked the preseed files and didn't see any references to these packages.

The installer may be doing it, or these packages may be required in some way during the installation process.

Cubic doesn't currently allow you to change the contents of the /pool directory, although this is something I would like to add in the future.

Cubic PPA (cubic-wizard) said : #12

I can suggest two possible remedies for this situation...

(1)
Simply install these packages in choot, so the installer doesn't need to install the outdated versions from the /pool directory on the "Live CD".

$ apt install busybox-static grub2-common grub-common grub-pc grub-pc-bin linux-firmware linux-generic linux-headers-generic linux-image-generic ubuntu-standard ufw ureadahead

(2)
You could try to replace the outdated *.deb files in the /pool directory manually.

BEFORE you click the "Generate" button on Cubic's Options Page, do the following on your host computer...

Download the newest versions of the *deb files for the packages you listed in Comment #3.
Place these files in the appropriate sub-directories under...
    <Your Cubic Project Location>/custom-live-iso/pool

If you chose to try this option, please let me know if it worked?

Casey (gagnorak) said : #13

I tried option 1 but now I get a kernel panic during install, very early on. I'm assuming something to do with the grub installs. I tried to remove all newly installed packages but I still get the panic. I'm going to create a new Cubic instance and use option 2. Thanks for the help!!

Cubic PPA (cubic-wizard) said : #14

Casey,

Please make sure you are using the latest version of Cubic.

Cubic selects the newest kernel to bootstrap the ISO.

This causes BusyBox in Ubuntu Server 18.04.0, but ~seems~ to work fine in Ubuntu Server 18.04.2.

The original bootstrap kernel (from the original ISO) is at the bottom of the list on the "ISO Boot Kernels" on the Options page. This is not selected by default, but you might have better luck if you select this. If you do this, Option 1 from Comment 12 should work for you.

Cubic PPA (cubic-wizard) said : #15

One more question..

Do you know which version of Cubic you were running when you encountered the BusyBox?

(The latest release is 2019.05-55-release).

Casey (gagnorak) said : #16

Thanks, I'll give that a shot! It looks like I was running 2019.04-54.

Cubic PPA (cubic-wizard) said : #17

OK. Let me know how it goes.

Also, the latest version is now 2019.05-56-release.

Casey (gagnorak) said : #18

I just upgraded to 56. I will let you know as soon as I can. I was making other customizations, in addition to your suggestions, and I'm not sure what I did but the install now hangs near the end. On TTY4 it's looping through a bunch of messages about falling back to package description XXX, where XXX is the name of different packages. There is a warning message 'internal error! "cannot find debian-installer/main-menu doesn't exist" in menu'.

Casey (gagnorak) said : #19

After creating a new instance and following your advice on the additional packages as well as selecting the older boot kernel, all is well. Thanks so much! This tool is awesome!

Cubic PPA (cubic-wizard) said : #20

Glad it worked, and Thanks! :-)