filesystem.manifest

Asked by Adam Lewis on 2018-08-31

What I'm trying to do is copy filesystem.manifest from the "server" install to the /casper directory on the ISO that cubic is making. I think what's happening is that cubic is doing a dpkg --list (or something) and appending that to the filesystem.manifest. I could be wrong.

Either way, what I want to wind up with is the filesystem.manifest that I copied from the "server" ISO's casper directory untouched on my ISO that cubic makes.

What is the easiest way to do that?

Thank you,

Adam

Question information

Language:
English Edit question
Status:
Solved
For:
Cubic Edit question
Assignee:
No assignee Edit question
Solved by:
Cubic PPA
Solved:
2018-09-07
Last query:
2018-09-07
Last reply:
2018-09-02
Best Cubic PPA (cubic-wizard) said : #1

Cubic generates a new filesystem.manifest file from the installed packages in your chroot environment.
It should not appending anything. (Do you see duplicate entries in the generated filesystem.manifest file?)

I'm not sure why you would want the file to have different contents than the packages you've installed into your chroot environment, but you could try the following...

1)
Navigate to the Manage Options Page. (This is the page where you see tabs for Kernels and Manifest files).

2)
On the Manifest tab, make sure you un-check any packages you do ~not~ want to be automatically removed.

3)
Before you click the "Next" button, manually copy your version of filesystem.manifest to
<your cubic project directory>/custom-live-iso/casper

(Of course, you will need to do this outside Cubic, using sudo).

This will overwrite Cubic's generated version of filesystem.manifest with your version.

4)
Then click the Next button.

Note that the filesystem.manifest-remove and the filesystem.manifest-minimal-remove files will still be automatically generated from your selections in step 3 above. (There may be some inconsistencies with the "remove" files and the "manifest" file, since you replaced Cubic's "manifest" file, and I don't know what the consequences of that would be).

However, the filesystem.manifest file you had manually copied should be included in the new iso.

Adam Lewis (adam525) said : #2

Thanks Cubic PPA, that solved my question.