Sprites from PNG pack discard existing transparency

Asked by Lisandro_Wixi on 2008-11-24

I think this is the same problem on #247554.

Images are properly arranged, but the transparency in the original PNG images is discarded. A new white background appears now.

I tried several configurations, in particular background color properties, to no avail.

This is a sample config:

Ignore duplicates: YES
Size: 100% x 100%
Keep aspect: YES
Offset: 4px, 4px
Wrapped columns: YES
Background / Transparency Colour: NONE
Use Background Colour for Transparency: NO
Output: PNG
Colours: True-colour
Compress with OptiPNG: NO

And here are the files:

input: http://martin.malditainternet.com/file_types.zip

output: http://martin.malditainternet.com/csg-492b09a42fc06.png

Will really appreciate if you find a solution to this one.
Thanks a lot,

Lisandro Mc Gough

Question information

English Edit question
CSS Sprite Generator Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Lisandro_Wixi (developers-wixi) said :

This issue appears to be GD2-specific, as running a local copy of your service in a imagick-enabled Debian host yields appropriate results.

Revision history for this message
Launchpad Janitor (janitor) said :

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Revision history for this message
Stuart Colville (muffinresearch) said :

We're not likely to provide further support to the GD fallback - seems like you've found a workaround at least so marking this as answered.

Revision history for this message
PascalKHH (pascal-hh) said :

I had the same problem, but the solution is very easy for me: I only had install imagemagick ... This was not enought...

If you have the same Problem: You must install php5-imagick, too...

With Debain and Ubuntuserver: sudo apt-get install imagemagick php5-imagick optipng

Great tool! Thanks for your work!

Can you help with this problem?

Provide an answer of your own, or ask Lisandro_Wixi for more information if necessary.

To post a message you must log in.