.py files won't execute

Asked by GhoS on 2010-01-03

Admittedly not that well versed in Linux, but I can't seem to get the .py files to run. They are checked as "run as executable" but nothing happens. I've checked and the !# etc is at the beginning of the file. I didn't install Gloobus Preview but nothing I could find says you have to have it installed. I can't get the command ./autogen.sh to work as I think I have it installed/compiled but nothing works.
Unfortunately this program isn't designed with Linux newbies in mind.

Thanks for your reply.

Question information

English Edit question
CoverGloobus Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:

This question was reopened

  • 2010-01-09 by GhoS
Alexandr Grigorcea (cahr-gr) said : #1

covergloobus.py and covergloobus-config.py will not run without installation, they require some files that are generated during installation

to install try running from command line:
cd path/to/covergllobus/
./autogen.sh --prefix=/usr
sudo make install

and then to run CoverGloobus run command


from where you like it ( command line or Alt+F2 )

GhoS (ghos64) said : #2

Thank you for the reply.
Ok here is what I get when I do that, so perhaps this helps.

wayne@wayne-desktop:~/covergloobus$ ./autogen.sh --prefix=/usr
./autogen.sh: line 3: aclocal: command not found
./autogen.sh: line 4: autoconf: command not found
./autogen.sh: line 5: automake: command not found
Running configure with arguments -prefix=/usr
./autogen.sh: line 7: ./configure: No such file or directory

Alexandr Grigorcea (cahr-gr) said : #3

you need automake and autoconf installed
I suppose you are an ubuntu user
so run from command line:

sudo apt-get install build-essential

sudo apt-get install automake

then try again ./autogen.sh .....
more info here:

Alexandr Grigorcea (cahr-gr) said : #4

to install autoconf run:
sudo apt-get install autoconf

GhoS (ghos64) said : #5

Thanks Alexandr Grigorcea, that solved my question.

GhoS (ghos64) said : #6

Ah ha didn't realize I was missing all that. I am using a variation on Ubuntu - Linux Mint.
However on first run I had no problem getting into the config and making changes. However after changing the skin it froze, not only that after I quit it and ran it again it freezes my whole computer. It also has reverted back to the skin it starts with, but I can't do anything, the computer is frozen. The mouse works, but I can't click on anything. The keys don't seem to make anything work either. Its very strange.

So now the program is compiled, but it freezes my pc up when I run it.

GhoS (ghos64) said : #7

I just seen another post about the docky option creating a crash, I bet that is why since I had checked that. I'll check that post for a fix.

GhoS (ghos64) said : #8

Ok found the answer.