Rating not working

Asked by raamee on 2011-09-11

Hi,

I installed cover gloobus through bzr. It all went nice, but the ratings not work.

Here's my debug info:

raamee@raamee-workstation ~ $ covergloobus --debug
[DEBUG] Installed themes:
   * /usr/share/covergloobus/themes/Postcard2
   * /usr/share/covergloobus/themes/corner
   * /usr/share/covergloobus/themes/Coversutra
   * /usr/share/covergloobus/themes/Postcard
   * /usr/share/covergloobus/themes/iSticky
   * /usr/share/covergloobus/themes/Polaroid
   * /usr/share/covergloobus/themes/45Controls
   * /usr/share/covergloobus/themes/Dirty
   * /usr/share/covergloobus/themes/BoxOfTricks
   * /usr/share/covergloobus/themes/LucidDark
   * /usr/share/covergloobus/themes/Vinyl
   * /usr/share/covergloobus/themes/BadChoice3
   * /usr/share/covergloobus/themes/BoxOfTricksMod
   * /usr/share/covergloobus/themes/Ibex
   * /usr/share/covergloobus/themes/simple
   * /usr/share/covergloobus/themes/BadChoice
   * /usr/share/covergloobus/themes/BadChoice2
   * /usr/share/covergloobus/themes/ToolTip
   * /home/raamee/.CoverGloobus/themes/Teac mini
   * /home/raamee/.CoverGloobus/themes/Teac extra small
   * /home/raamee/.CoverGloobus/themes/Teac X-2000R silver
   * /home/raamee/.CoverGloobus/themes/Teac X-2000R black
[DEBUG] Installed players:
   * Amarok2
   * Audacious2
   * Banshee
   * BeatBox
   * Clementine
   * DeaDBeeF
   * Decibel
   * Exaile
   * Exaile3
   * Exaile3MPRIS
   * gmusicbrowser
   * Grooveshark
   * Guayadeque
   * Listen
   * MOC
   * MPD
   * Pithos
   * Pogo
   * QuodLibet
   * Rhythmbox
   * Songbird
   * Spotify
   * Totem
   * VLC
   * Xmms2client
[DEBUG] Prefix: /usr/
[DEBUG] ABS_PATH: /usr/share/covergloobus
[DEBUG] Initializing dbus
Traceback (most recent call last):
  File "/usr/share/covergloobus/ui.py", line 228, in expose_event
    self.draw_nice_background(cr, self.width, self.height)
AttributeError: 'CoverGloobusUI' object has no attribute 'width'
[DEBUG] LYRICS: init done
[DEBUG] COVERSEARCH: loading engine Location
[DEBUG] COVERSEARCH: loading engine Amazon
[DEBUG] Loading player
[DEBUG] Connecting player
[DEBUG] Player loaded: Clementine
[DEBUG] UI: Theme path: /usr/share/covergloobus/themes/ToolTip
[DEBUG] Showing status icon: True
[DEBUG] Init done

Any help?

Question information

Language:
English Edit question
Status:
Solved
For:
CoverGloobus Edit question
Assignee:
No assignee Edit question
Solved by:
raamee
Solved:
2011-09-11
Last query:
2011-09-11
Last reply:
2011-09-11
Alexandr Grigorcea (cahr-gr) said : #1

you are using Clementine player, it implements MPRIS interface, which does
not specify rating setting, so you can't set rating in CG with Clementine

raamee (thiyadaram) said : #2

Thanks. Yea, I tried with Banshee Player and the rating worked. The problem is with clementine only. Thanks for the answer.