error while installing from bzr

Asked by Wishing Star on 2010-06-28

When i run the command to get covergloobus from bzr:

bzr branch lp:covergloobus

I get the following output in terminal:

You have not informed bzr of your Launchpad ID, and you must do this to
write to Launchpad or access private data. See "bzr help launchpad-login".
bzr: ERROR: Invalid http response for http://bazaar.launchpad.net/~guitarboy000/covergloobus/trunk/.bzr/repository/packs/77d520c446730bab0e19de0804468c7c.pack: Expected a boundary (l)s=8w'gnfngZPc.aC'') line, got ''

then the process aborts, and i can't continue with the next steps, I'm not very linux savvy, so be easy with the responses :)

WishingStar

Question information

Language:
English Edit question
Status:
Solved
For:
CoverGloobus Edit question
Assignee:
No assignee Edit question
Solved by:
Alexandr Grigorcea
Solved:
2010-06-28
Last query:
2010-06-28
Last reply:
2010-06-28
Best Alexandr Grigorcea (cahr-gr) said : #1

its a bug when using http connection, you need to use ssh to avoid this, to use ssh you need to login bzr:
1) do this:
http://wiki.awn-project.org/HowToDevelopWithLaunchpad
( some more info here https://help.launchpad.net/YourAccount/CreatingAnSSHKeyPair)
2) run from terminal:
$ bzr launchpad-login %your_user_name%
you will be asked to enter the passphrase (the one you've entered in step 1)
3) try again :
$ bzr branch lp:covergloobus

Wishing Star (ymajeed) said : #2

Thanks Alexandr Grigorcea, that solved my question.