How to set mood or activity?

Asked by buzzdee on 2009-09-10

I use coccinella from SVN, on OpenBSD 4.5. When I click on the mood or activity icon in the roster, then nothing happens. Do I need sth. special on client or server side? The same problem is on a windows box of a friend. There Coccinella 0.96.10 or so is used. Under the services tab, under online-users, I see for my user, user mood and user activity is listed as the capabilities of the online users. I guess I can see those, because I am a admin user on the server.
The server is my own, ejabberd 2.0.1

cheers
Sebastian

Question information

Language:
English Edit question
Status:
Solved
For:
Coccinella Edit question
Assignee:
No assignee Edit question
Solved by:
sander
Solved:
2009-09-14
Last query:
2009-09-14
Last reply:
2009-09-13
sander (s-devrieze) said : #1

At this moment, you only see the mood and activity in the contact overview balloon text (text that appears when hovering over a contact in the main window). On Mac OS X you also see mood/activity updates using Growl.

buzzdee (sebastia) said : #2

Hi,

thanks for your answer, but I think you maybe got my question wrong. I want to set my own mood and activity. In the bottom of the roster, I can set my avatar. When I hover the mouse over the avatar, then the background color changes and when I click on it, a small menu shows up. When I hover over the mood or activity icons, then nothing happens, also when I click on it.

cheers
Sebastian

Best sander (s-devrieze) said : #3

Do you mean the Mood and Activity icons are disabled (no menu when clicking on it)? If that is true, PEP support may not be enabled in your ejabberd deployment. Can you try with a public deployment like jabber.se (this one is known to work; I just tested it :-) )? If it does not work with jabber.se, you probably are doing something wrong (or there is an OpenBSD-related bug).

buzzdee (sebastia) said : #4

Hi,

this was the right hint, I created an account on jabber.se and both worked. So I checked my server configuration, and I figured out that pep is a plugin to pubsub, which is not enabled by default.
Now it is working there too.

thanks a lot.
Sebastian

buzzdee (sebastia) said : #5

Thanks sander, that solved my question.